Fatal error json.php when trying to export a db [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Fatal error json.php when trying to export a db [SOLVED]

Postby some99 » 20. December 2011 20:46

hi guys,

xampp is driving me craxy :(
i cant export databases on phpmyadmin because i get the following error everytime i click export

Fatal error: Call to undefined function __() in F:\xampp\phpMyAdmin\libraries\export\json.php on line 26

i checked phpinfo and json is enabled.

is there a solution to this ?

thnx!
some99
 
Posts: 6
Joined: 16. September 2011 00:53
Operating System: windows 7 64bit

Re: Fatal error json.php when trying to export a db

Postby Sharley » 20. December 2011 20:49

Would you be so kind as to add your XAMPP version and Operating System to your profile as per these instructions:
viewtopic.php?f=16&t=48626
Thanks. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Fatal error json.php when trying to export a db

Postby some99 » 20. December 2011 20:57

updated! thnx for replying :)

1.7.3
windows 7 64bit
some99
 
Posts: 6
Joined: 16. September 2011 00:53
Operating System: windows 7 64bit

Re: Fatal error json.php when trying to export a db

Postby Sharley » 20. December 2011 21:04

Thanks for that as most things now in XAMPP are version specific. 8)


I am just wondering if phpMyAdmin has been corrupted in some way.

The solution may be to download the zip version of 1.7.3 from here:
SourceForge XAMPP File Repository

Then drag just the export folder from the archive and drop it over the one in your installation, overwriting when asked, so the files are then known to be fresh and try to export again after restarting Apache and MySQL.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Fatal error json.php when trying to export a db

Postby some99 » 20. December 2011 21:20

didn't work :(

btw i noticed that import also doesn't work

Fatal error: Call to undefined function __() in F:\xampp\phpMyAdmin\libraries\import\ods.php on line 22
some99
 
Posts: 6
Joined: 16. September 2011 00:53
Operating System: windows 7 64bit

Re: Fatal error json.php when trying to export a db

Postby Sharley » 20. December 2011 21:38

Well at least we now know it was not a corrupted file and we can move on.

Is this a new XAMPP installation?

If so or you don't mind uninstalling then try a different installation method by following these instructions:
viewtopic.php?p=179699#p179699
You can use the zip file you download previously if you wish.

This method often fixes issues as it is sometimes the installer that plays up with some Windows versions and will be replaced in the next release.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Fatal error json.php when trying to export a db

Postby Sharley » 20. December 2011 21:43

Just to add that if you stop all the xampp components and uninstall any services in the control panel and then exit the control panel there is no need to delete the xampp folder, simply rename it to xampp_old.

Then extract the new xampp folder as described in the instructions.

This way you will still have your older installation to be able to copy over your own files etc. - sort of a sophisticated backup of your older installation.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Fatal error json.php when trying to export a db

Postby some99 » 21. December 2011 00:23

oke, now the export function works again but how do i transfer my website to the new xampp?

i moved htdocs/mysitefolder to the new htdocs folder

and i also moved \xampp_old\mysql\data\mysitename to the new mysql folder

but i get a billion errors when opening the website on localhost, did i mis something?
some99
 
Posts: 6
Joined: 16. September 2011 00:53
Operating System: windows 7 64bit

Re: Fatal error json.php when trying to export a db

Postby Altrea » 21. December 2011 01:22

some99 wrote:but i get a billion errors when opening the website on localhost, did i mis something?

Without knowing the error messages, nobody can know for sure but you.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Fatal error json.php when trying to export a db

Postby Sharley » 21. December 2011 05:05

So did you install a fresh 1.7.3 version or did you install a newer version?

If you installed a newer version of XAMPP then MySQL will also be a newer version and so your database maybe having issues with new MySQL version.

Let me know what version you installed and I may be able to help with your issue.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Fatal error json.php when trying to export a db

Postby some99 » 22. December 2011 00:05

thank you for the help guys, i fixed it! thnx to your assistance! ^^
when i reinstalled xmapp i used a different version than the 1 i had installed.
so i redownloaded the zip of the same version and everything worked like a charm! i can sleep again ^^
some99
 
Posts: 6
Joined: 16. September 2011 00:53
Operating System: windows 7 64bit

Re: Fatal error json.php when trying to export a db

Postby Sharley » 22. December 2011 01:05

Thanks for the feedback and I am pleased you can now move forward. 8)

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests