Help pointing Apache to Coppermine plz?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help pointing Apache to Coppermine plz?

Postby sherifffruitfly » 21. March 2004 23:15

Hi all,

I'm (obviously) new at the web-admin stuff....

I just installed xampp on my winxp machine, and that went without a hitch (well, except for some sort of a jpgraph font problem...).

The reason I installed xampp was because it was recommended for use with the Coppermine image gallery web app.

I've got them both on my machine now, and I just don't know how to tell apache that "localhost" should point to the coppermine stuff, and not the xampp stuff....

I've tried following the coppermine instructions, but I draw a blank when they say "upload your stuff to the server"... help?

Also in those same instructions, #9 at http://coppermine.sourceforge.net/faq.php , it says to point my browser to an install.php file. When I do this, I only get the source code on my screen - the php isn't actually run. I know that PHP is correctly installed and working, since I've seen it work on the default xampp webpage, and the xampp status thingie reports no errors.

I've tried editing the DocumentRoot property in the httpd.conf file, so that it points at coppermine (namely <Directory "C:/cpg1.2.1_standalone/cpg1.2.1_standalone">), but this just game me some sort of an error - i'll post it if anyone's interested.

I'm out of ideas about how to get apache to see coppermine, so that I can complete the coppermine install instructions. Any assistance would be very much appreciated.

thanks,

cdj
sherifffruitfly
 
Posts: 2
Joined: 21. March 2004 22:55

Postby Wiedmann » 21. March 2004 23:40

Copy all Coppermine-files in the directory:
"C:/xampp/htdocs/"

Then you can access the install.php with:
"http://localhost/install.php"

------------------------------------------------------------------------

But i think it is better to install Coppermine in a subdirectory like:
"C:/xampp/htdocs/gallery"

and then access it via:
"http://localhost/gallery/"

With this installation point you must start the installation via the URL:
"http://localhost/gallery/install.php"
Wiedmann
AF Moderator
 
Posts: 17106
Joined: 01. February 2004 12:38
Location: Stuttgart / Germany

will do, but.....

Postby sherifffruitfly » 21. March 2004 23:46

won't that make a mess of the htdocs directory, what with all the xampp default stuff that's in there?

lol - all good tho.....

thanks a bunch for the response.....

cdj

<edit: do you mean literally all the coppermine files - subdirectories and all? or just the 1st level files, all the php files including install.php?>
sherifffruitfly
 
Posts: 2
Joined: 21. March 2004 22:55


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests