problems after migrating Xampp [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

problems after migrating Xampp [SOLVED]

Postby fredmens » 18. December 2011 14:36

Hi There, i write in english, but there is no problem if someone would answer in German english or dutch language.

I am running Xamp for more then 6 years now. Only running HTTP services and FTP, the rest i don't care about. I have a dynamic IP address, but with help of no-ip.com i managed to change my dynamic ip address in a static one.

After 6 years my server was getting very old, so i migrated to a new server/pc with better specs. I just copied the total xamp folder to my new pc, adjusted the ip address, altered my router and went for it.
I started up setup_xampp.bat so all the paths were working again, started up xampp-control.exe to start up the services and hoped i would be ready.

The apache HTTP services and the ftp services start up, but after a few minutes, or when i try to visit my site , apache kills and gives me a pop up the apache services had to close down.

i am running XP pro on a pcwith better specs then my old server I am running a VERY old version of Xamp, 1.5.3a . has anyone have a clue what i could do to fix this?

Could i for instance install a new version of Xamp, and just copy all the content folders into the new install ??

Hope to get a good answer,

Kind regards,

Fred
fredmens
 
Posts: 10
Joined: 18. December 2011 14:08
Operating System: XP pro

Re: problems after migrating Xamp

Postby Sharley » 18. December 2011 23:40

You could install a new version using these instructions:
viewtopic.php?p=179699#p179699

But recommend you simply rename your existing xampp folder, for example xampp_old (or xampp153a) rather than uninstall the older version then extract the new version zip file to the C:\ drive or drive of choice - you must stop and uninstall any services you may have running by removing the ticks in any Svc boxes and making sure that Apache and MySQL are not running and then you can Exit the control panel, in other words your 1.5.3a version must be completely stopped before you can start the new version's components.

You can then copy over your own files and folders from the htdocs folder of your old version to the htdocs folder of your new version - but do not copy over any files or folders of the older version xampp system as they would not be compatible with the new version.

You should first backup any databases you have in the old xampp version using phpMyAdmin to an sql file so you can import them after you have established that your new version is working properly and this also applies before copying your own files, first go to http://localhost and after setting your language and before anything else make sure all the demos work in the Welcome page as outlined in the above install instructions link.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: problems after migrating Xamp

Postby fredmens » 19. December 2011 10:35

Thanks for the tips, i will give it a try

kind regards

Fred
fredmens
 
Posts: 10
Joined: 18. December 2011 14:08
Operating System: XP pro

Re: problems after migrating Xamp

Postby fredmens » 19. December 2011 16:03

Nopes, sorry, that doesn't do the trick.

I installed the newest version of Xamp, and removed the old one. Imported all my folders into the htdocs folder and try to get it running. The FTP client runs ok, but the apache webserver won't come online. If i try to run the batch file it says it can't find the c windows system 32 file to fix.

Any ideas??

Kind regards

Fred
fredmens
 
Posts: 10
Joined: 18. December 2011 14:08
Operating System: XP pro

Re: problems after migrating Xamp

Postby Altrea » 19. December 2011 16:28

Hello fredmens,

Have you installed the Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) Runtime too? Thats a requirement for the current XAMPP version to run.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: problems after migrating Xamp

Postby fredmens » 19. December 2011 17:22

Nopes, didn't do that, another thing to try indeed. Thanx for the tip

Kind regards

Fred
fredmens
 
Posts: 10
Joined: 18. December 2011 14:08
Operating System: XP pro

Re: problems after migrating Xamp

Postby fredmens » 19. December 2011 19:10

Thanx for that last tip. The webserver is running now :) it really needed the microsoft visual basic it seems now.

Now i try to get the ftp server up and running. Xamp asks me for a server to connect to. I recon it means the ip adress of the server (the same the webserver is running in my case. I normally use port 21, but it can't connect, any suggestions ?

Kind regards (again :) )

Fred
fredmens
 
Posts: 10
Joined: 18. December 2011 14:08
Operating System: XP pro

Re: problems after migrating Xamp

Postby Sharley » 20. December 2011 10:05

Please start a new topic for your different issue - only one issue per topic:.
How to posts item 9:
viewtopic.php?f=16&t=48331
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests