Which version?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Which version?

Postby splash2 » 13. December 2011 14:38

Hi All,

I have just been handed a project that needs postgre, MySQL [don't ask!], cURL & dBase support in Apache/PHP - does anyone know which version of XAMPP supports all of these dependencies?

TIA,

A
splash2
 
Posts: 5
Joined: 13. December 2011 14:28
Operating System: Wondows 7

Re: Which version?

Postby Altrea » 13. December 2011 17:44

Hi spalsh2,

AS far as i know none XAMPP version supports all of the dependencies.
MySQL and cURL (must be activated first) are implemented by default.
The last XAMPP version which comes with php_dbase was XAMPP 1.7.3.
postgreSQL was never included in the XAMPP Stack, but you can request existent postgreSQL databases with PDO for example

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Which version?

Postby splash2 » 14. December 2011 09:24

Many thanks - good info. For those that come after; the dbase extension is not in php.ini in 1.7.3, just add it manually and restart apache. dbase will then show up in phpinfo as 'Additional modules'
splash2
 
Posts: 5
Joined: 13. December 2011 14:28
Operating System: Wondows 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 76 guests