Apache won't start (XP SP3) 1.7.7 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache won't start (XP SP3) 1.7.7 [SOLVED]

Postby Devadaru » 10. December 2011 22:37

Hello,

Solutions posted so far don't seem to work for me.

XP, sp3

XAMPP 1.7.7

When I start Apache, it sometimes says "running" for a second or two, but then stops again. Log folder is empty.

Tried disabling firewall.
Tried updating the C++ thing
Unchecked the port 80 box in Skype

There's lots of software on this computer. Could there be another http server? How would I find out? Task manager shows no httpd.exe running. Anything else to look for?

I want to test openbiblio library catalog program, that's why I'm trying to install this.

Your help is much appreciated.
Devadaru
 
Posts: 2
Joined: 10. December 2011 22:29
Operating System: windows xp sp3

Re: Apache won't start

Postby Altrea » 10. December 2011 23:10

Hi Devadaru,

Use the new XAMPP control panel v3 and check, if there are other processes running on port 80 or 443.
But if there is no error.log file, than Apache has never successfully tried to start.
Have you installed the correct Microsoft Visual C++ 2008 SP1 Redistributable (x86)?
It MUST be the x86 (32 Bit) version and MUST be the 2008 version, not earlier or later.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache won't start

Postby Devadaru » 11. December 2011 03:04

Thank you, Altrea.

For reference of other readers of this thread: the control panel v3 is found in the xampp directory, filename xampp-control-3-beta.exe.

Yes, that revealed that inetinfo.exe was using ports 80 and 443; internet search shows that it is a MS server for IIS. I stopped it, and now Apache starts. I didn't know it was there, and I have no idea what it was doing, or if I need to restart it when I am done with xampp. But anyhow, I was able to start the Apache server as desired. thanks again for your quick and helpful reply.

Devadaru
Devadaru
 
Posts: 2
Joined: 10. December 2011 22:29
Operating System: windows xp sp3

Re: Apache won't start

Postby Altrea » 11. December 2011 03:09

You are very welcome Devadaru :)

IIS is a webserver too (like the Apache build in XAMPP).
You will know when you need it. If you don't know it is very very common you don't need it, especially not for webdevelopment if you use XAMPP.

I wish you all the best.
Have fun
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests