XAMPP Auto Start (Win7 HP 32) 1.7.7 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Auto Start (Win7 HP 32) 1.7.7 [SOLVED]

Postby Coastalguy » 08. December 2011 17:42

On a previous post, that is now locked, I had asked how to have Apache and Mysql startup on Windows start, on my XAMPP 1.7.7. After discovering that control panel 3.0.2 was installed on 1.7.7 (I was using 2.5 control panel), I found the new control panel had settings to auto start Apache and Mysql.

However, these only start with the startup of the control panel, which is still not auto starting with Windows startup. Is there a preferred way to auto start the control panel, which I assume would then auto start Apache and Mysql?

Do I just copy the control panel to Windows Start folder, or again, is there a preferred way other than this?
Coastalguy
 
Posts: 47
Joined: 06. March 2011 21:06
Operating System: Windows 7 Home Premium

Re: XAMPP Auto Start on Windows 7

Postby Altrea » 08. December 2011 19:16

The preferred method to autostart XAMPP components are the svc checkboxes in the control panel.
If this doesn't work for you like reported in your other post, we should find out why this didn't work.
The new control panel v3 does have these checkboxes too and a far better status reporting then the control panel v2.5.

I recommend to update the control panel v3.0.2 with the new version 3.0.11. Simply extract the .bat and .exe files directly to your XAMPP installation dir (e.g. c:\xampp\), overwrite or rename the old files.
After that start the control panel v3.0.11, choose a language, go to the options and tick the setting "show debug stuff" to "very many details". This will give us much more information about why the services cannot be registered.
Then go back to the control panel and try to tick the services checkboxes.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP Auto Start on Windows 7

Postby Coastalguy » 08. December 2011 20:11

Noticed when I clicked your link to the updated version, that the post advised these versions were not supported by the XAMPP team. Also, the link to the download was under maintenance. So wasn't sure about using the 11 version, and where I can actually find it??
Coastalguy
 
Posts: 47
Joined: 06. March 2011 21:06
Operating System: Windows 7 Home Premium

Re: XAMPP Auto Start on Windows 7

Postby Altrea » 08. December 2011 20:22

Coastalguy wrote:Noticed when I clicked your link to the updated version, that the post advised these versions were not supported by the XAMPP team.

This only means that this version is updated by a single user and is not yet part of the official XAMPP release and test quality management.
The current CP v3 seams to be very stable and we can recommend to use it. The CP v3 will be the next official XAMPP control panel in one of the next XAMPP releases.

Coastalguy wrote:Also, the link to the download was under maintenance. So wasn't sure about using the 11 version, and where I can actually find it??

There is a mirror link in the thread => http://www.mediafire.com/download.php?kz391q7kp33ftiq
or simply use the direct link pointing to my own webhost => http://xampp.statusnull.com/CPv3/CPv3.0.11.7z
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP Auto Start on Windows 7

Postby Coastalguy » 08. December 2011 23:16

Went to your direct webhost and downloaded 3.1.11 and unzipped. Renamed catalina_start and stop and then copied all unzipped files to XAMPP root. Opened up v11, and tried to activate the apache and mysql services, however it advised I had to stop them first. Tried to stop them, but would not stop. Rebooted to Windows and opened v11 again, and could not start either of them. The messages on both, indicated both auto starts were activated, but they would not start.

Opened up my v3.0.2, and on opening it, apache and mysql started fine. All I need to for the 3.0.2 control panel to open on Window 7 boot, where it looks like apache and mysql will autostart with the auto control panel start??

2 log files appeared on the desktop, during my starting and stopping apache and mysql via v11, but don't know how to send them along with this reply?
Coastalguy
 
Posts: 47
Joined: 06. March 2011 21:06
Operating System: Windows 7 Home Premium

Re: XAMPP Auto Start on Windows 7

Postby Altrea » 08. December 2011 23:22

Would be very interesting to see the status messages you get when you start the CP v3.0.11.
Do you start the CP with "rightclick -> run as Administrator" mode as recommend?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8297
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP Auto Start on Windows 7

Postby hackattack142 » 08. December 2011 23:32

It is very strange anything would appear on your desktop unless you were trying to run it from your desktop.

Could you please post the contents of the 'xampp-control-3-beta10.log' file here between some code tags and tell us what the names of these log files that appeared.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: XAMPP Auto Start on Windows 7

Postby Coastalguy » 09. December 2011 00:11

I opened it with shift/ctrl pressed which I was told also opens it as administrator. I also did a right click and had the same results.

On the 2 files, one is a .ini file and one a log.

The .ini file:

[Common]
Editor=notepad.exe
Browser=
Debug=0
Debuglevel=0
CheckDefaultPorts=1
Language=en
TomcatVisible=1

[LogSettings]
Font=Arial
FontSize=10

[WindowSettings]
Left=168
Top=143
Width=722
Height=454

[Autostart]
Apache=1
MySQL=1
FileZilla=0
Mercury=0
Tomcat=0

[ServiceNames]
Apache=Apache2.2
MySQL=mysql
FileZilla=FileZillaServer
Tomcat=Tomcat7

[ServicePorts]
Apache=80
ApacheSSL=443
MySQL=3306
FileZilla=21
FileZillaAdmin=14147
Mercury1=25
Mercury2=79
Mercury3=105
Mercury4=106
Mercury5=110
Mercury6=143
Mercury7=2224
TomcatHTTP=8080
TomcatAJP=8009
Tomcat=8005

[UserConfigs]
Apache=
MySQL=
FileZilla=
Mercury=
Tomcat=

[UserLogs]
Apache=
MySQL=
FileZilla=
Mercury=
Tomcat=

The log file:

4:48:30 PM [main] Initializing Control Panel
4:48:30 PM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
4:48:30 PM [main] XAMPP Version: ???
4:48:30 PM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
4:48:30 PM [main] You are not running with administrator rights! This will work for
4:48:30 PM [main] most application stuff but whenever you do something with services
4:48:30 PM [main] there will be a security dialogue or things will break! So think
4:48:30 PM [main] about running this application with administrator rights!
4:48:30 PM [main] XAMPP Installation Directory: "c:\users\dave\desktop\"
4:48:30 PM [main] Initializing Modules
4:48:30 PM [apache] Possible problem detected: Apache Not Found!
4:48:30 PM [apache] Run this program from your XAMPP root directory!
4:48:30 PM [apache] Possible problem detected!
4:48:30 PM [apache] Port 80 in use by "f:\xampp\apache\bin\httpd.exe"!
4:48:30 PM [apache] Possible problem detected!
4:48:30 PM [apache] Port 443 in use by "f:\xampp\apache\bin\httpd.exe"!
4:48:30 PM [mysql] Possible problem detected: MySQL Not Found!
4:48:30 PM [mysql] Run this program from your XAMPP root directory!
4:48:30 PM [mysql] Possible problem detected!
4:48:30 PM [mysql] Port 3306 in use by "f:\xampp\mysql\bin\mysqld.exe"!
4:48:30 PM [filezilla] Possible problem detected: FileZilla Not Found!
4:48:30 PM [filezilla] Run this program from your XAMPP root directory!
4:48:30 PM [mercury] Possible problem detected: Mercury Not Found!
4:48:30 PM [mercury] Run this program from your XAMPP root directory!
4:48:30 PM [tomcat] Possible problem detected: Tomcat Not Found!
4:48:30 PM [tomcat] Run this program from your XAMPP root directory!
4:48:30 PM [main] Starting Check-Timer
4:48:30 PM [main] Control Panel Ready
4:49:16 PM [apache] Stopping apache (PID: 5900)
4:49:38 PM [mysql] Stopping mysql (PID: 6000)
4:50:42 PM [main] Deinitializing Modules
4:50:42 PM [main] Deinitializing Control Panel

4:51:33 PM [main] Initializing Control Panel
4:51:33 PM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
4:51:33 PM [main] XAMPP Version: ???
4:51:33 PM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
4:51:33 PM [main] You are not running with administrator rights! This will work for
4:51:33 PM [main] most application stuff but whenever you do something with services
4:51:33 PM [main] there will be a security dialogue or things will break! So think
4:51:33 PM [main] about running this application with administrator rights!
4:51:33 PM [main] XAMPP Installation Directory: "c:\users\dave\desktop\"
4:51:33 PM [main] Initializing Modules
4:51:33 PM [apache] Possible problem detected: Apache Not Found!
4:51:33 PM [apache] Run this program from your XAMPP root directory!
4:51:33 PM [apache] Possible problem detected!
4:51:33 PM [apache] Port 80 in use by "f:\xampp\apache\bin\httpd.exe"!
4:51:33 PM [apache] Possible problem detected!
4:51:33 PM [apache] Port 443 in use by "f:\xampp\apache\bin\httpd.exe"!
4:51:33 PM [mysql] Possible problem detected: MySQL Not Found!
4:51:33 PM [mysql] Run this program from your XAMPP root directory!
4:51:33 PM [mysql] Possible problem detected!
4:51:33 PM [mysql] Port 3306 in use by "f:\xampp\mysql\bin\mysqld.exe"!
4:51:33 PM [filezilla] Possible problem detected: FileZilla Not Found!
4:51:33 PM [filezilla] Run this program from your XAMPP root directory!
4:51:33 PM [mercury] Possible problem detected: Mercury Not Found!
4:51:33 PM [mercury] Run this program from your XAMPP root directory!
4:51:33 PM [tomcat] Possible problem detected: Tomcat Not Found!
4:51:34 PM [tomcat] Run this program from your XAMPP root directory!
4:51:34 PM [main] Enabling autostart for module "apache"
4:51:34 PM [main] Enabling autostart for module "mysql"
4:51:34 PM [main] Starting Check-Timer
4:51:34 PM [main] Control Panel Ready
4:51:34 PM [apache] Autostart active: module is already running - aborted
4:51:34 PM [mysql] Autostart active: module is already running - aborted
4:51:47 PM [apache] Stopping apache (PID: 5900)
4:52:06 PM [main] Deinitializing Modules
4:52:06 PM [main] Deinitializing Control Panel

4:52:22 PM [main] Initializing Control Panel
4:52:22 PM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
4:52:22 PM [main] XAMPP Version: ???
4:52:22 PM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
4:52:22 PM [main] You are not running with administrator rights! This will work for
4:52:22 PM [main] most application stuff but whenever you do something with services
4:52:22 PM [main] there will be a security dialogue or things will break! So think
4:52:22 PM [main] about running this application with administrator rights!
4:52:22 PM [main] XAMPP Installation Directory: "c:\users\dave\desktop\"
4:52:23 PM [main] Initializing Modules
4:52:23 PM [apache] Possible problem detected: Apache Not Found!
4:52:23 PM [apache] Run this program from your XAMPP root directory!
4:52:23 PM [apache] Possible problem detected!
4:52:23 PM [apache] Port 80 in use by "f:\xampp\apache\bin\httpd.exe"!
4:52:23 PM [apache] Possible problem detected!
4:52:23 PM [apache] Port 443 in use by "f:\xampp\apache\bin\httpd.exe"!
4:52:23 PM [mysql] Possible problem detected: MySQL Not Found!
4:52:23 PM [mysql] Run this program from your XAMPP root directory!
4:52:23 PM [mysql] Possible problem detected!
4:52:23 PM [mysql] Port 3306 in use by "f:\xampp\mysql\bin\mysqld.exe"!
4:52:23 PM [filezilla] Possible problem detected: FileZilla Not Found!
4:52:23 PM [filezilla] Run this program from your XAMPP root directory!
4:52:23 PM [mercury] Possible problem detected: Mercury Not Found!
4:52:23 PM [mercury] Run this program from your XAMPP root directory!
4:52:23 PM [tomcat] Possible problem detected: Tomcat Not Found!
4:52:23 PM [tomcat] Run this program from your XAMPP root directory!
4:52:23 PM [main] Enabling autostart for module "apache"
4:52:23 PM [main] Enabling autostart for module "mysql"
4:52:23 PM [main] Starting Check-Timer
4:52:23 PM [main] Control Panel Ready
4:52:23 PM [apache] Autostart active: module is already running - aborted
4:52:23 PM [mysql] Autostart active: module is already running - aborted
4:53:02 PM [apache] Stopping apache (PID: 5900)
4:53:49 PM [main] Deinitializing Modules
4:53:49 PM [main] Deinitializing Control Panel

4:57:21 PM [main] Initializing Control Panel
4:57:21 PM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
4:57:21 PM [main] XAMPP Version: ???
4:57:21 PM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
4:57:21 PM [main] You are not running with administrator rights! This will work for
4:57:21 PM [main] most application stuff but whenever you do something with services
4:57:21 PM [main] there will be a security dialogue or things will break! So think
4:57:21 PM [main] about running this application with administrator rights!
4:57:21 PM [main] XAMPP Installation Directory: "c:\users\dave\desktop\"
4:57:21 PM [main] Initializing Modules
4:57:21 PM [apache] Possible problem detected: Apache Not Found!
4:57:21 PM [apache] Run this program from your XAMPP root directory!
4:57:21 PM [apache] Possible problem detected!
4:57:21 PM [apache] Port 80 in use by "f:\xampp\apache\bin\httpd.exe"!
4:57:21 PM [apache] Possible problem detected!
4:57:22 PM [apache] Port 443 in use by "f:\xampp\apache\bin\httpd.exe"!
4:57:22 PM [mysql] Possible problem detected: MySQL Not Found!
4:57:22 PM [mysql] Run this program from your XAMPP root directory!
4:57:22 PM [mysql] Possible problem detected!
4:57:22 PM [mysql] Port 3306 in use by "f:\xampp\mysql\bin\mysqld.exe"!
4:57:22 PM [filezilla] Possible problem detected: FileZilla Not Found!
4:57:22 PM [filezilla] Run this program from your XAMPP root directory!
4:57:22 PM [mercury] Possible problem detected: Mercury Not Found!
4:57:22 PM [mercury] Run this program from your XAMPP root directory!
4:57:22 PM [tomcat] Possible problem detected: Tomcat Not Found!
4:57:22 PM [tomcat] Run this program from your XAMPP root directory!
4:57:22 PM [main] Starting Check-Timer
4:57:22 PM [main] Control Panel Ready
4:57:29 PM [apache] Stopping apache (PID: 5900)
4:57:45 PM [mysql] Stopping mysql (PID: 6000)
4:58:30 PM [main] Deinitializing Modules
4:58:30 PM [main] Deinitializing Control Panel

5:01:01 PM [main] Initializing Control Panel
5:01:01 PM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
5:01:01 PM [main] XAMPP Version: ???
5:01:01 PM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
5:01:01 PM [main] You are not running with administrator rights! This will work for
5:01:01 PM [main] most application stuff but whenever you do something with services
5:01:01 PM [main] there will be a security dialogue or things will break! So think
5:01:01 PM [main] about running this application with administrator rights!
5:01:01 PM [main] XAMPP Installation Directory: "c:\users\dave\desktop\"
5:01:01 PM [main] Initializing Modules
5:01:01 PM [apache] Possible problem detected: Apache Not Found!
5:01:01 PM [apache] Run this program from your XAMPP root directory!
5:01:01 PM [apache] Possible problem detected!
5:01:01 PM [apache] Port 80 in use by "f:\xampp\apache\bin\httpd.exe"!
5:01:01 PM [apache] Possible problem detected!
5:01:01 PM [apache] Port 443 in use by "f:\xampp\apache\bin\httpd.exe"!
5:01:01 PM [mysql] Possible problem detected: MySQL Not Found!
5:01:01 PM [mysql] Run this program from your XAMPP root directory!
5:01:01 PM [mysql] Possible problem detected!
5:01:01 PM [mysql] Port 3306 in use by "f:\xampp\mysql\bin\mysqld.exe"!
5:01:01 PM [filezilla] Possible problem detected: FileZilla Not Found!
5:01:01 PM [filezilla] Run this program from your XAMPP root directory!
5:01:01 PM [mercury] Possible problem detected: Mercury Not Found!
5:01:01 PM [mercury] Run this program from your XAMPP root directory!
5:01:01 PM [tomcat] Possible problem detected: Tomcat Not Found!
5:01:01 PM [tomcat] Run this program from your XAMPP root directory!
5:01:01 PM [main] Starting Check-Timer
5:01:01 PM [main] Control Panel Ready
5:01:07 PM [apache] Stopping apache (PID: 5900)
5:01:59 PM [main] Deinitializing Modules
5:01:59 PM [main] Deinitializing Control Panel

5:05:59 PM [main] Initializing Control Panel
5:05:59 PM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
5:05:59 PM [main] XAMPP Version: ???
5:05:59 PM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
5:05:59 PM [main] You are not running with administrator rights! This will work for
5:05:59 PM [main] most application stuff but whenever you do something with services
5:05:59 PM [main] there will be a security dialogue or things will break! So think
5:05:59 PM [main] about running this application with administrator rights!
5:05:59 PM [main] XAMPP Installation Directory: "c:\users\dave\desktop\"
5:05:59 PM [main] Initializing Modules
5:05:59 PM [apache] Possible problem detected: Apache Not Found!
5:05:59 PM [apache] Run this program from your XAMPP root directory!
5:05:59 PM [mysql] Possible problem detected: MySQL Not Found!
5:05:59 PM [mysql] Run this program from your XAMPP root directory!
5:05:59 PM [filezilla] Possible problem detected: FileZilla Not Found!
5:05:59 PM [filezilla] Run this program from your XAMPP root directory!
5:05:59 PM [mercury] Possible problem detected: Mercury Not Found!
5:05:59 PM [mercury] Run this program from your XAMPP root directory!
5:05:59 PM [tomcat] Possible problem detected: Tomcat Not Found!
5:05:59 PM [tomcat] Run this program from your XAMPP root directory!
5:05:59 PM [main] Enabling autostart for module "apache"
5:05:59 PM [main] Enabling autostart for module "mysql"
5:05:59 PM [main] Starting Check-Timer
5:05:59 PM [main] Control Panel Ready
5:06:00 PM [apache] Autostart active: starting...
5:06:00 PM [apache] Starting apache app...
5:06:00 PM [mysql] Autostart active: starting...
5:06:00 PM [mysql] Starting mysql app...
5:07:45 PM [main] Deinitializing Modules
5:07:45 PM [main] Deinitializing Control Panel

6:07:25 PM [main] Initializing Control Panel
6:07:25 PM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
6:07:25 PM [main] XAMPP Version: ???
6:07:25 PM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
6:07:25 PM [main] Running with Administrator rights - good!
6:07:25 PM [main] XAMPP Installation Directory: "c:\users\dave\desktop\v3.0.11 cp\"
6:07:25 PM [main] ERROR: Your install directory contains spaces. This will break programs
6:07:25 PM [main] Initializing Modules
6:07:25 PM [apache] Possible problem detected: Apache Not Found!
6:07:25 PM [apache] Run this program from your XAMPP root directory!
6:07:25 PM [apache] Possible problem detected!
6:07:25 PM [apache] Port 80 in use by "f:\xampp\apache\bin\httpd.exe"!
6:07:25 PM [apache] Possible problem detected!
6:07:25 PM [apache] Port 443 in use by "f:\xampp\apache\bin\httpd.exe"!
6:07:25 PM [mysql] Possible problem detected: MySQL Not Found!
6:07:25 PM [mysql] Run this program from your XAMPP root directory!
6:07:25 PM [mysql] Possible problem detected!
6:07:25 PM [mysql] Port 3306 in use by "f:\xampp\mysql\bin\mysqld.exe"!
6:07:25 PM [filezilla] Possible problem detected: FileZilla Not Found!
6:07:25 PM [filezilla] Run this program from your XAMPP root directory!
6:07:25 PM [mercury] Possible problem detected: Mercury Not Found!
6:07:25 PM [mercury] Run this program from your XAMPP root directory!
6:07:25 PM [tomcat] Possible problem detected: Tomcat Not Found!
6:07:25 PM [tomcat] Run this program from your XAMPP root directory!
6:07:25 PM [main] Enabling autostart for module "apache"
6:07:25 PM [main] Enabling autostart for module "mysql"
6:07:25 PM [main] Starting Check-Timer
6:07:25 PM [main] Control Panel Ready
6:07:26 PM [apache] Autostart active: module is already running - aborted
6:07:26 PM [mysql] Autostart active: module is already running - aborted
6:07:33 PM [apache] Stopping apache (PID: 2936)
6:07:47 PM [main] Deinitializing Modules
6:07:47 PM [main] Deinitializing Control Panel
Coastalguy
 
Posts: 47
Joined: 06. March 2011 21:06
Operating System: Windows 7 Home Premium

Re: XAMPP Auto Start on Windows 7

Postby Sharley » 09. December 2011 00:23

XAMPP Installation Directory: "c:\users\dave\desktop\v3.0.11 cp\"
The xcpv3 exe and the other files in the archive should be extracted to the xampp installation folder F:\xampp and then change the shortcut and run it from there should fix your issues.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP Auto Start on Windows 7

Postby Coastalguy » 09. December 2011 00:50

I had copied the 4 files (catalina_service.bat, catalina_start.bat, catalina_stop.bat and xampp-control-3-beta10.exe), to my f:\XAMPP root folder (where I installed XAMPP). What I forgot was the 2 folders (locale and xcp3src), which I copied also after renaming the old folders.

Now, when I try to start apache, it advises that the http.conf file is not at: c:\users\dave\desktop\v3.0.11 cp, which I assume is the default install folder. Is there an .ini file that points to the default install folder, and wasn't changed to where XAMPP was actually installed.
Coastalguy
 
Posts: 47
Joined: 06. March 2011 21:06
Operating System: Windows 7 Home Premium

Re: XAMPP Auto Start on Windows 7

Postby Sharley » 09. December 2011 00:56

Run the F:\xampp\setup_xampp.bat file to correct any path issues.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP Auto Start on Windows 7

Postby Coastalguy » 09. December 2011 00:58

Regarding my last response, after copying everything mentioned to my f:\xampp folder, I was trying to check the apache service module when it advised it could not find the http.conf file at the default install location. Neither apache nor mysql will start as before.

Per your response that I received while typing the above, I ran the setup file and received a message that "it had nothing to do". Tried again to check the apache module and still receive the http.conf error.
Coastalguy
 
Posts: 47
Joined: 06. March 2011 21:06
Operating System: Windows 7 Home Premium

Re: XAMPP Auto Start on Windows 7

Postby Sharley » 09. December 2011 01:05

Long shot but rename or delete the folder on the desktop.

The bat file response is telling you that all paths are correct in XAMPP for F:\xampp

Delete the XCPv3.0.11 ini file in the F:\xampp folder after first Quitting the panel and then start the same panel again as it will recreate the ini file as if it had been installed for the first time.

You could also delete the cpv3 log file so you have a clean start.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP Auto Start on Windows 7

Postby Coastalguy » 09. December 2011 01:19

First, I did't have a XCPv3.0.11 ini file in my f:\xampp. The only ini file appearing is on my desktop:
xampp-control-3-beta10.ini

Second, I deleted the xampp-control-3-beta10.ini file on my desktop, which was created again when starting the cp11.

Still, I cannot check the apache module without the conf file location error, nor start apache and mysql. Following are the messages in the control panel. As you can see, it advises that apache is starting, but then nothing.....

7:18:06 PM [main] Initializing Control Panel
7:18:06 PM [main] Windows Version: Windows 7 Home Premium SP1 32-bit
7:18:06 PM [main] XAMPP Version: ???
7:18:06 PM [main] Control Panel Version: 3.0.11 [ Compiled: December 7th 2011 ]
7:18:06 PM [main] Running with Administrator rights - good!
7:18:06 PM [main] XAMPP Installation Directory: "c:\users\dave\desktop\v3.0.11 cp\cpv3\"
7:18:06 PM [main] ERROR: Your install directory contains spaces. This will break programs
7:18:07 PM [main] Initializing Modules
7:18:07 PM [apache] Possible problem detected: Apache Not Found!
7:18:07 PM [apache] Run this program from your XAMPP root directory!
7:18:07 PM [mysql] Possible problem detected: MySQL Not Found!
7:18:07 PM [mysql] Run this program from your XAMPP root directory!
7:18:07 PM [filezilla] Possible problem detected: FileZilla Not Found!
7:18:07 PM [filezilla] Run this program from your XAMPP root directory!
7:18:07 PM [mercury] Possible problem detected: Mercury Not Found!
7:18:07 PM [mercury] Run this program from your XAMPP root directory!
7:18:07 PM [tomcat] Possible problem detected: Tomcat Not Found!
7:18:07 PM [tomcat] Run this program from your XAMPP root directory!
7:18:07 PM [main] Starting Check-Timer
7:18:07 PM [main] Control Panel Ready
7:18:20 PM [apache] Starting apache app...
Coastalguy
 
Posts: 47
Joined: 06. March 2011 21:06
Operating System: Windows 7 Home Premium

Re: XAMPP Auto Start on Windows 7

Postby Sharley » 09. December 2011 01:28

There should be no CPv3 files or folders on the desktop, they should all be in the F:\xampp folder.

Go to F:\xampp and right click on the xampp-control-3-beta10.exe file and select to run as administrator after first renaming the desktop folder v3.0.11cp to v3.0.11cp_original - delete any xampp-control-3-beta10.ini files in the F:\xampp folder before following this instruction.

The control panel must be started in the f:\xampp folder not from the desktop v3.0.11cp folder and so you may have to delete or reconfigure any shortcuts you have created or are using.

You can create a new shortcut by right clicking on the F:\xampp\xampp-control-3-beta10.exe file only and place it to a location for your own best convenience.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 49 guests