Joomla/php5.3 problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Joomla/php5.3 problem

Postby barndog » 03. December 2011 18:52

recently installed xampp1.7.7 on new windows7 computer. Built a Joomla site on local host. Just one of many. tranfered the site to a live host. made backup. tranferred the backup to localhost. Tons of errors. Discovered there seem to be problems and the only solution I could find was to go back in xampp versions until the problems (404, 500) errors disappeared. Bottomline:

Seems that something has happened within php. backups of joomla site fails to re-install AFTER php 5.2
barndog
 
Posts: 8
Joined: 01. September 2010 12:05
Operating System: windows7

Re: Joomla/php5.3 problem

Postby Altrea » 03. December 2011 23:56

1st: Please add your OS version and XAMPP version in your Profile Information

2nd: You have to give us much more details about the Joomla Version you are using on your online system. Joomla can work with PHP 5.3 since Joomla 1.5.15. Maybe you have to update your Joomla version or your Apache error reporting setting to get it to work on the current XAMPP version. Nobody can know without that necessary information.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Joomla/php5.3 problem

Postby barndog » 04. December 2011 01:05

operating system:

Windows7 home premium
tried:

xampp1.7.7;1.7.4;1.7.3;finally 1.7.1

Joomla 1.7.3

problem is with idiosyncracies in php5.3
barndog
 
Posts: 8
Joined: 01. September 2010 12:05
Operating System: windows7

Re: Joomla/php5.3 problem

Postby barndog1946 » 05. December 2011 00:13

got locked out of barndog account.

So the problem continues like this:

On localhost running xampp1.7.1 which uses php 5.2, and Joomla1.7.3 if I make a sit backup and move to live host running apache 2.2 with php 5.2.7 all is fine. But if I install xampp 1.7.3 or higher which move to php 5.3 on localhost, make back up and move live. Then move the live backup on to localhost I get 404, 500 errors and messages in apache log saying some admin directories are missing. However those directories (images, templates) are there because I see them. When I revert back to xampp1.7.1 those problems dissappear.

I am Not a guru of any type so I can't help further. Just though I would report a problem and muddle along trying to maintain my site at localhost so as to NOT disturb the live site except to do midnight maintenance when I must do live updates tdue to site additions via backup routines
barndog1946
 
Posts: 1
Joined: 05. December 2011 00:04
Operating System: windows7 home premium

Re: Joomla/php5.3 problem

Postby Sharley » 05. December 2011 00:22

got locked out of barndog account.
You changed your password 2 times about 6 hours apart, did you forget the last password?

You may be able to recover it by clicking on 'I forgot my password' on the login page:
ucp.php?mode=login
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Joomla/php5.3 problem

Postby Altrea » 05. December 2011 10:58

barndog1946 wrote:Then move the live backup on to localhost I get 404, 500 errors and messages in apache log saying some admin directories are missing. However those directories (images, templates) are there because I see them. When I revert back to xampp1.7.1 those problems dissappear.

HTTP errors are logged in your \xampp\apache\logs\error.log. Take a look in there to find more about it (or quote the lines here so we can take a look on it).

I guess it's a Joomla Configuration problem (Base URL, .htaccess or something like that). The error.log should give us a hint.
btw: Do you use some Extensions for your Joomla instance?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Joomla/php5.3 problem

Postby barndog » 05. December 2011 13:08

What I see in Apache error.log:

[Mon Dec 05 00:10:32 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/announce
[Mon Dec 05 00:11:01 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/announce

more info in access.log:

127.0.0.1 - - [05/Dec/2011:05:42:18 -0600] "GET /announce?info_hash=%07%bf%eei%bf~%24F%3cV%a2%a2%8d%8b%188Rk%be%7f&peer_id=M7-5-0--Rd%dc%b5%edc%91%2c%94%b9%ca-&port=39526&uploaded=0&downloaded=3200253952&left=10833049551&corrupt=0&key=4DF86792&event=started&numwant=200&compact=1&no_peer_id=1&ipv6=2001%3a0%3a4137%3a9e76%3a348d%3a29fa%3ae7f0%3acca7 HTTP/1.1" 404 1115
127.0.0.1 - - [05/Dec/2011:05:42:39 -0600] "GET /announce?info_hash=%22%a1%bd%1f%1c%d1U%e4%ed%ee%17%7b%d1%81%e7%d1%d9%d8k%a3&peer_id=M7-5-0--Rd%dc%b5%edc%91%2c%94%b9%ca-&port=39526&uploaded=0&downloaded=2751463424&left=8490641389&corrupt=0&key=4DF86792&event=started&numwant=200&compact=1&no_peer_id=1&ipv6=2001%3a0%3a4137%3a9e76%3a348d%3a29fa%3ae7f0%3acca7 HTTP/1.1" 404 1115

Maybe this goves a clue but as I mentioned.... I have no clue
barndog
 
Posts: 8
Joined: 01. September 2010 12:05
Operating System: windows7

Re: Joomla/php5.3 problem

Postby Altrea » 05. December 2011 19:22

Please tell us your full installation path for your local Joomla installation.
I guess your live environment URL point directly to your Joomla installation so that it is a DirectoryRoot / Base url issue.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Joomla/php5.3 problem

Postby barndog » 05. December 2011 23:01

C:/xampp/htdocs/joomla17
barndog
 
Posts: 8
Joined: 01. September 2010 12:05
Operating System: windows7

Re: Joomla/php5.3 problem

Postby Altrea » 06. December 2011 01:18

Just a try.

- Open your C:\xampp\apache\conf\httpd.conf file

- Change line 183 from
Code: Select all
DocumentRoot "C:/xampp/htdocs"
to
Code: Select all
DocumentRoot "C:/xampp/htdocs/joomla17"


- Change line 210 from
Code: Select all
<Directory "C:/xampp/htdocs">
to
Code: Select all
<Directory "C:/xampp/htdocs/joomla17">


- Restart your Apache

- Try to access your Joomla directly with URL http://localhost/
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Joomla/php5.3 problem

Postby barndog » 06. December 2011 13:37

When I made that change apache error.log FILLED with :

[Tue Dec 06 05:45:59 2011] [error] [client 127.0.0.1] File does not exist: C:/xampp/htdocs/announce

and access.log with:

127.0.0.1 - - [06/Dec/2011:05:45:59 -0600] "GET /announce?info_hash=%22%a1%bd%1f%1c%d1U%e4%ed%ee%17%7b%d1%81%e7%d1%d9%d8k%a3&peer_id=M7-5-0--Rd%dc%b5%edc%91%2c%94%b9%ca-&port=39526&uploaded=0&downloaded=6631194624&left=4617306112&corrupt=0&key=4DF86792&event=started&numwant=200&compact=1&no_peer_id=1&ipv6=2001%3a0%3a4137%3a9e76%3a348d%3a29fa%3ae7f0%3acca7 HTTP/1.1" 404 1115
127.0.0.1 - - [06/Dec/2011:06:14:36 -0600] "GET /announce?info_hash=I%7f%d06%e6L%dd%84G%82%1a%0c4%29%97%2ab%b8%3f%a2&peer_id=M7-5-0--Rd%dc%b5%edc%91%2c%94%b9%ca-&port=39526&uploaded=0&downloaded=7361003520&left=5889523712&corrupt=0&key=4DF86792&event=started&numwant=200&compact=1&no_peer_id=1&ipv6=2001%3a0%3a4137%3a9e76%3a348d%3a29fa%3ae7f0%3acca7 HTTP/1.1" 404 1115
127.0.0.1 - - [06/Dec/2011:06:15:01 -0600] "GET /announce?info_hash=%09%c8%bc%f5%8e%1eq%14f%aa%7c%21%f4%1a%82%a6Gh%15%7f&peer_id=M7-5-0--Rd%dc%b5%edc%91%2c%94%b9%ca-&port=39526&uploaded=0&downloaded=9139388416&left=3726213120&corrupt=0&key=4DF86792&event=started&numwant=200&compact=1&no_peer_id=1&ipv6=2001%3a0%3a4137%3a9e76%3a348d%3a29fa%3ae7f0%3acca7 HTTP/1.1" 404 1115
127.0.0.1 - - [06/Dec/2011:06:15:20 -0600] "GET /announce?info_hash=%bfN%3d%be%c6%11%ed%ad%12%a4%a6M1%df%c6%ef%7f%5b%d4W&peer_id=M7-5-0--Rd%dc%b5%edc%91%2c%94%b9%ca-&port=39526&uploaded=0&downloaded=7012876288&left=7375962112&corrupt=0&key=4DF86792&event=started&numwant=200&compact=1&no_peer_id=1&ipv6=2001%3a0%3a4137%3a9e76%3a348d%3a29fa%3ae7f0%3acca7 HTTP/1.1" 404 1115
127.0.0.1 - - [06/Dec/2011:06:15:42 -0600] "GET /announce?info_hash=%07%bf%eei%bf~%24F%3cV%a2%a2%8d%8b%188Rk%be%7f&peer_id=M7-5-0--Rd%dc%b5%edc%91%2c%94%b9%ca-&port=39526&uploaded=0&downloaded=13824425984&left=207618048&corrupt=0&key=4DF86792&event=started&numwant=200&compact=1&no_peer_id=1&ipv6=2001%3a0%3a4137%3a9e76%3a348d%3a29fa%3ae7f0%3acca7 HTTP/1.1" 404 1115
127.0.0.1 - - [06/Dec/2011:06:16:03 -0600] "GET /announce?info_hash=%22%a1%bd%1f%1c%d1U%e4%ed%ee%17%7b%d1%81%e7%d1%d9%d8k%a3&peer_id=M7-5-0--Rd%dc%b5%edc%91%2c%94%b9%ca-&port=39526&uploaded=0&downloaded=6681526272&left=4570382336&corrupt=0&key=4DF86792&event=started&numwant=200&compact=1&no_peer_id=1&ipv6=2001%3a0%3a4137%3a9e76%3a348d%3a29fa%3ae7f0%3acca7 HTTP/1.1" 404 1115

So no joy there
barndog
 
Posts: 8
Joined: 01. September 2010 12:05
Operating System: windows7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests