Xampp and Google Ad Virus (Win7) 1.7.7 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp and Google Ad Virus (Win7) 1.7.7 [SOLVED]

Postby marins » 27. November 2011 14:36

Hello,

on last friday I got Google Ad Virus. It disabled my http://localhost on XAMPP.

I'm using the last Xammp 3.xx. I get rid of virus with Ad-Aware, but my localhost don't work.

XAMPP console shows me, that Apache and MySql are running, but I can not access to http://localhost. I already tried with Xampp control 3, but still don't work.

I think that virus has disabled something to work proprely.

Any ideas?

Thank you!

Best regards,
MS.
http://www.turist-on.net
marins
 
Posts: 6
Joined: 27. November 2011 14:05
Operating System: Windows 7

Re: Xampp and Google Ad Virus

Postby JonB » 27. November 2011 16:15

look in your hosts file
c:\windows\system32\drivers\etc\hosts

See what entry is on the line contains 'localhost.
It should look like this:

Code: Select all
127.0.0.1       localhost


If there is any other IP address there, change it to 127.0.0.1
OR
if there is more that one line with 127.0.0.1 at the start - remove them.

You should wind up with only one line that starts with 127.0.0.1 and it should have the 'localhost' entry.

Reason - a lot of malware installs -tiny servers- to redirect traffic.

I can't tell you how any times I have had to fix this on peep's computers after a malware attack (mostly the 'scamware' ones.

I hope this is it.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Xampp and Google Ad Virus

Postby marins » 27. November 2011 16:50

Unfortunally this is not an issue.

My host file looks like this:
Code: Select all
# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
#      102.54.94.97     rhino.acme.com          # source server
#       38.25.63.10     x.acme.com              # x client host

# localhost name resolution is handled within DNS itself.
#   127.0.0.1       localhost
#   ::1             localhost

127.0.0.1       localhost


In CMD I typed command netstat -o and I get result:
TCP 127.0.0.1:80 CLOSE_WAIT 5116

This PID is from XAMPP. I already uninstall it and then again install it, but it still doesn't work.

When I type http://localhost nothing apears -> waiting for localhost message in browser...

Maybe this can help, this is an error.log from Apache:
Code: Select all
[Sun Nov 27 16:39:47 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Nov 27 16:39:47 2011] [notice] Digest: done
[Sun Nov 27 16:39:48 2011] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Nov 27 16:39:48 2011] [notice] Server built: Sep 10 2011 11:34:11
[Sun Nov 27 16:39:48 2011] [notice] Parent: Created child process 3480
[Sun Nov 27 16:39:49 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Nov 27 16:39:49 2011] [notice] Digest: done
[Sun Nov 27 16:39:50 2011] [notice] Child 3480: Child process is running
[Sun Nov 27 16:39:50 2011] [notice] Child 3480: Acquired the start mutex.
[Sun Nov 27 16:39:50 2011] [notice] Child 3480: Starting 150 worker threads.
[Sun Nov 27 16:39:50 2011] [error] (OS 10038)An operation was attempted on something that is not a socket.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sun Nov 27 16:39:50 2011] [error] (OS 10038)An operation was attempted on something that is not a socket.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sun Nov 27 16:39:50 2011] [error] (OS 10038)An operation was attempted on something that is not a socket.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sun Nov 27 16:39:50 2011] [error] (OS 10038)An operation was attempted on something that is not a socket.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sun Nov 27 16:40:44 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Sun Nov 27 16:40:44 2011] [notice] Child 3480: Exit event signaled. Child process is ending.
[Sun Nov 27 16:40:45 2011] [notice] Child 3480: Released the start mutex
[Sun Nov 27 16:40:46 2011] [notice] Child 3480: All worker threads have exited.
[Sun Nov 27 16:40:46 2011] [notice] Child 3480: Child process is exiting
[Sun Nov 27 16:40:46 2011] [notice] Parent: Child process exited successfully.
[Sun Nov 27 16:41:47 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Nov 27 16:41:47 2011] [notice] Digest: done
[Sun Nov 27 16:41:48 2011] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Nov 27 16:41:48 2011] [notice] Server built: Sep 10 2011 11:34:11
[Sun Nov 27 16:41:48 2011] [notice] Parent: Created child process 1760
[Sun Nov 27 16:41:49 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Nov 27 16:41:49 2011] [notice] Digest: done
[Sun Nov 27 16:41:49 2011] [notice] Child 1760: Child process is running
[Sun Nov 27 16:41:49 2011] [notice] Child 1760: Acquired the start mutex.
[Sun Nov 27 16:41:49 2011] [notice] Child 1760: Starting 150 worker threads.
[Sun Nov 27 16:41:49 2011] [error] (OS 10038)An operation was attempted on something that is not a socket.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sun Nov 27 16:41:49 2011] [error] (OS 10038)An operation was attempted on something that is not a socket.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sun Nov 27 16:41:49 2011] [error] (OS 10038)An operation was attempted on something that is not a socket.  : winnt_accept: getsockname error on listening socket, is IPv6 available?
[Sun Nov 27 16:41:49 2011] [error] (OS 10038)An operation was attempted on something that is not a socket.  : winnt_accept: getsockname error on listening socket, is IPv6 available?


In Local Area Connection there is:
Conection IPv6: No internet access

Thanks.

BR, MS.
http://www.turist-on.net
marins
 
Posts: 6
Joined: 27. November 2011 14:05
Operating System: Windows 7

Re: Xampp and Google Ad Virus SOLVED!!

Postby marins » 27. November 2011 17:26

Hello,

after a whole day of surfing I solved it.

The problem was in:

My proxy settings. (Internet Explorer)

Start Internet Explorer. Click Internet Options. Select Connections. Click LAN settings. Check if none of the boxes are selected.


and

In Mozilla Firefox. Click Tools, select Options. Click Advanced. Select Network Tab and click Settings. Check if "No proxy is selected".

When I fixed that and reset apache and mysql it started to work.

I hope this will help to other users of XAMPP if they have the same problem.

BR, MS.
http://www.turist-on.net
marins
 
Posts: 6
Joined: 27. November 2011 14:05
Operating System: Windows 7

Re: Xampp and Google Ad Virus

Postby JonB » 27. November 2011 17:50

Thanks for posting the solution -

My bad - I also knew that from using Malware bytes - BUT forgot it!

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests