IIS off, SQL off but PORT 80 still used by system

Problems with the Windows version of XAMPP, questions, comments, and anything related.

IIS off, SQL off but PORT 80 still used by system

Postby furimmer » 26. November 2011 17:00

Hi

I'm pulling my hair out as to whyI can't get Apache to access Port 80. I've searched through the forums and done all the things suggested; switched off IIS, uninstalled SQL, unchecked port 90 access on Skype. Netstat tells me Port 80 is assigned to 'system'. I'm on Vista SP2 with UAC turned off.

Any help appreciated.

Thanks

Furimmer
furimmer
 
Posts: 1
Joined: 26. November 2011 16:45
Operating System: Vista

Re: IIS off, SQL off but PORT 80 still used by system

Postby JonB » 26. November 2011 18:35

There's a very good chance that the problem is a MS Web management tool/interface. Many of then use the 'stub' of IIS - which is http.sys (a kernel mode driver for http).

Have you tried 'netstat' (I'm guessing yes) ???

A good tool for finding out exactly what is on port 80 is Process Explorer
http://technet.microsoft.com/en-us/sysi ... s/bb896653

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: IIS off, SQL off but PORT 80 still used by system

Postby Altrea » 26. November 2011 19:35

Take a look into your Windows services for a service named "world wide web publishung" or "WWW-Publishing".
This is very common blocking these ports on newer Windows Installations.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: IIS off, SQL off but PORT 80 still used by system

Postby Sharley » 26. November 2011 22:46

Here's my 2 cents worth. :)

IMHO, a more feature rich process utilty than Microsoft's Process Explorer is the free open source Process Hacker from here:
http://processhacker.sourceforge.net/
It has very good reviews and my preferred process utility that has added advantages over the MS closed source utility.


Read these Vista specific instructions in this post...
viewtopic.php?p=135356#p135356
...and follow the link mentioned as it also has instruction to help with correctly disabling IIS and UAC in Vista that helped the original posters with a SYSTEM issue.

The SYSTEM issue usually means that there is a Windows service occupying the ports that Apache/MySQL requires which have not been uninstalled\disabled correctly and so may be still installed - the services need to be uninstalled which will remove them from the Windows registry.

If you use the keyword system in an advanced forum search in the XAMPP for Windows English forum then you will see many posters had a similar issue.


Also try and use the new control panel xampp-control-3-beta.exe found in the xampp folder.
First Stop all components and then remove any ticks in the Svc boxes then click on Exit the older control panel before double clicking on the new XCPv3.

You can then use the many new and improved features it contains including the Netstat button that will show you the ports in use.

Latest XCPv3 versions can be found here:
viewtopic.php?f=16&t=48932
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: IIS off, SQL off but PORT 80 still used by system

Postby GlennC » 06. December 2011 18:10

The new control panel 3.x is EXTREMELY useful and a big improvement over the previous version.

Not only did it tell me that port 80 is used by "system" when it starts up, but it also show that when you click the "NetStat" button. That put me right on the problem.

I disabled the World Wide Web service (IIS's web service).

Then, I went to this article to figure out how to solve it on my Win7 computer: http://bravo.newnetenterprises.com/wordpress/2011/09/how-to-rid-your-windows-7-of-a-port-80-problem-for-xamppapache/

Another tip: when looking at the Processes tab in Task Manager, make sure you take the option at the bottom to "Show processes from all users". I did that, and found MSDEPSvc.exe running, which is a web deployment agent. That was holding 80 from me. I killed that and it started working.

Great Job on the updated control panel!
GlennC
 
Posts: 4
Joined: 16. September 2011 01:45


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 53 guests