Mysql not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Mysql not working

Postby 4jassiking » 20. November 2011 10:26

MySQL said: Documentation
#2003 - Can't connect to MySQL server on 'localhost' (10061)
Connection for controluser as defined in your configuration failed.

All the components status showing deactivated on status page
and when i have tried using command prompt C:\xampplite\mysql\bin\mysql.exe -u root
i m getting error as
ERROR 2003 (HY000): cant connect to mysql server on localhost (10061)
and on the Xampp control panel it is showing both Apache and Mysql are running.

I have also tried reinstalling many times but still unable to solve to the problem, can anybody help me put?
4jassiking
 
Posts: 2
Joined: 20. November 2011 10:12
Operating System: windows 7

Re: Mysql not working

Postby Sharley » 20. November 2011 16:45

Is MySQL running?
Check in the XAMPP Control Panel.

Have you allowed access for port 3306 in your firewall?
Check your firewall/ZoneAlarm/other security utility settings.

Your error seems to indicate that MySQL is being blocked and so can't be accessed.

There is a newer version of XAMPP Lite 1.7.7 that you may like to use instead of the 1.7.2 version or have you considered installing the full featured 1.7.7 version?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests