access to HTTP localhost slow to load but HTTPS is very fast

Problems with the Windows version of XAMPP, questions, comments, and anything related.

access to HTTP localhost slow to load but HTTPS is very fast

Postby hpeleo » 17. November 2011 01:38

After installing and uninstalling several times the most recent version of xampp 1.7.7, xampp is very slow to load on http://localhost/xampp. It takes 30 minutes to load and when It does load, there's no css to the page and I can't see the orange background very familiar with the xampp page.

However when I access localhost through https://localhost, the page loads very fast, and everything works. Is there anything that I can do to fix this? I have Eset Smart Security 4.27 and Windows Firewall is disabled and instead am using Eset's firewall. Though even with the firewall on, Xampp 1.7.1 still worked.
hpeleo
 
Posts: 5
Joined: 17. November 2011 01:28
Operating System: Windows Vista

Re: access to HTTP localhost slow to load but HTTPS is very

Postby Sharley » 17. November 2011 01:45

Have you tried it in various other browser's and get the same result?

Are there any clues in the \xampp\apache\logs\error.log file at about the date and time you get this slowing down issue.

Have you tried using the newer control panel found in the xampp folder which often gives better log file displays and also creates a log file in the xampp folder:
xampp-control-3-beta.exe
Stop all XAMPP components and remove the ticks in the Svc check boxes to uninstall the Windows services then Exit the older version first before starting XCPv3.

The latest XCPv3 version can be downloaded from here and has many more features and bug fixes:
viewtopic.php?f=16&p=186862#p186862
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: access to HTTP localhost slow to load but HTTPS is very

Postby hpeleo » 17. November 2011 02:01

Yes, Ive tried it in IE and the page still loads for along time. I've also been using the newer control panel the entire time, though the old control panel doesn't resolve anything, page still doesnt load. Ive also unticked and ticked each of the services to reinstall them, to no avail.
hpeleo
 
Posts: 5
Joined: 17. November 2011 01:28
Operating System: Windows Vista

Re: access to HTTP localhost slow to load but HTTPS is very

Postby Sharley » 17. November 2011 02:09

Leave the Services unchecked for now.

Open \xampp\apache\conf\extra\httpd-mpm.conf in your text editor and down near the end of the file in the WinNT MPM section uncomment this line (remove the # character) so it looks like this
Code: Select all
    Win32DisableAcceptEx
Then restart Apache and try localhost again.

I take it there are no clues showing up in any of the log files mentioned?
Try pasting the tail of both logs here after starting Apache and the XCPv3 please.

You are logged into Vista as an admin have temporarily disabled UAC?

Do you have this same issue if you just type http://127.0.0.1 or http://localhost missing out any other folder names?

Using the Windows Task Manager can you see a spike in CPU usage in the Processes Tab when trying to access localhost?

Something else to try:
Open C:\Windows\system32\drivers\etc\hosts file in your text editor and comment out this line so it looks like this
Code: Select all
127.0.0.1 localhost
#::1 localhost
The first 2 lines after all the comment tags should look like the above now, you can also delete that IPv6 line completely if you wish - save the file and often a reboot after this edit helps.

There is no definitive solution for this but trial and error using previous solutions from members who have has similar issues.
Mostly it is related to your system not to XAMPP as millions of XAMPP users do not experience this behaviour.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: access to HTTP localhost slow to load but HTTPS is very

Postby hpeleo » 17. November 2011 04:09

Tried all those solutions but still the same problem :/

APACHE:
Here is the error log:
Code: Select all
[Wed Nov 16 22:02:44 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Wed Nov 16 22:02:44 2011] [notice] Child 5252: Exit event signaled. Child process is ending.
[Wed Nov 16 22:02:45 2011] [notice] Child 5252: Released the start mutex
[Wed Nov 16 22:03:06 2011] [notice] Child 5252: All worker threads have exited.
[Wed Nov 16 22:03:07 2011] [notice] Child 5252: Child process is exiting
[Wed Nov 16 22:03:08 2011] [notice] Parent: Child process exited successfully.
[Wed Nov 16 22:03:19 2011] [notice] Digest: generating secret for digest authentication ...
[Wed Nov 16 22:03:19 2011] [notice] Digest: done
[Wed Nov 16 22:03:22 2011] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Wed Nov 16 22:03:22 2011] [notice] Server built: Sep 10 2011 11:34:11
[Wed Nov 16 22:03:22 2011] [notice] Parent: Created child process 4192
[Wed Nov 16 22:03:22 2011] [notice] Disabled use of AcceptEx() WinSock2 API
[Wed Nov 16 22:03:24 2011] [notice] Digest: generating secret for digest authentication ...
[Wed Nov 16 22:03:24 2011] [notice] Digest: done
[Wed Nov 16 22:03:26 2011] [notice] Child 4192: Child process is running
[Wed Nov 16 22:03:26 2011] [notice] Child 4192: Acquired the start mutex.
[Wed Nov 16 22:03:26 2011] [notice] Child 4192: Starting 150 worker threads.
[Wed Nov 16 22:03:26 2011] [notice] Child 4192: Listening on port 443.
[Wed Nov 16 22:03:26 2011] [notice] Child 4192: Listening on port 443.
[Wed Nov 16 22:03:26 2011] [notice] Child 4192: Listening on port 80.
[Wed Nov 16 22:03:26 2011] [notice] Child 4192: Listening on port 80.


and access log:
Code: Select all
127.0.0.1 - - [16/Nov/2011:22:03:26 -0500] "GET /xampp/ HTTP/1.1" 200 594 "http://community.apachefriends.org/f/viewtopic.php?f=16&t=48987" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:26 -0500] "GET /favicon.ico HTTP/1.1" 200 7782 "-" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:26 -0500] "GET /xampp/head.php HTTP/1.1" 200 1393 "http://127.0.0.1/xampp/" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:26 -0500] "GET /xampp/start.php HTTP/1.1" 200 866 "http://127.0.0.1/xampp/" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:26 -0500] "GET /xampp/navi.php HTTP/1.1" 200 4606 "http://127.0.0.1/xampp/" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:27 -0500] "GET /xampp/xampp.css HTTP/1.1" 200 4178 "http://127.0.0.1/xampp/head.php" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:27 -0500] "GET /xampp/img/head-for.gif HTTP/1.1" 200 791 "http://127.0.0.1/xampp/head.php" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:27 -0500] "GET /xampp/img/head-windows.gif HTTP/1.1" 200 1362 "http://127.0.0.1/xampp/head.php" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:27 -0500] "GET /xampp/img/xampp-logo-new.gif HTTP/1.1" 200 4878 "http://127.0.0.1/xampp/head.php" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:27 -0500] "GET /xampp/img/apachefriends.gif HTTP/1.1" 200 979 "http://127.0.0.1/xampp/navi.php" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:05:49 -0500] "GET /xampp/ HTTP/1.1" 200 594 "http://community.apachefriends.org/f/viewtopic.php?f=16&t=48987" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:05:50 -0500] "GET /xampp/head.php HTTP/1.1" 200 1393 "http://127.0.0.1/xampp/" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:05:50 -0500] "GET /xampp/start.php HTTP/1.1" 200 866 "http://127.0.0.1/xampp/" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:05:50 -0500] "GET /xampp/navi.php HTTP/1.1" 200 4606 "http://127.0.0.1/xampp/" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"
127.0.0.1 - - [16/Nov/2011:22:03:27 -0500] "GET /xampp/xampp.js HTTP/1.1" 200 573 "http://127.0.0.1/xampp/navi.php" "Mozilla/5.0 (Windows NT 6.0; rv:8.0) Gecko/20100101 Firefox/8.0"


For MYSQL
Error Log:
Code: Select all
111116 22:02:44 [Note] C:\xampp\mysql\bin\mysqld.exe: Normal shutdown

111116 22:02:44 [Note] Event Scheduler: Purging the queue. 0 events
111116 22:02:44  InnoDB: Starting shutdown...
111116 22:02:45  InnoDB: Shutdown completed; log sequence number 1595675
111116 22:02:45 [Note] C:\xampp\mysql\bin\mysqld.exe: Shutdown complete

111116 22:03:15 [Note] Plugin 'FEDERATED' is disabled.
111116 22:03:15 InnoDB: The InnoDB memory heap is disabled
111116 22:03:15 InnoDB: Mutexes and rw_locks use Windows interlocked functions
111116 22:03:15 InnoDB: Compressed tables use zlib 1.2.3
111116 22:03:15 InnoDB: Initializing buffer pool, size = 16.0M
111116 22:03:15 InnoDB: Completed initialization of buffer pool
111116 22:03:15 InnoDB: highest supported file format is Barracuda.
111116 22:03:16  InnoDB: Waiting for the background threads to start
111116 22:03:17 InnoDB: 1.1.8 started; log sequence number 1595675
111116 22:03:18 [Note] Event Scheduler: Loaded 0 events
111116 22:03:18 [Note] C:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.16'  socket: ''  port: 3306  MySQL Community Server (GPL)
hpeleo
 
Posts: 5
Joined: 17. November 2011 01:28
Operating System: Windows Vista

Re: access to HTTP localhost slow to load but HTTPS is very

Postby Sharley » 17. November 2011 04:31

The error.log is normal and so I will reduce it to the tail (last start of Apache) as requested.

The access.log file shows Apache is sending requested files from the server without any delays.
Check the time difference between each file request and the next file request to be sent in a squence.

So the delay is somewhere between the Apache server and your browser (Firefox predominantly).

The MySQL error.log file is also normal and I will reduce it to the tail section only (last start of MySQL) and merge it with your last post so it is more easily read.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: access to HTTP localhost slow to load but HTTPS is very

Postby hpeleo » 17. November 2011 04:41

Ok, this seems weird but for some reason on Google Chrome everyything is fine. Is there a setting on firefox that will make xampp to work and load fast?
hpeleo
 
Posts: 5
Joined: 17. November 2011 01:28
Operating System: Windows Vista

Re: access to HTTP localhost slow to load but HTTPS is very

Postby Sharley » 17. November 2011 04:43

The best and probably the quickest method would be to ask on a good Firefox forum.

In the meantime I will take a look at FF8 and see what I can find.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: access to HTTP localhost slow to load but HTTPS is very

Postby Sharley » 17. November 2011 04:52

OK, it might be quicker here than the Mozilla forums.

Type about:config in your FF browser.

Then type IPv6 in the text box and you should see this:
Code: Select all
network.dns.disableIPv6;false

Right click and select Toggle and it will show True.
Close the Tab and FF.

Restart FF and try again.

If no difference then you know how to reverse the setting.

Let me know back if it helps.

Good luck.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: access to HTTP localhost slow to load but HTTPS is very

Postby hpeleo » 17. November 2011 05:07

Hi , I Just tried that and no change to firefox.
hpeleo
 
Posts: 5
Joined: 17. November 2011 01:28
Operating System: Windows Vista

Re: access to HTTP localhost slow to load but HTTPS is very

Postby Sharley » 17. November 2011 05:11

OK, well try the FF forums and see if there is anyone there who can help.

Let us know here if you find the solution please so it might help other members and readers.

Thanks and good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: access to HTTP localhost slow to load but HTTPS is very

Postby Sharley » 17. November 2011 06:13

Here is another known fix.

Same as before type about:config and then type this in the text box IPv
and you should then see this line
Code: Select all
network.dns.ipv4OnlyDomains;

Right click and type Modify and add localhost
Close, restart FF and then try and access localhost again.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 56 guests