Localhost Will Not Load (Win7U64) 1.7.7 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Localhost Will Not Load (Win7U64) 1.7.7 [SOLVED]

Postby BeratzGashi » 16. November 2011 20:55

when is the release of xampp and services to appear this issue
see in the picture below

Image

and when Google Chrome issue with localhost in it only appears

Mod - See next post, no response, image link deleted for incorrect size

i need help with this please
BeratzGashi
 
Posts: 10
Joined: 16. November 2011 20:44
Operating System: Windows 7 Ultimate (x64)

Re: Guys i need help on this please!

Postby Sharley » 16. November 2011 23:57

Please resize your screen cap image as outlined in item 7 of this forum announcement that you did read didn't you: :shock:
viewtopic.php?f=16&t=48331


First try and use http://127.0.0.1 to access using Chrome and if that works then try the following fix:

Open C:\Windows\system32\drivers\etc\hosts file in your text editor (right click on notepad and Run as administrator) then uncomment this line so it looks like this
Code: Select all
127.0.0.1 localhost
#::1 localhost
The first 2 lines after all the commented tags should look like the above now - save the file using any file *.* not as *.txt file.
Often a reboot after this edit helps.

Try again to access localhost in your Chrome browser.


Are there any clues in the \xampp\apache\logs\error.log file?

Have you tried using another browser other than Chrome, for example, Internet Explorer or Firefox?

Have you ZoneAlarm or similar security software that you can temporarily disable?

Have you allowed the ports that Apache and MySQL use to pass through any firewalls you may have?

Read this FAQ item and instigate the recommendation offered:
http://www.apachefriends.org/en/faq-xam ... s.html#cpu

Do you have this program installed on your PC?
viewtopic.php?p=182895#p182895
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Guys i need help on this please!

Postby JonB » 17. November 2011 00:29

I see a Firfefox tab there - is the problem limited to Chrome???

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Guys i need help on this please!

Postby BeratzGashi » 17. November 2011 12:04

Sharley wrote:Please resize your screen cap image as outlined in item 7 of this forum announcement that you did read didn't you: :shock:
http://community.apachefriends.org/f/viewtopic.php?f=16&t=48331


First try and use http://127.0.0.1 to access using Chrome and if that works then try the following fix:

Open C:\Windows\system32\drivers\etc\hosts file in your text editor (right click on notepad and Run as administrator) then uncomment this line so it looks like this
Code: Select all
127.0.0.1 localhost
#::1 localhost
The first 2 lines after all the commented tags should look like the above now - save the file using any file *.* not as *.txt file.
Often a reboot after this edit helps.

Try again to access localhost in your Chrome browser.


Are there any clues in the \xampp\apache\logs\error.log file?

Have you tried using another browser other than Chrome, for example, Internet Explorer or Firefox?

Have you ZoneAlarm or similar security software that you can temporarily disable?

Have you allowed the ports that Apache and MySQL use to pass through any firewalls you may have?

Read this FAQ item and instigate the recommendation offered:
http://www.apachefriends.org/en/faq-xampp-windows.html#cpu

Do you have this program installed on your PC?
http://community.apachefriends.org/f/viewtopic.php?p=182895#p182895


I tried but none of these worked: S

Any help please
BeratzGashi
 
Posts: 10
Joined: 16. November 2011 20:44
Operating System: Windows 7 Ultimate (x64)

Re: Guys i need help on this please!

Postby BeratzGashi » 17. November 2011 12:06

JonB wrote:I see a Firfefox tab there - is the problem limited to Chrome???

8)


not working in: Google Chrome, Firefox, Opera, Internet Explorer
BeratzGashi
 
Posts: 10
Joined: 16. November 2011 20:44
Operating System: Windows 7 Ultimate (x64)

Re: Guys i need help on this please!

Postby JonB » 17. November 2011 16:54

If its not working in any browser, its probably one of two things (IMO)

A. DNS/Hosts related. So, my first suggestion would be to 're-enable' the ::1 localhost line in the hosts file. The two lines are actually used independently by the MS dnsresolver.

B. A firewall issue of some sort. If teh servers are running, its not a port conflict - so 'something' is preventing that connection

What happens if you open a command window and Ping 127.0.0.1 or ::1???

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Guys i need help on this please!

Postby BeratzGashi » 17. November 2011 17:51

when i ping 127.0.0.1 showing this

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\BeraTi>Ping 127.0.0.1

Pinging 127.0.0.1 with 32 bytes of data:
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128
Reply from 127.0.0.1: bytes=32 time<1ms TTL=128

Ping statistics for 127.0.0.1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Users\BeraTi>
BeratzGashi
 
Posts: 10
Joined: 16. November 2011 20:44
Operating System: Windows 7 Ultimate (x64)

Re: Guys i need help on this please!

Postby JonB » 17. November 2011 18:00

OK - that's good - we know 127.0.0.1 is listening correctly

now try

ping http://localhost


Did you 'turn on' ::1 in the hosts file???

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Guys i need help on this please!

Postby BeratzGashi » 17. November 2011 18:35

how to do this "Did you 'turn on' ::1 in the hosts file???" can you be more clearly please

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\BeraTi>ping localhost

Pinging BeraTi-PC [::1] with 32 bytes of data:
Reply from ::1: time<1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms

Ping statistics for ::1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Users\BeraTi>
BeratzGashi
 
Posts: 10
Joined: 16. November 2011 20:44
Operating System: Windows 7 Ultimate (x64)

Re: Guys i need help on this please!

Postby JonB » 17. November 2011 22:02

Well we now now that Windows thinks 'localhost' is ::1

OK this seems to be a known issue -

Google "windows 7 64 bit hosts file ignored"

http://answers.microsoft.com/en-us/wind ... 35a42b1728


http://answers.microsoft.com/en-us/wind ... ecd2ff7d97

"Instructions"
2. Type this command using run or a command window

notepad %SystemRoot%\System32\drivers\etc\hosts.


could you post the contents of that file???

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Localhost Will Not Load (Win7U64) 1.7.7

Postby BeratzGashi » 18. November 2011 13:44

the content

# Copyright (c) 1993-2009 Microsoft Corp.
#
# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.
#
# This file contains the mappings of IP addresses to host names. Each
# entry should be kept on an individual line. The IP address should
# be placed in the first column followed by the corresponding host name.
# The IP address and the host name should be separated by at least one
# space.
#
# Additionally, comments (such as these) may be inserted on individual
# lines or following the machine name denoted by a '#' symbol.
#
# For example:
#
# 102.54.94.97 rhino.acme.com # source server
# 38.25.63.10 x.acme.com # x client host

# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
# ::1 localhost
BeratzGashi
 
Posts: 10
Joined: 16. November 2011 20:44
Operating System: Windows 7 Ultimate (x64)

Re: Localhost Will Not Load (Win7U64) 1.7.7

Postby JonB » 18. November 2011 16:39

OK that means that localhost does not point to 127.0.0.1

you need to edit that file again

Code: Select all
# 127.0.0.1 localhost


change to:

Code: Select all
127.0.0.1 localhost


Save the file

Reboot, and see if it works

IF it doesn't - check the file to see if your save "took" or not.

Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Localhost Will Not Load (Win7U64) 1.7.7

Postby BeratzGashi » 18. November 2011 17:38

file saved but not working again :S
BeratzGashi
 
Posts: 10
Joined: 16. November 2011 20:44
Operating System: Windows 7 Ultimate (x64)

Re: Localhost Will Not Load (Win7U64) 1.7.7

Postby JonB » 18. November 2011 18:24

OK try the "ping http://localhost" command again - and please post what they response is

Thanks

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Localhost Will Not Load (Win7U64) 1.7.7

Postby BeratzGashi » 19. November 2011 01:41

ping results

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\BeraTi>ping localhost

Pinging BeraTi-PC [::1] with 32 bytes of data:
Reply from ::1: time<1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms
Reply from ::1: time<1ms

Ping statistics for ::1:
Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
Minimum = 0ms, Maximum = 0ms, Average = 0ms

C:\Users\BeraTi>
BeratzGashi
 
Posts: 10
Joined: 16. November 2011 20:44
Operating System: Windows 7 Ultimate (x64)

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests