XAMPP slow

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 21:22

I looked in my.ini file and found things about "InnoDB" which was mentioned in the error log. Also in "phpMyAdmin" the tables are of InnoDB type.

Code: Select all
# Uncomment the following if you are using BDB tables
#bdb_cache_size = 4M
#bdb_max_lock = 10000

# Comment the following if you are using InnoDB tables
#skip-innodb
innodb_data_home_dir = "C:/ke-program/xampp/mysql/data"
innodb_data_file_path = ibdata1:10M:autoextend
innodb_log_group_home_dir = "C:/ke-program/xampp/mysql/data"
#innodb_log_arch_dir = "C:/ke-program/xampp/mysql/data"
## You can set .._buffer_pool_size up to 50 - 80 %
## of RAM but beware of setting memory usage too high
innodb_buffer_pool_size = 16M
innodb_additional_mem_pool_size = 2M
## Set .._log_file_size to 25 % of buffer pool size
innodb_log_file_size = 5M
innodb_log_buffer_size = 8M
innodb_flush_log_at_trx_commit = 1
innodb_lock_wait_timeout = 50
Last edited by Saverit Otogo on 17. November 2011 21:43, edited 1 time in total.
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Sharley » 17. November 2011 21:39

I have the same items in red and I don't have any databases only the defaults when I installed XAMPP.

I don't seem to be able to find an 'Engines' selection in the top row of phpMyAdmin, could you point me to where you see this message?

Have you checked that your Joomla version is compatible with the versions included in XAMPP?
The version numbers can be found in the readme_en.txt file in the xampp folder.

I have installed XAMPP in a catalogue:
C:\catalogue\xampp
Have you moved XAMPP to another location or have you more than one XAMPP installation?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 21:57

I now have found the "overhead" title!
Ok, I have only "-" marked there.

I have looked at the databases that came with the installation. Some of them are of MyISAM type. I have not found any with "InnoDB" type as I have for the Joomla tables.

To find Engines: localhost/phpmyadmin >> Upper meny row (far to the right, you may have to select the "more" button go get to see "Engines").

Summary: There seems to be inconsisties in Federated and InnoDB. Maybe some setting have to be changed.

1. InnoDB: I guess InnoDB should be activated in my.ini properly. Something seems to go wrong with InnoDB tables, if one looks at the mysql error log. Also, I can not run the CD Colletion example.

2. Federated: PhpMyAdmin states Federated storage engine but my.ini states "skip-federated" which I interpret as it is not activated. I tried to comment it with a "#" in front, but then mysql crashes at the first query. In the my sql error log I get "111107 15:18:08 [Note] Plugin 'FEDERATED' is disabled." which further makes me think something is going wrong with federated.
Last edited by Saverit Otogo on 18. November 2011 13:23, edited 3 times in total.
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Sharley » 17. November 2011 22:15

The cdcol demo database table uses innodb as does the webauth database tables.

Normally there should be no need to change the my.ini file from the defaults to get Joomla working correctly and as I said perhaps the Joomla forum can throw more light on the subject.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 22:52

1. Oh, the CD Collection did not work for me! I get the following message: "Could not connect to database!
Is MySQL running or did you change the password?"

I can not find webauth example.

2. I have increased settings for the my.ini file i looked att the my-large.ini for inspiration, but there were several differences so I can not say I felt convinced I did the right thing. When I at the end also increased innodb_ variables mysql would not start any longer, so now i am back with the initial my.ini.

3. I earlier checked that the requirements for PHP and MySQL were met for Joomla. I have Joomla 1.7.2. PHP 5.3.8 and phpMyAdmin 3.4.5. All are recent versions so there should not be a problem. phpMyAdmin says there is a newer version (3.4.7.1), but I have not updated, because I guess I will run into trouble trying to update something inclueded in the XAMPP package.

MySQL
Server: localhost via TCP/IP
Server version: 5.5.16
Protocol version: 10

4. By the way, Is not there any way one can increase the time out length of phpMyAdmin?
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Sharley » 17. November 2011 23:16

The cdcol will not work after you set a password for MySQL and phpMyAdmin.

The cdcol and (webauth is in a default 1.7.7 installation - did you delete it?) are examples that innodb and myisam can coexists.


Can you give me some history about how you installed Joomla in 1.7.7?
Was it a fresh install or did you copy it from elsewhere?

This page seems to say it's fine for Joomla 1.7.2 and XAMPP 1.7.7:
http://www.joomla.org/about-joomla/tech ... ments.html
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Sharley » 17. November 2011 23:33

Any answer to the XAMPP location question here:
viewtopic.php?p=188768#p188768
as this path in the my.ini file differs:
Code: Select all
innodb_data_home_dir = "C:/ke-program/xampp/mysql/data"
from this:
Code: Select all
I have installed XAMPP in a catalogue:
C:\catalogue\xampp
There is a fix for this if indeed the my.ini file is incorrect.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Saverit Otogo » 18. November 2011 12:05

Thanks for beeing attentive! But I am sorry, Actually the catalogue is ke-program. I changed the name to catalogue as an attempt be pedagogic in the beginning. I wanted to state the location of the installation, because somewhere I had read that one is recommended to install xampp in a root catalogue, but I have installed it in a subcatalogue to the root. I did not do the installation in the windows standard directory "C:/Program (x86).
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Saverit Otogo » 18. November 2011 12:29

I installed Joomla 1.7.2 by downloading the Stable Full package from the Joomla site. I then uncompressed the zip file. I put the catalogues and files in the xampp/htdocs directory, becoming "xampp/htdocs/Joomla_1.7.2-Stable-Full_Package" (unfortunately I did not change the name to simply Joomla). I think I then opened some file in a web browser where the installation was made. I chose the recommended setting database type MySQLi (improved mysql) ( http://docs.joomla.org/Installing_Joomla!_1.7 ). I never imported a mysql database for my new installation, instead I worked directly on the standard installation example (modifying it to my needs).

The database I had locally in XAMPP was exported to a Joomla installation of the same version (Joomla 1.7.2), but situated on a server on the web. Then Joomla worked better. Therefore I do not think the MySQL tables per see are defective.
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Saverit Otogo » 18. November 2011 12:33

The cdcol will not work after you set a password for MySQL and phpMyAdmin.

The cdcol and (webauth is in a default 1.7.7 installation - did you delete it?) are examples that innodb and myisam can coexists.


I set password because it was recommended in order to assure security. Can I remove the passwords with preserved security (from outside attacks)? I am on ADSL with a modem that claims to have a firewall.

I have webauth in the mysql database, but I can not find it in the XAMPP starting page. Where should it be located in the left meny? Is it under PHP, Perl, ...
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby songoo » 16. December 2011 02:24

Turn off microsoft essentials MsMpEng is fighting apache.

Or if you feel unsafe add to MSE exclude
C:\ProgramData\Microsoft\Microsoft Antimalware
C:\ProgramData\Microsoft\Microsoft Security Essentials
C:\Program Files\Microsoft Security Essentials
songoo
 
Posts: 1
Joined: 16. December 2011 02:21
Operating System: w 7

Re: XAMPP slow

Postby Saverit Otogo » 16. December 2011 04:43

Thank you a lot for advise! :)

I will remember this for the future. Now, I recently installed WampServer and then I can run Joomla without problems (it seems at last). Although the "user interface" does not show up as seen on the images on http://sourceforge.net/projects/wampserver/ ,I can run localhost in the webbrowser.
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Sharley » 16. December 2011 04:52

This topic is now closed as the OP is no longer using XAMPP for Windows.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests