XAMPP slow

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP slow

Postby Saverit Otogo » 16. November 2011 14:18

I have installed XAMPP on my computer in order to locally edit and modify a Joomla homepage. When I want to save my edits in Joomla, it takes a very long time. I guess the problem then is that it takes a long time to update the SQL database. Can I increase speed? Now, it is so slow that I chose to edit the pages directly online, but I would like to do it online.

I only want to work locally on my computer with Joomla (XAMPP).

In the XAMPP Control Panel I start Apache and MySQL, I have tried with the Svc alternative.

I am a newbie to XAMPP.

Note: I am often timed out in the phpMyAdmin. Can I change the setting so I am not timed out and have to log in again?

DATA

XAMPP 1.7.7
Windows 7 64 bit
Microsoft Security Essentials
Joomla 1.7.2

XAMPP status:
Activated: SQL database, PHP, SSL, SSI
Deactivated: SMTP, FTP, Tomcat

XAMPP security:
These XAMPP pages are no longer accessible by network for everyone SECURE
The MySQL admin user root has no longer no password SECURE
PhpMyAdmin password login is enabled. SECURE
PHP is NOT running in "safe mode" UNSECURE
A FTP server is not running or is blocked by a firewall! UNKNOWN
A POP3 server like Mercury Mail is not running or is blocked by a firewall! UNKNOWN

I have installed XAMPP in a catalogue:
C:\catalogue\xampp

Joomla installation is here:
C:\catalogue\xampp\htdocs\Joomla
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Sharley » 16. November 2011 23:53

There could many and varied reasons why you are finding accessing your database is slow.

How big is your Joomla database?
\xampp\mysql\data folder contains your Joomla database for checking the size if required.
I use a program called TreeSize Pro to show the size of all folders in Explorer, very handy.
There is a freeware version here:
http://www.jam-software.com/treesize_free/

Are there any errors in your database?
Click on your Joomla database in phpMyAdmin and check the overhead column.
Down at the bottom of the list of Tables is a drop box that contains various selections to aid in fixing table issues.

In \xampp\mysql\ folder are various alternative my.ini files that are suited to higher system resources - the default my.ini in the bin folder has settings for low resource computers.

Perhaps you could experiment with using a higher resource my.ini file - make a backup copy of the original my.ini so you have a fall back known good my.ini file.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 17:03

Thank you for your kind reply! :) I will go through your suggestions stepwise. Now I have checked the size of the size of /xampp/mysql/data with TreeSize. Will come back when done the next suggestion.

Jam Software TreeSize Free is great. That is the kind of program that one has always wanted and one has always wondered why Microsoft does not inclued that function in their operative system.

Result of TreeSize

catalogue: xampp/mysql/data 39,5 MB
files: xampp/mysql/data (without subcatalogues) 6 files 36 MB,
file: xampp/mysql/data/ibdata1 26 MB
file: xampp/mysql/data/ib_logfile0 5,0 MB
file: xampp/mysql/data/ib_logfile1 5,0 MB

cat: xampp/mysql/data/mysql 2,5 MB
file: xampp/mysql/data/time_zone_transition.MYI 0,7 MB
file: xampp/mysql/data/time_zone_transition.MYD 0,6 MB
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 17:27

I have opened phpMyAdmin for my local XAMPP installation. I select the Joomla MySQL database. I find no place with messages of errors. I try to find, I do not find, maybe I do not know where to look. :'(

Result: The size of the 34 tables is 3,4 MiB.

Are there versions of MySQL? Is there something like MySQLi? I have some memory of selecting MySQLi (MySQL Improved?) at some point. I do not remember if it was for this database though. Can I check what version I have?
Last edited by Saverit Otogo on 17. November 2011 20:56, edited 1 time in total.
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 18:33

I have no my.ini file

/xampp/mysql/my.ini does not exist in my installation.

I have my-huge.ini, my-large.ini, my-medium.ini, my-small.ini only.

I have 4 GB (3,79 usable). Intel i3 2,27 GHz. Now when XAMPP is running Apache and MySQL, the 68% of RAM is used.

What shall I do now ?

Summary:
1. I do not have a my.ini file.
2- I did not find how to check the Joomla MySQL database for errors with phpMyAdmin.
Last edited by Saverit Otogo on 17. November 2011 18:47, edited 1 time in total.
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Sharley » 17. November 2011 18:45

I have no my.ini file

/xampp/mysql/my.ini does not exist in my installation.

Sharley wrote:the default my.ini in the bin folder
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 18:50

OK! I did not read your text carefully enough I realize now. I then rename my.ini to my.ini.old and copy my-large.ini to bin directory where I rename it to my.ini. Do you think my-huge.ini would work on my computer?

I have Intel® Core™ i3-350M Processor (3M Cache, 2.26 GHz) i guess.
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Sharley » 17. November 2011 18:54

You have to use those alternate my.ini files on a trial basis and see which if any make a difference.

This is not a guarantee that an alternate my.ini will fix your issue.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 18:59

Shall I uncomment skip-networking? I only work on my own computer.

I now have:
#skip-networking
skip-federated

I have some directory pathways in the my.ini so I guess I will change the settings manually instead of exhanging the file.

I looked in mysql_error.log and saw this several times. Does it give you any clues?
Code: Select all
111107 15:18:08 [Note] Plugin 'FEDERATED' is disabled.
111107 15:18:08 InnoDB: The InnoDB memory heap is disabled
111107 15:18:08 InnoDB: Mutexes and rw_locks use Windows interlocked functions
111107 15:18:08 InnoDB: Compressed tables use zlib 1.2.3
111107 15:18:08 InnoDB: Initializing buffer pool, size = 16.0M
111107 15:18:08 InnoDB: Completed initialization of buffer pool
111107 15:18:08 InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
111107 15:18:08  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
Last edited by Saverit Otogo on 17. November 2011 19:07, edited 1 time in total.
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Sharley » 17. November 2011 19:05

I find no place with messages of errors.
Sharley wrote:Click on your Joomla database in phpMyAdmin and check the overhead column.
The overhead column should be free of any entries if the tables are free of errors or overheads - also the total size of all the overheads is defined in the last line.
If you have overheads they can be fixed using the drop box selections.

You do have a backup of your own databases?
Is Joomla the only database you created?

You can try skip-networking also, remember to restart MySQL after editing or replacing the my.ini files.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Sharley » 17. November 2011 19:10

Just as a test go to http://localhost and when you see the Welcome page run all the demos and see if they are also slow to run.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Sharley » 17. November 2011 19:22

Could you add to your error.log file entry above the rest of that sequence of events as it may also hold important information.

Database corruption can occur if a power cut or similar power outage or unexpected system shut down occurred when the database was being accessed.

Try the recommendations here for your innodb error log file message:
http://forums.devshed.com/mysql-help-4/ ... 89178.html

Copy and paste this in a Google search box may also find results:
InnoDB: The log sequence number in ibdata files does not match

This may be the reason for the slow down but until you try all the avenues it will be hard to pinpoint the actual cause.

Good luck again. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 20:45

I have tried the examples found via "http://localhost/xampp/", I have also navigated in Joomla. The following are the added errors in the "mysql_error.log" file. I do not think the examples are slow to run. Sometimes some pages are slow to load. But I do not have experience of what is normal. Here the the current is stable. Also i run a laptop so I am further protected.

Code: Select all
111117 17:07:06 [Note] Plugin 'FEDERATED' is disabled.
111117 17:07:06 InnoDB: The InnoDB memory heap is disabled
111117 17:07:06 InnoDB: Mutexes and rw_locks use Windows interlocked functions
111117 17:07:06 InnoDB: Compressed tables use zlib 1.2.3
111117 17:07:06 InnoDB: Initializing buffer pool, size = 16.0M
111117 17:07:06 InnoDB: Completed initialization of buffer pool
111117 17:07:07 InnoDB: highest supported file format is Barracuda.
InnoDB: The log sequence number in ibdata files does not match
InnoDB: the log sequence number in the ib_logfiles!
111117 17:07:07  InnoDB: Database was not shut down normally!
InnoDB: Starting crash recovery.
InnoDB: Reading tablespace information from the .ibd files...
InnoDB: Restoring possible half-written data pages from the doublewrite
InnoDB: buffer...
111117 17:07:09  InnoDB: Waiting for the background threads to start
111117 17:07:10 InnoDB: 1.1.8 started; log sequence number 10861247
111117 17:07:12 [Note] Event Scheduler: Loaded 0 events
111117 17:07:12 [Note] mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.16'  socket: ''  port: 3306  MySQL Community Server (GPL)
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Re: XAMPP slow

Postby Sharley » 17. November 2011 20:56

The error.log file now looks normal for MySQL when it starts.

The demos seem to work without delays.

That only leaves the Joomla database (installation).

Might I suggest you search the Joomla forums for a post with a similar issue and if you don't find one then try a post in their forums to see if anyone there can assist - we seem to have covered all the bases in XAMPP so they may be able to offer some assistance.

Please post back here if you finally pinpoint the cause, thanks.

Sorry I can't be of more help.

Best wishes. :).
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP slow

Postby Saverit Otogo » 17. November 2011 21:06

I found something that I think may be important. In phpMyAdmins I select "Engines" in the top row. Then I get "FEDERATED Federated MySQL storage engine". Is this not in clonflict with the my.ini file that states "skip-federated"?

When looking in phpMyAdmin "Runtime information" (via Status in the top row) I get red on the following things:

Code: Select all
Innodb_buffer_pool_reads    518    
Handler_read_rnd   783    
Handler_read_rnd_next   7.4 k
Created_tmp_disk_tables  123   
Key_reads    9
Select_full_join    22    
Opened_tablesDocumentation    147    
Saverit Otogo
 
Posts: 15
Joined: 16. November 2011 13:48
Operating System: Windows 7 (64 bit)

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests