1.7.7 - A few problems with MySQL (Vista/Win7) [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

1.7.7 - A few problems with MySQL (Vista/Win7) [SOLVED]

Postby RussianAndrey » 13. November 2011 18:56

Hello,
I have just installed XAMPP using the .zip package and successfully run the setup_xampp.bat file. I started the XAMPP Control Panel 3 v. 3.0.2 and started the Apache and MySQL.

On the status page, it indicates that MySQL database DEACTIVATED and when trying to enter PhpMyAdmin, i get this error:
Code: Select all
#2002 – The server is not responding (or local MySQL server's socket is not correctly configured)

Connection for controluser as defined in your configuration failed.


How can I fix this to make PhpMyAdmin and the rest work?
RussianAndrey
 
Posts: 2
Joined: 13. November 2011 18:44
Operating System: Windows Vista

Re: XAMPP 1.7.7 - A few problems with MySQL

Postby Sharley » 13. November 2011 23:58

Try this:
Open \xampp\mysql\my.ini file in your text editor and find this line and remove the # character from the start of the line
#bind-address="127.0.0.1"
Save the file and try and start MySQL again.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP 1.7.7 - A few problems with MySQL

Postby RussianAndrey » 14. November 2011 16:17

Sharley wrote:Try this:
Open \xampp\mysql\my.ini file in your text editor and find this line and remove the # character from the start of the line
#bind-address="127.0.0.1"
Save the file and try and start MySQL again.

Good luck. :)


THANK YOU VERY MUCH. It works! :wink:
RussianAndrey
 
Posts: 2
Joined: 13. November 2011 18:44
Operating System: Windows Vista

Re: XAMPP 1.7.7 - A few problems with MySQL

Postby Fantosh » 14. November 2011 21:08

Sharley wrote:Try this:
Open \xampp\mysql\my.ini file in your text editor and find this line and remove the # character from the start of the line
#bind-address="127.0.0.1"
Save the file and try and start MySQL again.

Good luck. :)



hey!!! I got registered here cuz' I hav' this same issue, damn!!! man u are a God!!! :o lol after register in this web, I lost 2 Days with not luck on google search!! , Thanks !!!!!!! man!!! Blesses from Panama, and sorry fi my english!! :mrgreen: :P
Fantosh
 
Posts: 1
Joined: 14. November 2011 21:00
Operating System: Windows 7 Enterprise

Re: XAMPP 1.7.7 - A few problems with MySQL

Postby Sharley » 14. November 2011 22:47

Thanks for all the feedback. 8)

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests