Thank You - Sharley

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Thank You - Sharley

Postby tcas » 12. November 2011 16:15

Wanted to say thank you to Sharley for the excellent walk through regarding setting up multiple virtual sites on windows XP with Xampp. It took me a couple of days to find all my mistakes, but without this excellent explanation and error checking methods, I would still be in the dark.

I did have to modify the htppd.conf file to allow access to the virtual directories, but all is working at this time.

Thank you, Sharley

michael
tcas
 
Posts: 3
Joined: 12. November 2011 16:02
XAMPP Version: 5.6.3
Operating System: xp pro svc pk 3

Re: Thank You - Sharley

Postby Sharley » 12. November 2011 18:45

Hello Michael,

Thank you for your kind words but...

...there should be no need to edit the httpd.conf file by changing the default directory access directive which may pose a security risk by giving access to directories via the server to all the directories on your PC.

Individual VirtualHost directories have their own access directives set and opening the whole directory structure using the default httpd.conf setting is not the way to go.

Perhaps you would like to return the httpd.conf file to it's default state and then paste here your httpd-vhosts.conf file so I can see what may have caused you to change the wrong setting.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Thank You - Sharley

Postby tcas » 13. November 2011 15:02

Sharley,

Original post still stands...

As you suggested, I returned htppd.conf file to orginal.

I was trying to get a Joomla site working in vhosts without much luck. I set up 2nd vhost with a straight html site and worked like a charm. Realizing I have problems with Jsite, I worked on index.php page for site and it now loads in vhost.

Having problems with menu displaying any page except index.php. (menu is PopMenuMagic2 from projectseven.com)

Most of my issues result from my lack of knowledge. I am trying to take the jsite back to straight html because of all my hacking.

Will be glad to post any code that you would like to see, but I realize you cover a lot of bases here and may not have time to "hand-hold" people like me :)

Not a web designer...just trying to help a friend with his site. The jsite works fine on the web www.exhortationplace.com, but as above, on vhosts, just index page loads.

regards,
michael
tcas
 
Posts: 3
Joined: 12. November 2011 16:02
XAMPP Version: 5.6.3
Operating System: xp pro svc pk 3

Re: Thank You - Sharley

Postby tcas » 13. November 2011 20:41

All is well...and virtual hosts working as you described.

All problems were direct result of my doing...

Thank you, Sharley for your help to this community and in this case, to myself

michael
tcas
 
Posts: 3
Joined: 12. November 2011 16:02
XAMPP Version: 5.6.3
Operating System: xp pro svc pk 3

Re: Thank You - Sharley

Postby Sharley » 14. November 2011 00:19

You're most welcome and thanks once again for your feedback. 8)

Sometimes we can't see the wood for the trees. ;)

I am pleased you found a solution and you can now move forward.

Good luck and best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
XAMPP Version: 5.6.3
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 44 guests