bug in XAMPP 1.7.7

Problems with the Windows version of XAMPP, questions, comments, and anything related.

bug in XAMPP 1.7.7

Postby Rankxerox1984 » 12. November 2011 14:53

Hi all again:

This a second part for a before post which disapear (or I can't find) I have the following XAMPP version:

###### ApacheFriends XAMPP version 1.7.7 ######

+ Apache 2.2.21
+ MySQL 5.5.16 (Community Server)
+ PHP 5.3.8 (VC9 X86 32bit thread safe) + PEAR
+ XAMPP Control Panel Version 2.5 from www.nat32.com
+ (BETA) XAMPP Control Panel Version 3.0.2 by Steffen Strueber (not in the USB & lite version)
see http://community.apachefriends.org/f/viewtopic.php?f=16&t=46743
+ XAMPP Security
+ OpenSSL 1.0.0e
+ phpMyAdmin 3.4.5
+ ADOdb 5.14
+ Mercury Mail Transport System v4.62 (not in the USB & lite version)
+ FileZilla FTP Server 0.9.39 (not in the USB & lite version)
+ Webalizer 2.23-04 (not in the USB & lite version)
+ Perl 5.10.1 (not in the USB & lite version)
+ Mod_perl 2.0.4 (not in the USB & lite version)
+ Tomcat 7.0.21 (not in the USB & lite version)

As declared in the XAMPP/Readme_en file and what is happening is a consecuence to try delaing with Symfony 2.0.5.
When I installed Xampp everything goes right, I made the changes in passwords recomended and so on. But when I try to proceed with Symfony is required to change Short_open_tag to Off when I make this change Xampp gives me this error:
Warning: Variable passed to each() is not an array or object in C:\xampp\htdocs\xampp\head.php on line 27
The main part of the XAMPP screens dissapear and shows an ! and the main tittle changes to Xampp fürfor Windows.
If I revert the edit in the php.ini to short_open_tags=On, Xampp recover his original aspect
My system is Running Windows7 with all teh patches and SP already installed.

Please shall somebody give me a solution?

Many thanks in advance for your effort, time and dedication,

J.
Rankxerox1984
 
Posts: 16
Joined: 25. October 2010 18:04
Operating System: MS Windows 7

Re: bug in XAMPP 1.7.7

Postby Altrea » 12. November 2011 16:33

There is no solution. The XAMPP Administration page needs short_open_tags to be set to On. Symfony should work with that too. It is just a recommandation.

One alternative can be to use a .htaccess file in your \xampp\htdocs\xampp\ folder (DON'T overwrite any existent .htaccess file in that folder if existent!) with the following contents:
Code: Select all
php_flag short_open_tag on


btw: just click on your name in any thread to get to all your posts you made here. I will be sure your post can be found there if not deleted.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: bug in XAMPP 1.7.7

Postby Rankxerox1984 » 12. November 2011 18:43

Many thanks Altrea

Do you mean if I edit the .htaccess adding the line you suggested I could edit Short_open_tags to Off in php.ini and everything will work well?
Please, where I need to place this line, anywhere in the file?
Also you meant Symfony will work without any issue even if I don't follow their recommendations?

Thanks for your quick answer :)

J.
Rankxerox1984
 
Posts: 16
Joined: 25. October 2010 18:04
Operating System: MS Windows 7

Re: bug in XAMPP 1.7.7

Postby Sharley » 12. November 2011 19:22

Rankxerox1984 wrote:Do you mean if I edit the .htaccess adding the line you suggested I could edit Short_open_tags to Off in php.ini and everything will work well?
Yes that is what he meant.


Rankxerox1984 wrote:Please, where I need to place this line, anywhere in the file?
Try putting it as the first line and then a blank line to the next entry already in there.


Rankxerox1984 wrote:Also you meant Symfony will work without any issue even if I don't follow their recommendations?
Yes Symphony should work with the tag set to On - try it and see and if it gives you problems then add or edit the .htaccess file in the symphony main folder.

Your other topic was closed because you posted back that all was now working and Altrea's recommendation to find all your posts is valid.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: bug in XAMPP 1.7.7

Postby Altrea » 12. November 2011 19:26

Rankxerox1984 wrote:Do you mean if I edit the .htaccess adding the line you suggested I could edit Short_open_tags to Off in php.ini and everything will work well?

Yes! Important is that the .htaccess file is at the correct directory and that the AllowOverride is configurated to allow this override rule.

So to make that work open your \xampp\apache\conf\extra\httpd-xampp.conf file
go to line 72 and change
Code: Select all
AllowOverride AuthConfig

to
Code: Select all
AllowOverride AuthConfig Options


and restart your Apache that the change can take effect.

Rankxerox1984 wrote:Please, where I need to place this line, anywhere in the file?

See Sharleys post. But generaly you could put it nearly anywhere in that file.

Rankxerox1984 wrote:Also you meant Symfony will work without any issue even if I don't follow their recommendations?

short_open_tag just causes one issue: If you use xml Start tags inside of php parsed files where short_open_tag is activated.
I don't know Symfony that much (not yet :D ) but nearly all frameworks are working with short_open_tag activated.

If Symfony will not work with it, you will realize that. You will get a Fatal Error in relation with php xml syntax.

There are much more issues with application which required short_open_tag setted to On on environments where it is not activated, than the other way round.

best wishes,
Altrea
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: bug in XAMPP 1.7.7

Postby Rankxerox1984 » 13. November 2011 13:46

Hi Altrea and Sharley:
Thank you both for your help and time :) .
I tried what you both suggested and found the following inconvenient
Editing C:\xampp\htdocs\Symfony\bin\.htaccess with notepad is not allowed therefore because my limited knowledge of Symfony structure I did not go more deeper.
So I tried to set in php.ini short_open_ tag = off and run any page from localhost and the server seems to works fine.
Also I tried to do the recommended by Sharley in my before post (the lost one) to set php_int.dll working and I can’t restart the server (using any of the Xampp Control Panel, now I’m already using v3.0.2 compiled: July 21th 2011 – build #1).
Also in relation with this intl.dll setting when I copied the icu*46.dll from C:\xampp\php to C:\xampp\apache\bin the Xampp page works well only when I added in php.ini the extension line extension=php_intl.dll when the server does not restart (I don’t know but it seems is there any trouble to accept changes in php.ini to this latest release) I commented the line and, again, I can restart the server.
Therefore and meanwhile comes a new release with this two bugs fixed I decided to work without the welcome Xampp Page.
I understand what you say when tells me all of this are recommendations and symphony have to work also without following them, but what I’m trying is to learn Symfony so I need to be sure to work as “symphony requirements compliant” as it’s possible in order to avoid misunderstanding in errors instructions.
I’m fully open to more suggestions or comments you want to do.
Thanks very match again for your help,

J.
Rankxerox1984
 
Posts: 16
Joined: 25. October 2010 18:04
Operating System: MS Windows 7

Re: bug in XAMPP 1.7.7

Postby Altrea » 13. November 2011 15:15

Rankxerox1984 wrote:Editing C:\xampp\htdocs\Symfony\bin\.htaccess with notepad is not allowed

- why do you want to edit the .htaccess file of symfony instead the one in \xampp\htdocs\xampp\ and turning short_open_tag Off?
- don't use notepad for editing any webrelated files (.htaccess, .php, .css, .html, etc.). Use a good editor like Notepad++

Rankxerox1984 wrote:I understand what you say when tells me all of this are recommendations and symphony have to work also without following them, but what I’m trying is to learn Symfony so I need to be sure to work as “symphony requirements compliant” as it’s possible in order to avoid misunderstanding in errors instructions.

In live environments at Webhoster you will never have the exact configuration you want to have (exept you pay a lot of money). Especially short_open_tag is in most of the cases turned to On to prevent support requests because of incompatibility with some scripts.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8291
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: Bonniem and 69 guests