Apache wont start (Win XP) 1.7.7 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache wont start (Win XP) 1.7.7 [SOLVED]

Postby riahc3 » 11. November 2011 21:43

Hey

I installed XAMPP for Windows and it seems I can get MySql to start but I cant get Apache to start.

In the control center, I simply click start and it never says Running. In case there was a port issue, I went into the configuration file, httpd.conf, and I changed (from what I read on other forums) the 2 lines required so it can listen in on a different port yet it still tries to listen on port 80 and fails.

Another person with the same thing PC I as do (they are clone images) installed XAMPP without any problems yet he can get Apache to start.

Ive tried uninstalling it and reinstalling it. Same thing. I tried to copy HIS xampp folder and just overwrite mine. Same thing.

This is on Windows XP SP3. I believe there is no firewall issue (can't check it out now as this is at work) as I looked around and dont see anything blocking it.

I also believe there is no firewall issue as I installed Apache by itself ( http://www.apache.org/ ) and this worked: It showed "Running" when I started up Apache from the Apache control panel (it showed "Running" as well on the XAMPP control panel). I cant access things like phpmyadmin and such so it gives me problems in certain areas. Also I perfer the "all in one" package as this make configuration alot easier for me.

Any tips or suggestions? Thanks
riahc3
 
Posts: 6
Joined: 11. November 2011 17:45
Operating System: Windows XP

Re: Apache wont start

Postby Altrea » 11. November 2011 21:59

Hi riahc3,

First of all you should explain which of the two control panels you use. If you use the standard one you should switch to the control panel v3 beta which comes with the XAMPP 1.7.7 too. This will give you much more status information and helpful features. It is highly recommend.

riahc3 wrote:In case there was a port issue, I went into the configuration file, httpd.conf, and I changed (from what I read on other forums) the 2 lines required so it can listen in on a different port yet it still tries to listen on port 80 and fails.

Don't believe what this control panel tells you about which port it tries to listen to. The port numbers are hard coded in the control panel and are not used at the starting process. Important is just which is standing in the configuration files.

One thing you should check is, if you have already installed the Microsoft Visual C++ 2008 SP1 Redistributable Package (x86) installed. This is one requirement to get This XAMPP version running on your computer.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache wont start

Postby riahc3 » 11. November 2011 22:51

Altrea wrote:Hi riahc3,

First of all you should explain which of the two control panels you use. If you use the standard one you should switch to the control panel v3 beta which comes with the XAMPP 1.7.7 too. This will give you much more status information and helpful features. It is highly recommend.

Ill try that one out. I was trying the normal one, not the beta.

Altrea wrote:Don't believe what this control panel tells you about which port it tries to listen to. The port numbers are hard coded in the control panel and are not used at the starting process. Important is just which is standing in the configuration files.

OK :) Thanks

Altrea wrote:One thing you should check is, if you have already installed the Microsoft Visual C++ 2008 SP1 Redistributable Package (x86)installed. This is one requirement to get This XAMPP version running on your computer.

I have the 2010 Redistributable Package. Should I also download the 2008 one?
riahc3
 
Posts: 6
Joined: 11. November 2011 17:45
Operating System: Windows XP

Re: Apache wont start

Postby Altrea » 11. November 2011 23:07

riahc3 wrote:I have the 2010 Redistributable Package. Should I also download the 2008 one?

Yes please. Just give it a try :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8298
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: Apache wont start

Postby riahc3 » 12. November 2011 02:03

Altrea wrote:Yes please. Just give it a try :D

Will do on Monday :) Thanks for all the help!
riahc3
 
Posts: 6
Joined: 11. November 2011 17:45
Operating System: Windows XP

Re: Apache wont start

Postby riahc3 » 14. November 2011 08:47

Yup,installed the VS C++ redist 2008 SP1 and now it works. Odd....Thought with 2010 it would be enough.
riahc3
 
Posts: 6
Joined: 11. November 2011 17:45
Operating System: Windows XP

Re: Apache wont start

Postby Sharley » 14. November 2011 08:49

Thanks for the feedback. 8)

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 54 guests