XAMPP won't initialize Apache properly

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP won't initialize Apache properly

Postby j03p4n75 » 10. November 2011 03:03

Hello everyone!

I am running Windows 7 Home Premium 32-Bit and XAMPP 1.7.7 (using the Control Panel 3 beta).

I have searched the forums, but have yet to find anything that has helped me solve my problem. Any help will be greatly appreciated. :D

I cannot get Apache to start and stay on. When I start XAMPP and Apache, I see the following in the panel:

5:50:23 PM [main] Initializing main
5:50:23 PM [main] Windows version: 6.1 (build 7601) - Service Pack 1
5:50:23 PM [main] Xampp version: 1.7.7
5:50:23 PM [main] Control center version: 3.0.2 [ Compiled: Jul 21th 2011 - build #1 ]
5:50:23 PM [main] Running not as admin! This will work for all application stuff, but whenever you do
5:50:23 PM [main] something with services there will be a security dialogue! So think about running
5:50:23 PM [main] this application with administrator rights!
5:50:23 PM [main] Working with basedir: "c:\xampp\"
5:50:23 PM [main] Initializing moduls
5:50:24 PM [apache] Possible problem detected: Port 80 in use by "c:\xampp\xampp-control-3-beta.exe"!
5:50:24 PM [main] Starting check-timer
5:50:32 PM [apache] Starting apache service...
5:51:30 PM [apache] Starting apache service...
5:51:37 PM [apache] Status change detected: running
5:51:38 PM [apache] Status change detected: stopped

I have the box checked to run Apache as a service.

I have no files that I'm trying to run, yet. localhost won't even work; it just sends me to the IIS7 homepage (if I have http:// preceding) or a Google search for keyword localhost (if I just type that into my address bar). I don't know if it changes anything, but I use Firefox with the Omnibar add-on (combines search field and address bar). I've tried disabling the Omnibar, to no success.

This is my first attempt to use this program and due to the good things I've read online about it I'd like to continue using it. Any suggestions?
Posts: 1
Joined: 10. November 2011 01:44
Location: Costa Mesa, CA
Operating System: Windows 7 Home Premium 32-Bit

Re: XAMPP won't initialize Apache properly

Postby Sharley » 10. November 2011 03:09

You will need to disable IIS7 as it will be using the ports 80 and 443 you require for Apache to start.
C:\xampp\apache\logs\error.log file may hold more clues why Apache can't start.
User avatar
AF Moderator
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 37 guests