XAMPP won't start with php:ldap

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP won't start with php:ldap

Postby SanderrNL » 01. November 2011 08:29

Hi

My installation of XAMPP 1.7.7 on Windows Server 2003 (standard) R2 won't start.
I did a clean install, installed the VC++ 2008 SP1 redist, attempted to start the service, but it hangs on 'starting'

When I kill httpd.exe, comment out the ext=php_ldap line in php.ini, it starts like intended.

Any fix for this ?
SanderrNL
 
Posts: 2
Joined: 01. November 2011 08:06
Operating System: Windows Server 2003 r2 Standar

Re: XAMPP won't start with php:ldap

Postby Sharley » 01. November 2011 08:32

When Apache can't start it usually makes an entry in the \xampp\apache\logs\error.log file and this may offer a clue.

Use the xampp-control-3-beta.exe control panel and try again and it will give a better error message why Apache can't start when you comment out the ldap extension.

I will investigate further as there seems to be some other dependant files that are missing.

Stay tuned.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP won't start with php:ldap

Postby Sharley » 01. November 2011 08:42

In the \xampp\php folder you will find this file:
Code: Select all
libsasl.dll

Copy it into the \xampp\apache\bin folder.

Now try and start Apache again.

It should now start.

Please let me know if the above was successful for you.

Thanks and good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP won't start with php:ldap

Postby SanderrNL » 01. November 2011 08:45

When I use xampp-control-3-beta.exe and I hit start apache, it says it's started, but nothing replies on http://localhost/
Also the service states it's still 'starting'

The error.log only contains:
[Tue Nov 01 08:22:22 2011] [notice] Digest: generating secret for digest authentication ...
[Tue Nov 01 08:22:22 2011] [notice] Digest: done

edit This is also still the case when copied over libsasl.dll to /apache/bin/

edit2 Additional information: Since this is installed on a production environment, the server has not yet rebooted since the installation of the VC++ 2008 redist.
This server also runs IIS bound to 10.13.1.46:80/443, and Apache is configured to listen on 10.13.1.47:80

The server is scheduled for a reboot at 12:00, hoping this will fix the issue.

Will let you know about progress when the server has rebooted. Thanks.
SanderrNL
 
Posts: 2
Joined: 01. November 2011 08:06
Operating System: Windows Server 2003 r2 Standar

Re: XAMPP won't start with php:ldap

Postby Sharley » 01. November 2011 09:02

You can check if the ldap extension is in use after copying the above file and when Apache finally starts by going to
http://localhost/xampp/phpinfo.php

Look for the ldap section which should indicate enabled.

If Apache is running as a Windows service then, as you say, a reboot may have the newly copied file recognised.

Also if you have ldap issues then this site might be worth a visit:
http://www.cyrusimap.org

BTW. XAMPP in a production environment is not recommended because of the open security issues - keep a close eye on your on your access.log file in the apache\logs folder.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: ben.mansuk and 60 guests