migrating from xampplite to xampp extreme problems

Problems with the Windows version of XAMPP, questions, comments, and anything related.

migrating from xampplite to xampp extreme problems

Postby creageous » 01. November 2011 00:09

Hi,
I have been running xamplite for the last 2 years with no trouble. I started having problems with TCPDF (of all things), out of memory errors, can't render anything but jpg images, blank screen, etc. This is code that has been working, so very frustrating. I am trying everything before I just rebuild my system - wipe the HD and start all over. This computer was purchased earlier this year so it was fairly recent that I had to do it.

Anyway... In an attempt to avoid that I tried upgrading my server to xampp. Pretty much it went smoothly. Most of the sites I work on are working and I haven't run into too many problems, but yes, I am running into problems. I have been fixing them one-by-one and it is taking me quite some time.

I just ran into this one: "Request-URI Too Large" - again on code that works on the actual server and in my xampplite installation.

I am using a POST method and somehow the form is ending up in the URL like I am using a GET method. Here is the form tag:

Code: Select all
<form name="doc" action="docs.php" method="post" id="doc" target="_blank">


Also, most of my PDFs are generating fine, but there are a couple still with errors (these are ones that actually work on my xampplite install).

1st... any help with the FORM tag turning my POST into a GET would be appreciated.
2nd... is there a way to "port" my xampplite config to my new xampp installation?
3rd... in my old xamplite php.ini file I have these dlls listed:

Code: Select all
[PECL]
extension=php_ming.dll
extension=php_pdflib.dll


If I copy them over to xampp I get errors, and they didn't come with xampp where it seems they did come with xampplite. Could that php_pdflib.dll have anything to do with my problems? I'm not sure since many of my PDFs are being generated without problems. The install of xampp seemed to help quite a bit, but frustration is mounting the more errors I encounter.

If there is someone that can help speed things along in any way I would be most grateful!

THanks.
creageous
 
Posts: 2
Joined: 31. October 2011 23:49
Operating System: windows 7

Re: migrating from xampplite to xampp extreme problems

Postby creageous » 01. November 2011 00:46

Form problem is solved. That one was a bug in the code and did not have anything to do with the server config.
So, any help with the TCPDF problems?
creageous
 
Posts: 2
Joined: 31. October 2011 23:49
Operating System: windows 7

Re: migrating from xampplite to xampp extreme problems

Postby JonB » 04. November 2011 11:21

If I copy them over to xampp I get errors, and they didn't come with xampp where it seems they did come with xampplite. Could that php_pdflib.dll have anything to do with my problems?


The DLL's for PHP cannot generally be copied from one installation to another -- UNLESS the new installation is the same PHP version (say 5.3) as the old installation, and the dll's were created with the same compiler. In your case the OLD dll's are VC6, and the NEW dll's need to be VC9, thus they won't work. :shock:

I think ming was abandoned for lack of use, and the PDF functionality was replaced with a new method.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests