downgrading xampp?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

downgrading xampp?

Postby its me » 27. October 2011 17:31

Hello guys,
I know you miss me now :)
okay, i will not be any more headache, I just want to discuss downgrade issue with you and take your advice:
I have been with xampp 1.7.7 with windows server 2008 R2 for 20 days (migrating from usual installation of apache and php4/mysql 4)
I saw xampp nice and stable, robust, support available from good guys like you
to be honest, I ran into some troubles like to adjust the settings and add all necessary mods... etc

conclusion and problems:
On this windows server must run an application that require zend loader and that is not supported by thread safe - xampp with php 5.3.8 and when I installed the ioncube version of this application it gave me some errors related to php 5.3.xx that is not solved yet by php.net

Also another application which needs less than php 5.3.x

I read a lot about running php4 and 5 on the same server but nobody encourages that

I have installed hMail server also and works fine

Now and my environment is almost ready! to speak frankly I don't want to change this setup up to now but the application which require php version 5.3 or less is mandatory, and there are a lot of errors coming up like deprecated functions and stuff that only happens with php 5.3...

so, if i now go back with xampp to earlier stable version, is zend going to work fine? what basically i will lose?

of course i will make backups.. but what you think that i have to lose if i tried the version 1.7.3 which looks stable as i see in your signatures moderators here @AF forums?
btw: i couldn't find trusted source for version 1.7.3, or a link from the main page for previous version of xampp?

your advice please
Mike
its me
 
Posts: 61
Joined: 03. October 2011 09:45
Operating System: Windows server 2008 SP1 R2

Re: downgrading xampp?

Postby Altrea » 27. October 2011 18:07

The last XAMPP release with PHP 5.2 was XAMPP 1.7.1 (which comes with PHP 5.2.9).
Zend Optimizer should be included and ready to run.

You can find all old versions of XAMPP for Windows here @ sourceforge.

Or (you don't want to read that) use Zend Server (CE). You have the choice if you want to use a version with PHP 5.2 or PHP 5.3, Zend Guard is already included and some other stuff.
IMHO Zend Server (CE) is by far the best choice if someone wants/needs to use other Zend products.

btw: Messages like Deprecated Messages can be defined with an adjustment in your php error_reporting level.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: downgrading xampp?

Postby its me » 28. October 2011 01:25

Hello,
thanks for your reply

actually i tried Zend CE and removed it back as it contains another apache, so either will run xampp or zend, I prefere xampp as i have done all settings and feeling better with it.

now, again, same question, with rephrase:

what basically i have to change if i moved from version 1.7.7 to 1.7.1 ?? is there a lot of changes? because i see my status now -almost- stable but only missing that software which requires php downgrade to 5.2.x

another small q: do you think this version 1.7.2 is stable to handle the server load as production? is there missing things that are available in 1.7.7 and not available in 1.7.2?

thanks in advanced
its me
 
Posts: 61
Joined: 03. October 2011 09:45
Operating System: Windows server 2008 SP1 R2

Re: downgrading xampp?

Postby Altrea » 28. October 2011 04:51

its me wrote:what basically i have to change if i moved from version 1.7.7 to 1.7.1 ??

That depends on:
- what do you have changed in the XAMPP configurations?
- what do you all need for your applications?

Why don't you just start to "install" XAMPP 1.7.1 on your computer without touching your XAMPP 1.7.7? Simply use the .zip verion of XAMPP 1.7.1, extract it into a new folder (i always use something like c:\xampp171\), run his setup_xampp.bat file and see, if it starts from his control panel (sure it can just start if your other XAMPP is stopped, but that shouldn't be the problem on a development engine).
And then you can configure this XAMPP without having trouble to crash the XAMPP 1.7.7 instance. Move each application on it's own (files can simply be copied, databases should be extracted and reimported to the new database). If it is just the one application that needs PHP 5.2 i wouldn't move ALL to the older XAMPP, but just this one application and stay with two XAMPPs.

its me wrote:is there a lot of changes? because i see my status now -almost- stable but only missing that software which requires php downgrade to 5.2.x

YES, there are a lot of changes. Especially the change from PHP 5.3 to PHP 5.2 and from MySQL 5.5 to 5.1 are bigger ones.

its me wrote:another small q: do you think this version 1.7.2 is stable to handle the server load as production?

1.7.2? no, this is not a stable one. We are talking about 1.7.1 i thought :shock: If you want to use 1.7.2, you can stay with 1.7.7, because these both use PHP 5.3.X.
All XAMPP can handle the server load. It's just a matter of configuration. But the case why we wouldn't recommend to use it as production server is the security aspect.

its me wrote:is there missing things that are available in 1.7.7 and not available in 1.7.2?

YES, but again, why 1.7.2?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8294
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: downgrading xampp?

Postby its me » 29. October 2011 00:14

perfect, i will do the way u said :)

yeah, i mean 1.7.1

anyway i changed the document root of apache in 1.7.7 to another folder on C drive, so i should re configure it on the new 1.7.1 php.ini and should go fine, i will start with that application, if works fine, then will suspend this, go back to 1.7.7 and get a copy of all dbs then re import them into the 1.7.1 and stabilize, otherwise, if run into unexpected errors, i will go back to 1.7.7 and ignore that application and check for alternative for it :)

I will let you know Altrea, thanks a lot dear
Sharely! I know u r reading :) also thanks a lot :)
Mike
its me
 
Posts: 61
Joined: 03. October 2011 09:45
Operating System: Windows server 2008 SP1 R2


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests