phpMyAdmin fails to load 403 error (Win 7 64) 1.7.3 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpMyAdmin fails to load 403 error (Win 7 64) 1.7.3 [SOLVED]

Postby Achul » 23. October 2011 00:50

Hello Apachefriends!

This is my thread from WordPress forums as they suggested this would be a better place.
Please excuse the copy-paste.

Hello everyone!

I'm in alot of trouble and I would so much appreciate it if you could help me out. I've been working on my first commercial wordpress-site for a few months and recently had a computer crash.
Luckily I managed to save my files on a USB stick using safe-mode and then I formated.

Once I re-installed my computer I copied all my old webdevelopment files to my what I believe is my old directory and tried to start the homepage again from localhost/wordpress.

This worked and Xampp worked to.
But inside Xampp when trying to enter myPhpAdmin i keep getting the following classic error:
http://imageshack.us/photo/my-images/12/errorni.png/

Roughly translated to "Xampp has a new security function"
"You may only access this file through the local network (Which I am trying!)"
"You can config these settings in the config file".

But I do not want to config it by "allowing all".
I need it to work in a secure way by allowing me on my own local computer to access my own local phpmyadmin!

The big problem is I can't just re-install everything and put in my htdoc-files in my new directory. This since I can't export my database files from phpmyadmin and then import them. If I do it this way I'm left with the general settings of my new homepage but without all the text and pages that I have added.

Please, please help!


Please note Xampp is also copied from the usb. Perhaps it needs some reg-edit?
Achul
 
Posts: 9
Joined: 23. October 2011 00:47
Operating System: Windows 7 64 bit

Re: phpMyAdmin not working after re-formating of computer.

Postby Sharley » 23. October 2011 00:58

Achul wrote:Please note Xampp is also copied from the usb. Perhaps it needs some reg-edit?
No regedit required.

Run the setup_xampp.bat file found in the xampp folder, if coming from a portable device installation or when ever you want to change an XAMPP setting that the bat file can handle, and answer the questions that are asked.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpMyAdmin not working after re-formating of computer.

Postby Achul » 23. October 2011 01:00

This was one of the first things I did, sorry for not mentioning it.

This if you mean "relocate"
Achul
 
Posts: 9
Joined: 23. October 2011 00:47
Operating System: Windows 7 64 bit

Re: phpMyAdmin not working after re-formating of computer.

Postby Sharley » 23. October 2011 01:06

Where did you relocate XAMPP to, which drive and folder tree?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpMyAdmin not working after re-formating of computer.

Postby Achul » 23. October 2011 01:09

Im not 100% sure it's the old exact directory but it and htdocs with the wordpress files are in: C:\Webdevelopment\Xamp\Xamp\Xampp\~

The whole double Xamp thing always worked in the past.
Windows is in C:\

If you mean the relocation through the setup_xampp file it is automatic.
Achul
 
Posts: 9
Joined: 23. October 2011 00:47
Operating System: Windows 7 64 bit

Re: phpMyAdmin not working after re-formating of computer.

Postby Sharley » 23. October 2011 01:17

The bat file simply sets the paths to where it finds the XAMPP files and folders in all the configuration files and I take it that the tilde ~ is not part of the path..

The error seems to indicate that you are trying to access not from localhost.

So open your C:\Windows\system32\drivers\etc\hosts file and make sure that the first line after all the commented lines is
Code: Select all
127.0.0.1 localhost
If not there then add that line as the first line after the commented lines.

See if that has an effect on the 403 error.

Also look in the \xampp\apache\logs\error.log file for a clue perhaps.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpMyAdmin not working after re-formating of computer.

Postby Achul » 23. October 2011 01:23

I know it is not part of the path.
It has anyway set the paths (or attempted to do so) to the direction i mentioned above.


Here's what's written in the file below the example when opening in notebook.
# localhost name resolution is handled within DNS itself.
# 127.0.0.1 localhost
# ::1 localhost


Recent errors:
[Sun Oct 23 02:00:34 2011] [error] [client ::1] Directory index forbidden by Options directive: C:/Webdevelopement/XAMP/XAMP/xampp/phpMyAdmin/, referer: http://localhost/xampp/navi.php
[Sun Oct 23 02:22:51 2011] [error] [client ::1] Directory index forbidden by Options directive: C:/Webdevelopement/XAMP/XAMP/xampp/phpMyAdmin/
[Sun Oct 23 02:22:59 2011] [error] [client ::1] Directory index forbidden by Options directive: C:/Webdevelopement/XAMP/XAMP/xampp/phpMyAdmin/
Achul
 
Posts: 9
Joined: 23. October 2011 00:47
Operating System: Windows 7 64 bit

Re: phpMyAdmin not working after re-formating of computer.

Postby Sharley » 23. October 2011 01:30

So did you uncomment this line so it looks like this without the hash # ?
Code: Select all
127.0.0.1 localhost

What do you see when you go to http://locahost/ only?

That 403 error looks like there are no index files in the mentioned folders.

It may also mean that the Alias entry in the httpd-xampp.conf file has a path issue.
Can you paste here the phpMyAdmin alias section from the above conf file please.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpMyAdmin not working after re-formating of computer.

Postby Achul » 23. October 2011 01:52

Just tried to change it.
Kept the "DNS..." part with # but removed # from the ip and the ::1.

localhost leads to http://localhost/xampp/
Which works.

Here it is, and thanks for the fast replies.
Code: Select all
    Alias /phpmyadmin "C:/Webdevelopement/XAMP/XAMP/xampp/phpMyAdmin/"
    <Directory "C:/Webdevelopement/XAMP/XAMP/xampp/phpMyAdmin">
        AllowOverride AuthConfig
    </Directory>


Not sure exacly what you need.
Achul
 
Posts: 9
Joined: 23. October 2011 00:47
Operating System: Windows 7 64 bit

Re: phpMyAdmin not working after re-formating of computer.

Postby Achul » 23. October 2011 01:56

btw my phpmyadmin folder is empty in (...xamp\xampp\~).Not sure if its supposed to be that. Somehow the website is working though...
Achul
 
Posts: 9
Joined: 23. October 2011 00:47
Operating System: Windows 7 64 bit

Re: phpMyAdmin not working after re-formating of computer.

Postby Sharley » 23. October 2011 02:03

I have deleted the extra conf entries to make it easier to read as I only wanted the phpMyAdmin Alias.

The bat file looks like it has done the job.

No the phpmyadmin folder contains many file and folders and this is your problem.

First check all the other folders in the xampp folder and make sure they are not empty, then post back and I will explain how to remedy this without having to reinstall XAMPP.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpMyAdmin not working after re-formating of computer.

Postby Achul » 23. October 2011 02:08

Thanks: The following folders have nothing in them:

Phpmyadmin.
Security
Sendmail
Webalizer
Webdav



This is quite confusing since the main problem with a reinstalled xampp and copying only the htdocs files is that the database is gone (all the pagelinks for example)
Achul
 
Posts: 9
Joined: 23. October 2011 00:47
Operating System: Windows 7 64 bit

Re: phpMyAdmin not working after re-formating of computer.

Postby Sharley » 23. October 2011 02:21

I wonder how deleting the contents of those folders happened???? :shock:

Go here
http://sourceforge.net/projects/xampp/f ... ows/1.7.3/
and download the xampp-win32-1.7.3.zip file to your desktop.

Open the archive and copy the needed folders to your xampp folder overwriting if required.

Then you will need to run the setup_xampp.bat file again and select the relocate option to once again set any paths that need setting (this will do no harm to the rest of your xampp installation) but as always best practice is to make a 'copy of' (backup) of your current xampp folder just in case.

After all the above is complete try and first access http://localhost and then if all looks in order try http://localhost/phpmyadmin again and let me know how it all end up.

As an additional issue check the WebDAV link in my signature and implement the instructions to make your webdav folder secure.

Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpMyAdmin not working after re-formating of computer.

Postby Achul » 23. October 2011 02:30

Yeah now I'm seriously scared...
Virus?

It would havae to be a nasty bugger but something did crash my computer...

A previous install perhaps? Of Xampp and/or phpMyAdmin making the new one ignore those folders?
I really don't know.
If you have any ideas...


Anyway downloading.
Achul
 
Posts: 9
Joined: 23. October 2011 00:47
Operating System: Windows 7 64 bit

Re: phpMyAdmin not working after re-formating of computer.

Postby Achul » 23. October 2011 02:36

I could give you a kiss right now.
Thanks alot.



...And wtf indeed.
Achul
 
Posts: 9
Joined: 23. October 2011 00:47
Operating System: Windows 7 64 bit

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests