Setup Subdomain Under XAMPP

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Setup Subdomain Under XAMPP

Postby ma3ih » 20. October 2011 12:54

i have domain
domain.net
i do all work
i can see my subdomain
at
forum.localhost

but cant see it at
subdomain.domain.net


this is my setting at vhost....
<VirtualHost *:80>
ServerAdmin admin@localhost
DocumentRoot "C:/xampp/htdocs"
ServerName localhost
ServerAlias http://www.localhost
##ErrorLog "logs/dummy-host.localhost-error.log"
##CustomLog "logs/dummy-host.localhost-access.log" combined
</VirtualHost>

<VirtualHost *:80>
ServerAdmin admin@localhost
DocumentRoot "C:/xampp/htdocs/forum"
ServerName forum.localhost
ServerAlias http://www.forum.localhost
##ErrorLog "logs/dummy-host2.localhost-error.log"
##CustomLog "logs/dummy-host2.localhost-access.log" combined
</VirtualHost>


and this is my settin at hosts file

127.0.0.1 localhost
127.0.0.1 forum.localhost
77.95.230.80 forum.localhost
77.95.230.80 subdomain.domain.net
127.0.0.1 subdomain.domain.net

what i must to do?
ma3ih
 
Posts: 4
Joined: 20. October 2011 12:50
Operating System: windows 2003 server

Re: Setup Subdomain Under XAMPP

Postby JonB » 20. October 2011 13:02

i can see my subdomain
at
forum.localhost

but cant see it at
subdomain.domain.net


77.95.230.80 forum.vejax.net
127.0.0.1 subdomain.domain.net


you have made those addresses the same - they BOTH now point to your localhost
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Setup Subdomain Under XAMPP

Postby Sharley » 20. October 2011 13:05

You posted in the Linux forum instead of the Windows forum. :shock:

I don't see an IP based virtual host for subdomain.domain.net
I don't see a name based virtualhost for subdomain.domain.net

I don't see an IP based virtualhost for forum.localhost
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Setup Subdomain Under XAMPP

Postby ma3ih » 21. October 2011 00:59

i change Hosts file in system32/drivers/....
with 1 time
127.0.0.1 subdomain.domain.net
1 time 127.0.0.1 forum.localhost
1 time 77.95.230.80 subdomain.domain.net
1 time v77.95.230.80 forum.localhost
none of them work :(
can you type whats i must type in there and in vhost..?
my domain domain.net
server ip 77.95.230.80
folder sub domain: C:/xampp/htdocs/forum

and 1 other question i cant run appache when install xampp 1.7.7
1.7.6 and 1.7.5
just 1.7.4 work for me at windows 2003 server
i must do something ? or my windows is bull***:D
ma3ih
 
Posts: 4
Joined: 20. October 2011 12:50
Operating System: windows 2003 server

Re: Setup Subdomain Under XAMPP

Postby hackattack142 » 21. October 2011 02:11

and 1 other question i cant run appache when install xampp 1.7.7
1.7.6 and 1.7.5
just 1.7.4 work for me at windows 2003 server
i must do something ? or my windows is bull***:D

If MySQL in 1.7.7 works but Apache doesn't try installing this: http://www.microsoft.com/download/en/de ... px?id=5582
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 77 guests