XAMPP 1.7.7 Failure Windows 7 [NOT XAMPP RELATED - SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP 1.7.7 Failure Windows 7 [NOT XAMPP RELATED - SOLVED]

Postby imow » 20. October 2011 11:30

Hello guys,

I installed XAMPP in my Windows 7 Professional SP1, all instalation works fine, until i tried to access localhost. In FF, it shows "Connected to localhost", but i'ts like never complete request.

Image
Code: Select all
http://upload.kapanlagi.com/c.php?f=201110201714024_never_ending_loading_4e9ff46a0190f.jpeg



Then i tried to see the error logs :

Image
Code: Select all
http://upload.kapanlagi.com/c.php?f=201110201714004_error_log_4e9ff4682dffc.jpeg


So I disabled IPV6 :

Image
Code: Select all
http://upload.kapanlagi.com/c.php?f=201110201713544_disabling_ipv6_4e9ff462190cf.jpeg


I also tried to run Apache and mySQL from xampp-control-3-beta :

Image
Code: Select all
http://upload.kapanlagi.com/c.php?f=201110201717084_xampp_control_panel_4e9ff524b15a1.jpeg


But still no luck.. After I read couples of suggestion in this forum, somewhere said like "Try to execute setup_xampp, it may not execute automatically when installing". So I follow the step, and end up like this :

Image
Code: Select all
http://upload.kapanlagi.com/c.php?f=201110201717034_setup_xampp_nothing_4e9ff51f0eff7.jpeg


I tried to "Run as administrator", but still no luck :

Image
Code: Select all
http://upload.kapanlagi.com/c.php?f=201110201716594_setup_xampp_as_admin_4e9ff51bef1ea.jpeg


Please HELP.. Any suggestion will be much appreciated.. Thank you very much..
Last edited by imow on 22. October 2011 04:25, edited 3 times in total.
imow
 
Posts: 7
Joined: 20. October 2011 11:05
Operating System: Windows 7 Professional SP1

Re: XAMPP 1.7.7 Failure on Windows 7

Postby Sharley » 20. October 2011 11:35

Try adding
Code: Select all
127.0.0.1 localhost
as the first line in your hosts file after the commented entries.

Clear the cache in Firefox then try again to access http://localhost

BTW you need to provided a full url address to your images.

New members are restricted because of our strong ant-spam policy.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP 1.7.7 Failure on Windows 7

Postby imow » 20. October 2011 11:45

Sharley wrote:Try adding
Code: Select all
127.0.0.1 localhost
as the first line in your hosts file after the commented entries.

Sorry, I dont get it.. :?: :?:

Sharley wrote:Clear the cache in Firefox then try again to access http://localhost

It did, but still no response
imow
 
Posts: 7
Joined: 20. October 2011 11:05
Operating System: Windows 7 Professional SP1

Re: XAMPP 1.7.7 Failure on Windows 7

Postby Sharley » 20. October 2011 11:54

Drag the C:\Windows\system32\drivers\etc\hosts file into a text editor you open by right clicking and selecting run as administrator.

Then follow my instructions above.

Can you access using http://127.0.0.1 in FF?

In FF if using a proxy make sure that no proxy for 127.0.0.1 is ticked.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP 1.7.7 Failure on Windows 7

Postby imow » 20. October 2011 12:10

Sharley wrote:Drag the C:\Windows\system32\drivers\etc\hosts file into a text editor you open by right clicking and selecting run as administrator.

Then follow my instructions above.

Can you access using http://127.0.0.1 in FF?

In FF if using a proxy make sure that no proxy for 127.0.0.1 is ticked.


I follow your suggestion, and the problem still remain..
oya I forgot, I was joined a domain on my office.. is it takes effect ?
Because I also install on my laptop, and it's works great..
this problem occure after I upgrade the xampp version to 1.7.7
imow
 
Posts: 7
Joined: 20. October 2011 11:05
Operating System: Windows 7 Professional SP1

Re: XAMPP 1.7.7 Failure on Windows 7

Postby Sharley » 20. October 2011 12:16

Can you access using http://127.0.0.1 as I requested you to check before?

XAMPP looks like it is installed and running just fine.

Have you tried in another browser?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP 1.7.7 Failure on Windows 7

Postby imow » 20. October 2011 12:27

Sharley wrote:Can you access using http://127.0.0.1 as I requested you to check before?

XAMPP looks like it is installed and running just fine.

Have you tried in another browser?


yes, I tried http://127.0.0.1 as you requested, i also tried using opera, and chrome.. but still no luck, maybe this is caused by domain i joined..
It's really frustrating... :(
imow
 
Posts: 7
Joined: 20. October 2011 11:05
Operating System: Windows 7 Professional SP1

Re: XAMPP 1.7.7 Failure on Windows 7

Postby Sharley » 20. October 2011 12:34

imow wrote:maybe this is caused by domain i joined..
As I said XAMPP looks fine and you said the lap top works fine, so it looks like something linked to what you suspect is the issue.

I am not familiar with that side of your issue but there may be someone else who spots this topic who can help you further.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP 1.7.7 Failure on Windows 7

Postby imow » 21. October 2011 03:23

Maybe with this additional picture, can add more clue.. I hope :(

Image
Code: Select all
http://upload.kapanlagi.com/c.php?f=201110210921324_any_clue_4ea0d72cb3d55.jpeg


Image
Code: Select all
http://upload.kapanlagi.com/c.php?f=201110210921354_host_file_4ea0d72f951ed.jpeg
imow
 
Posts: 7
Joined: 20. October 2011 11:05
Operating System: Windows 7 Professional SP1

Re: XAMPP 1.7.7 Failure on Windows 7

Postby Altrea » 21. October 2011 04:43

in picture 1:
PID 2292 is your XAMPP Apache, correct? You can find this out in your task managers processes tab.

in picture 2:
You can't define localhost for two different IPs in your HOSTS file. The DomainName must be unique.
How should your OS know where to send the request to?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8290
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP 1.7.7 Failure on Windows 7

Postby imow » 21. October 2011 10:01

Altrea wrote:in picture 1:
PID 2292 is your XAMPP Apache, correct? You can find this out in your task managers processes tab.

Yes, PID 2292 is for httpd.exe

Altrea wrote:in picture 2:
You can't define localhost for two different IPs in your HOSTS file. The DomainName must be unique.
How should your OS know where to send the request to?

ohh sorry, I correct that one.. but still no response..
imow
 
Posts: 7
Joined: 20. October 2011 11:05
Operating System: Windows 7 Professional SP1

Re: XAMPP 1.7.7 Failure on Windows 7

Postby Sharley » 21. October 2011 13:07

Use the Netstat button in the version 3 Control Panel it will give good information and the window refreshes automatically.

Do you have ZoneAlarm or similar security software and if so are ports 80, 443, 3306 or the XAMPP components (Apache MySQL etc.) allowed to function?
Have you opened the above ports or components in your firewall?


Perhaps also try this long shot:
In Firefox click on Tools>Options>Advanced>Network>Settings

If you have Manual proxy configuration selected then down near the bottom of the window next to No Proxy For Type in the box 127.0.0.1, localhost, 192.168.1.0/24
Click OK, OK.

Now try again and see if your page loads but first and important is to clear the browser's cache again so you get a fresh page loaded and not old one from the cache.

Cache is Offline Storage click Now and it is found in the same Network tab as above.

It's a long shot but worth a try.

If you have other proxy settings selected other than Manual proxy configuration then you may have to investigate those other setting's configurations and see if they also have a no proxy setting for localhost and your LAN IP range available.

Good luck again. ;)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP 1.7.7 Failure on Windows 7

Postby imow » 22. October 2011 04:24

Finally I found that my ISS feature is turned off.. after I turned it on, and Tadaaaa... It works like a charm for me.. Hope this will help other people with the same problem..

Image
Code: Select all
http://upload.kapanlagi.com/c.php?f=201110221023554_iis_4ea2374b363ee.jpeg
imow
 
Posts: 7
Joined: 20. October 2011 11:05
Operating System: Windows 7 Professional SP1

Re: XAMPP 1.7.7 Failure Windows 7 [NOT XAMPP RELATED - SOLVE

Postby Sharley » 22. October 2011 04:51

Thanks for the feedback and after all that time spent troubleshooting your issue it was a IIS Windows setting after all. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 55 guests

cron