https access but no http access

Problems with the Windows version of XAMPP, questions, comments, and anything related.

https access but no http access

Postby sthrnynkee » 17. October 2011 22:21

Xampp vers. 1.7.7
Windows 7 Home Prem

I set up Dynamic DNS to access a site I'm working on from an external location.
Everything seems to work fine for HTTPS, but fails for HTTP. Firewall and port forwarding seem to be in order with all port 80 requests going to my XAMPP server.

Could it be that my ISP is blocking incoming port 80 requests or am I just missing a config option?
sthrnynkee
 
Posts: 2
Joined: 17. October 2011 22:13
Operating System: windows 7 home pro

Re: https access but no http access

Postby its me » 17. October 2011 22:29

yes, once happened to me, try locating direct page in your server something like http://yournameORip/folder/file.html
try it out
its me
 
Posts: 61
Joined: 03. October 2011 09:45
Operating System: Windows server 2008 SP1 R2

Re: https access but no http access

Postby sthrnynkee » 17. October 2011 22:54

I tried going straight to the index.html, but with out any luck. I guess it's not a big deal to send it through 443, since it's just for testing and personal use. Just kind of odd.
sthrnynkee
 
Posts: 2
Joined: 17. October 2011 22:13
Operating System: windows 7 home pro

Re: https access but no http access

Postby JonB » 17. October 2011 23:14

Could it be that my ISP is blocking incoming port 80 requests


did you ask???
:shock:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: https access but no http access

Postby its me » 18. October 2011 15:57

JonB, I noticed also some isp's won't allow you to access to something like http://YOUR-IP directly, but it worked for me if you calling streight the index.html or index.php, but? some ISP don't allow you also use http://yourdomain.dynamic.dns directly from the internet, assuming it is not FQDN (fully quality domain name) and you can't access it unless you know the indes file
its me
 
Posts: 61
Joined: 03. October 2011 09:45
Operating System: Windows server 2008 SP1 R2

Re: https access but no http access

Postby Sharley » 18. October 2011 23:30

sthrnynkee wrote:Could it be that my ISP is blocking incoming port 80 requests or am I just missing a config option?
Sounds precisely what is happening - cable users are more likely to be blocked.

I usually find out by doing a Google search for words similar to this example:
cox blocks port 80
Change cox for the ISP you want to check for - usually others will have had the same issue and there may be informative results - often quicker than contacting your ISP's support.
If you have residential Cox, I think they expressly forbid you to have mail/web servers, that sort of thing. If you want to do it, sign up for Cox Business. It costs more, but you get unlimited upload/downloads, no blocked ports, a great deal of leeway, a much better level of support, and the right to have all the servers you want.

You can also change the Listening port in the httpd.conf file from 80 to a different numbered port.

Hosting a web site on your home Apache server is not recommended if using XAMPP because of the very poor security it offers for anything other than developing on localhost.
Also you will experience very slow speeds due to the upload limits placed on home connections by your ISP - there are more secure production server suits out there.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 52 guests