Changing port in httpd.conf (Vista) 1.7.7 [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Changing port in httpd.conf (Vista) 1.7.7 [SOLVED]

Postby jeffhuber » 15. October 2011 22:38

Thanks for your help.

Running Windows Vista - no skype port conflict
XAMPP version 1.7.7 - Control panel version 3


On a fresh install on XAMPP (phpMyAdmin working fine) - I go into, xampp -> apache -> conf ->httpd.conf, to redirect localhost to localhost:8888. (trying to work with partner's Mac's WAMP which auto uses 8888)

Change: Line 47: from Listen 80 to Listen 8888 Line 176: from ServerName localhost:80 to ServerName localhost:8888

This change breaks Phpmyadmin and gives me the error: Cannot connect: invalid settings.

(Note I did not change any mySql settings from the defaults - and didnt change anything in the phpMyAdmin->config.inc.php file.)

Let me know if you have any questions! Much appreciated!!
jeffhuber
 
Posts: 2
Joined: 15. October 2011 22:08

Re: XAMPP - Changing port for Apache in httpd.conf from 80 t

Postby Altrea » 15. October 2011 22:44

I have tried that too but can access phpmyadmin as normal.

can you access the XAMPP Administration page? => http://localhost:8888/xampp/
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: XAMPP - Changing port for Apache in httpd.conf from 80 t

Postby jeffhuber » 15. October 2011 22:53

Altrea,

As a COMPLETE and utter fluke - I have no other explanation - I may have 'solved' part of it.

After changing my DocumentRoot (in httpd.conf) from "C:/xampp/htdocs/Dropbox" to "C:/xampp/htdocs" and back again to "C:/xampp/htdocs/Dropbox". I can now load my default index page at localhost:8888 (with .htaccess running) as well as access localhost:8888/phpmyadmin fine.

I can not access localhost:8888/xampp while the DocumentRoot is set to "C:/xampp/htdocs/Dropbox" however. If I change the DocumentRoot back to "C:/xampp/htdocs/" - I can access Xampp administration fine.

Hope this helps future people that run across this problem. Sorry I could not be more help.
jeffhuber
 
Posts: 2
Joined: 15. October 2011 22:08

Re: XAMPP - Changing port for Apache in httpd.conf from 80 t

Postby Altrea » 15. October 2011 23:00

Okay. Next time please you should give us all information which could be needed to solve your problem.
The change of the DocumentRoot can be such an information. Anything which is not XAMPP default setting.

In your case it was maybe not the change of the DocumentRoot but a Browser cache issue.
But the most importing thing is that it start running and your problem is solved :D
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8293
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 57 guests