XAMPP-USB-LITE 1.7.7 CGI Deactived.

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP-USB-LITE 1.7.7 CGI Deactived.

Postby atalucas » 14. October 2011 15:20

Hi,
I installed on Monday XAMPP lite. I program something easy in python like print the HTML with some get forms. And it works. but when I use a function from another folder I get a 500 error with Premature end of script headers. Later, I realise that the status of xammp says:

Common Gateway Interface (CGI) Deactivated.

The rest is activated.

I read something that for using Perl yo need more things.

could someone help me?

Thanks in advance.
atalucas
 
Posts: 1
Joined: 14. October 2011 15:13

Re: XAMPP-USB-LITE 1.7.7 CGI Deactived.

Postby Sharley » 14. October 2011 21:36

What Windows version are you using:
Please read the following Announcements.
viewtopic.php?f=16&t=48331
viewtopic.php?f=16&t=32670

Did you install this version to a portable USB device or to your hard drive?
If to the hard drive did you run the setup_xampp.bat file or did you install it without using the bat file, to simulate a USB portable device perhaps?

atalucas wrote:I get a 500 error with Premature end of script headers
Read the \xampp\apache\logs\error.log file for 500 errors.

Did you change the first line of your cgi (Perl) scripts. the shebang to point to your perl.exe file in XAMPP?
For example:
#!"\xampplite\perl\bin\perl.exe"
Change the path to suit your installation

atalucas wrote:Later, I realise that the status of xammp says:

Common Gateway Interface (CGI) Deactivated.
CGI is Activated by default in the version you are using.

Did you test the cgi scripts in \xampplite\cgi-bin folder (there are 3 test scripts) for example:
http://localhost/cgi-bin/perltest.cgi

There is only a mini-perl in the lite version.

Unless you absolutely need the lite version then use the full featured version instead. ;)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests