'XSLTProcessor' not found [SOLVED]

Problems with the Windows version of XAMPP, questions, comments, and anything related.

'XSLTProcessor' not found [SOLVED]

Postby ythnmj » 14. October 2011 03:49

Hello i have this problem can anyone help me

Fatal error: Class 'XSLTProcessor' not found in C:\xampp\htdocs\New\transform.php on line 17
ihave look the extensions and i have the xsl.dll
but on php.ini no extensions or is it somethink else
any idea ???


Thanks
ythnmj
 
Posts: 1
Joined: 13. October 2011 05:24

Re: 'XSLTProcessor' not found

Postby Sharley » 14. October 2011 03:51

We require your XAMPP version and your Windows Version to provide the correct version support - please read the following Announcements.
viewtopic.php?f=16&t=48331
viewtopic.php?f=16&t=32670

Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: 'XSLTProcessor' not found

Postby DavidTroidl » 29. October 2011 19:58

I have had the same error on the last several versions. Here is what the control panel shows:
XAMPP Control Panel Version 2.5 (16 March, 2011)
Windows 6.1 Build 7601 Platform 2 Service Pack 1
Current Directory" c:\xampp
Install (er) Directory: c:\xampp
WARN: This program must be run from your XAMPP root directory.
INFO: Perhaps this program running on a 64 bit platform please ignore the message above.
Busy. . .
Apache Started [Port80]
(It would be really helpful if I could copy and paste this.)

The error message from Firebug is:
<br />
<b>Fatal error</b>: Class 'XSLTProcessor' not found in <b>C:\xampp\htdocs\pages\Verse\Model\LexiconEntry.php</b> on line <b>21</b><br />

The relevant code is:
$this->proc = new XSLTProcessor();

Please help.
DavidTroidl
 
Posts: 2
Joined: 29. October 2011 19:44
Operating System: Windows 7 - 64-bit

Re: 'XSLTProcessor' not found

Postby Sharley » 29. October 2011 22:04

Open \xampp\php\php.ini file in your text editor and add the red xsl extension line only so it looks like this when added:
extension=php_xmlrpc.dll
extension=php_xsl.dll
Save the file and restart Apache.

To check if it is now enabled go to:
http://localhost/xampp/phpinfo.php
and find near the end the xsl entry.

Clear your browsers cache and try your script again.

Please let me know if it helped.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: 'XSLTProcessor' not found

Postby DavidTroidl » 29. October 2011 22:58

Thanks! That did it.

The first extension was there, but I had to add
extension=php_xsl.dll

If this could be included in the future, it would be really helpful.
DavidTroidl
 
Posts: 2
Joined: 29. October 2011 19:44
Operating System: Windows 7 - 64-bit

Re: 'XSLTProcessor' not found

Postby Sharley » 29. October 2011 23:01

Thanks for the feedback. 8)

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests