webmatrix on windows

Problems with the Windows version of XAMPP, questions, comments, and anything related.

webmatrix on windows

Postby rogerl_uk » 12. October 2011 15:18

I run windows vista 64 bit Home premium sp2 and have both IIS and XAMPP loaded on my system. So long as I stop IIS then I can start Apache and everything works.

This weekend I tried to install Microsoft Webmatrix as it supports Drupal and DotNetNuke, assuming tha tI could stop IIS to run Apache as before. The install didn't seem to work, so I uninstalled it.

I have successfully (I think) completed a system restore to a point before I tried to load Webmatrix. However, even though I can stop IIS I cannot load Apache from the Xampp control centre!

In hindsight it was stupid of me to trust a Microsoft product but hindsight is a wonderful thing.

Short of a complete rebuild (and I have tried installing the latest version of Xampp) can anyone suggest a solution that enables me to retain the databases that I have set up on MySQL?

Many thanks

rogerl_uk
rogerl_uk
 
Posts: 3
Joined: 06. January 2007 08:41

Re: webmatrix on windows

Postby Sharley » 12. October 2011 20:48

What version of XAMPP?
Please read the following:
viewtopic.php?f=16&t=48331
viewtopic.php?f=16&t=32670

Anything in here that might help?
viewtopic.php?f=16&t=48573
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: webmatrix on windows

Postby rogerl_uk » 13. October 2011 14:29

I've tried to install Xampp v1.7.7

I've viewed the topics recommended by Shayley, but either missed the solution or it is not there (IIS is stopped so that isn't causing the conflict)

I've disabled IIS and using the port check on the Xampp console ports 80, 81 and 443 are free.

Reading through various posts I've discovered the APache error log and found this message:

OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address [::]:80
(OS 10013)An attempt was made to access a socket in a way forbidden by its access permissions. : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down

This does not help me, but does if someone can tell me where to go from here I would be grateful.

I am running Norton Internet Security 2011, but this wasn't an issue before.

I suspect there may be something hanging around in the registry, but don't know what to check

So further guidance would be helpful
rogerl_uk
 
Posts: 3
Joined: 06. January 2007 08:41

Re: webmatrix on windows

Postby rogerl_uk » 13. October 2011 18:26

I've loaded the xampp control panel v3.0.2 and tried to run xampp.

This is the report in the log screen

18:20:31 [main] Initializing main
18:20:31 [main] Windows version: 6.0 (build 6002) - Service Pack 2
18:20:31 [main] Xampp version: 1.7.7
18:20:31 [main] Control center version: 3.0.2 [ Compiled: Jul 21th 2011 - build #1 ]
18:20:31 [main] Running as admin - good!
18:20:31 [main] Working with basedir: "c:\xampp\"
18:20:31 [main] Initializing moduls
18:20:31 [filezilla] Possible problem detected: file "c:\xampp\FileZillaFTP\FileZillaServer.exe" not found - run this program from your XAMPP root directory!
18:20:31 [tomcat] Possible problem detected: file "c:\xampp\tomcat\bin\tomcat6.exe/c:\xampp\tomcat\bin\tomcat7.exe" not found - run this program from your XAMPP root directory!
18:20:31 [main] Starting check-timer
18:20:42 [apache] Starting apache app...
18:20:51 [mysql] Starting mysql app...
18:20:51 [mysql] Status change detected: running
18:20:54 [mysql] Status change detected: stopped
rogerl_uk
 
Posts: 3
Joined: 06. January 2007 08:41


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 60 guests