path for localhost not correct? (Vista) 1.7.7 [SOLVED}

Problems with the Windows version of XAMPP, questions, comments, and anything related.

path for localhost not correct? (Vista) 1.7.7 [SOLVED}

Postby Valerie73 » 11. October 2011 19:43

Hi

I installed Xampp and WebMatrix on my computer (with Windows Vista). This products seem to have some conflicts/incompatibilities and therefore I had to install/uninstall them a couple of time.

I finally manage to have xampp running, and sucessfully started Apache (on port 85) and MySql (Svc selected).


Here is my problem:
- When I click on the Admin button next to Apache in the Xampp console, internet explorer opens up to the page http://localhost/ but this shows the start page from ISS7 instead.
- On the same way, when I click on the Admin button next to MySql, http://localhost/phpmyadmin/ opens up, but this displays the error 404 - not found and the following message:
-------------------------------------------------------------------------
Module: IIS Web Core
Notification: MapRequestHandler
Handler: StaticFile
Error Code: 0x80070002
Requested URL: http://localhost:80/phpmyadmin/
Physical Path: C:\inetpub\wwwroot\phpmyadmin\
Logon Method: Anonymous
Logon User: Anonymous
-------------------------------------------------------------------------

Thereby the path C:\inetpub\wwwroot\phpmyadmin\ doesn't exist...

Does anyone know how I can solve the problem?
Thanks in advance.
Valerie
Valerie73
 
Posts: 5
Joined: 11. October 2011 18:49

Re: path for localhost not correct??

Postby Sharley » 11. October 2011 19:59

What version of XAMPP?
please read the following Announcements.
viewtopic.php?f=16&t=48331
viewtopic.php?f=16&t=32670

You will need to disable IIS if you want to use XAMPP at the same time as you have a conflict.
viewtopic.php?p=134260#p134260

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: path for localhost not correct??

Postby Valerie73 » 11. October 2011 20:35

Thanks a lot for your help and for being so quick!

I am running Xampp 1.7.7 under Windows Vista. Xampp was installed in a directory which name has a space. In the posts you've send me, it is said it is not recommended, so I am reinstall xampp.

After reinstallation, I'll try disabling IIS to solve this. I'll let you know.
Thanks
Valerie
Valerie73
 
Posts: 5
Joined: 11. October 2011 18:49

Re: path for localhost not correct??

Postby Sharley » 11. October 2011 20:48

Hello Valerie
If you have problems uninstalling and reinstalling then try a different method outlined in this post:
viewtopic.php?p=179699#p179699

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: path for localhost not correct??

Postby Valerie73 » 11. October 2011 23:02

Hi

Ok, thank you for your help. Unfortunately it doesn't work yet. As you said, I've uninstalled and reinstalled Xampp version 1.7.7 in c:/xampp as described in your post above.
I removed IIS in Control Panels->Program and Features->Features. And then restarted my Computer.

I then started xampp using the file xampp-control.exe, but I can't start Apache.

netstat -ano indicates that the port 80 is already being used.
tasklist says it is used from PID 4.
How can I see what exactly is using that port?

Skype is not installed

In case this is relevant, my host file contains the lines
127.0.0.1 localhost loopback
::1 localhost

What should I do? Should I try to know why port 80 is used? Should I change the port in the configuration file c:/xampp/apache/conf/httpd.conf?

Thanks in advance!
Valerie
Valerie73
 
Posts: 5
Joined: 11. October 2011 18:49

Re: path for localhost not correct??

Postby JonB » 11. October 2011 23:18

Here's a MS Tool to dig down with :

Process Explorer

http://msdn.microsoft.com/en-us/library/ms684868(VS.85).aspx

You can also search on it in this forum "Process Explorer" - see what others have found

Its most likely a MS Web Remote Management tool

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: path for localhost not correct??

Postby Sharley » 11. October 2011 23:29

Valerie, have you tried using the new version 3 control panel instead of the older default version 2.5* as it has more features with a more informative log window:
C:\xampp\xampp-control-3-beta.exe
You can, if you wish, create a shortcut on your desktop for easy access.

First though Stop MySQL and any other components running in the older Control Panel and Exit the older panel before running CP3.

If you then click on the Netstat button it will tell you what is using port 80 and port 443 that Apache needs and the log window is more informative.

You can also use the xampp-shell button to run the inetmgr command below.

In some Windows systems they also use the term World Wide Publishing as well as IIS (Internet Information Service).

Valerie, I should also mention that you should be logged into Vista as an administrator but if not then right click on files and shortcuts and select to Run as administrator, especially those in XAMPP including the control panels.


Sorry I don't use Vista but try this from the xampp-shell # command prompt type inetmgr

The full sequence.
1 - open inetmgr (see above)
2 - expand your computer
3 - expand sites
4 - right-click the default web site
5 - select stop (XP)
6 - manage web site --> select stop (Vista/Win7)


Here is another method:
http://forums.iis.net/p/1150139/1872824.aspx


Finally try a reboot after making all these changes tou have made to your system settings.


Valeries wrote:In case this is relevant, my host file contains the lines
127.0.0.1 localhost loopback
::1 localhost
You can if you wish comment out IPv6 localhost entry and the add a comment to the 127.0.0.1 like so:
Code: Select all
127.0.0.1 localhost # loopback
# ::1 localhost
This may prevent possible issues down the track.


Best wishes Valerie. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: path for localhost not correct??

Postby Valerie73 » 12. October 2011 09:55

Thanks a lot to both of you.

It was indeed very helpful to use the beta version control panel.

Netstat button didn't give me more information, than the netstat followed by tasklist commands in the prompt window, but it is quicker to get the information.

What should appear when you click the xampp-shell button? I have been asked if I should create it. I couldn''t start inetmgr. How is it to be started? A screenshot might be useful? Therefore I couldn't execute the sequence you suggested at the bottom of your post.

Finally, looking at the list of services, I found a service called "Web Deployment Agent Service". I read somewhere that someone had conflicts because of the component Web Deployment, which is used by WebMatrix. So, I stopped that service. I could then finally start Apache, and clicking on Admin was sucessfull too. MySql is fine too.

I hope this experience of mine will help someone else who might be stuck with the same kind of issues...

I'll know put again my backuped website in the httdocs and hope I can get this all to work fine again now...

Thanks a lot again, and thanks for replying so precisely, that's really great.

Regards,
Valerie
Valerie73
 
Posts: 5
Joined: 11. October 2011 18:49

Re: path for localhost not correct? (Vista) 1.77 [SOLVED}

Postby Sharley » 12. October 2011 10:22

Thanks for the feedback. 8)

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 45 guests