pear within xampp installer

Problems with the Windows version of XAMPP, questions, comments, and anything related.

pear within xampp installer

Postby chandecweng » 11. October 2011 14:09

Hi, I can't find go-pear.bat in xampp 1.7.7. and can't use pear successfully.

I try many time and really can't solve the problem.

About the pear_env.reg, I can't manually execute it too.

I download xampp by installer.

Thanks for reply me !!!
chandecweng
 
Posts: 17
Joined: 20. July 2011 05:54
Operating System: Window 7

Re: pear within xampp installer

Postby Altrea » 11. October 2011 15:46

pear is already installed in your \xampp\php\PEAR directory.
You can use pear for example with the XAMPP-Shell (Button in your XAMPP control panel v3 beta).
Type in "pear version" and you should get the installed versionnumber.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: pear within xampp installer

Postby chandecweng » 12. October 2011 06:48

Altrea wrote:pear is already installed in your \xampp\php\PEAR directory.
You can use pear for example with the XAMPP-Shell (Button in your XAMPP control panel v3 beta).
Type in "pear version" and you should get the installed versionnumber.

Hi, Thanks for reply me,but I fail to upgrade the package
Maybe because of the environment variable?
The window command prompt ouput,for example: ERROR: failed to mkdir c:\php\pear\tests\Mail_mimeDecode\tests
Thanks for helping me !!!
chandecweng
 
Posts: 17
Joined: 20. July 2011 05:54
Operating System: Window 7

Re: pear within xampp installer

Postby Altrea » 12. October 2011 18:20

We need information about your OS and the user priviledges you have on this machine.

ERROR: failed to mkdir c:\php\pear\tests\Mail_mimeDecode\tests

c:\php\ is not the correct path, so no wonder why that failed.
But to give you a better support we need information aout what you have done exactly to get this error.

Do you have used the XAMPP-Shell? What do you have typed in?
The more information we get the better we can help.
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: pear within xampp installer

Postby chandecweng » 13. October 2011 13:41

Altrea wrote:We need information about your OS and the user priviledges you have on this machine.

ERROR: failed to mkdir c:\php\pear\tests\Mail_mimeDecode\tests

c:\php\ is not the correct path, so no wonder why that failed.
But to give you a better support we need information aout what you have done exactly to get this error.

Do you have used the XAMPP-Shell? What do you have typed in?
The more information we get the better we can help.


Hi, thanks for your help,

I am using xampp-control-3-beta.exe

I press the xampp-shell button

Then I update-channels the pear.php.net

It output :Updating channel "components.ez.no"
Cannot retrieve channel.xml for channel "components.ez.no" (Connection to 'components.ez.no:80' failed: php_network_getaddresses: getaddrinfo failed: No such host is known.)

I not yet set the password for xampp and Mysql when doing the update

Then I type in :pear upgrade-all

First,it output: Failed to download pear/archive_zip within preferred state "stable", latest release is version 0.1.2,stability "beta", use "channel://pear.php.net/archive_zip-0.1.2" to install
Cannot initialize 'channel://pear.php.net/archive_zip' , invalid or missing package file

Other package are the same

Then the xampp shell help me download the new package
Download finish and output

Package "channel://pear.php.net/archive_zip" is not valid
Some of the package also output the same ,then

ERROR: failed to mkdir c:\php\pear\tests\Mail_mimeDecode\tests

Other also same

I am using 64-bit Operating System or Windows_NT
This is my environment variable :

Path: C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\EgisTec MyWinLocker\x86;C:\Program Files (x86)\EgisTec MyWinLocker\x64;C:\Program Files\WIDCOMM\Bluetooth Software\;C:\Program Files\WIDCOMM\Bluetooth Software\syswow64;C:\Program Files (x86)\Windows Live\Shared;c:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;c:\Program Files\Microsoft SQL Server\100\Tools\Binn\;c:\Program Files\Microsoft SQL Server\100\DTS\Binn\;C:\Program Files (x86)\Microsoft ASP.NET\ASP.NET Web Pages\v1.0\

Window 7 user

User privilege: program files(x 86) is unwriteable

I am the only user

Thanks a lot for helping me,sincerely !!!
chandecweng
 
Posts: 17
Joined: 20. July 2011 05:54
Operating System: Window 7

Re: pear within xampp installer

Postby Sharley » 13. October 2011 13:53

Did you install XAMPP in the C:\ drive - no spaces or special characters in the folder name - so you end up with C:\xampp

XAMPP and it's components don't get on too well if you install to C:\Program Files (x 86\xampp

If you have to install again then use the archive version (zip or 7zip) and after extracting run the setup_xampp.bat file in the xampp folder to set all the paths correctly.

XAMPP will only work if installed in the root of a drive or partition and works well in the C:\ drive as C:\xampp

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: pear within xampp installer

Postby chandecweng » 13. October 2011 14:01

Sharley wrote:Did you install XAMPP in the C:\ drive - no spaces or special characters in the folder name - so you end up with C:\xampp

XAMPP and it's components don't get on to well if you install to C:\Program Files (x 86\xampp


I install using c:\xampp and last time I install webMatrix by Microsoft and I have install Internet Information service(IIS)Manager and

every time I start my laptop,it automatic assign the port 80 to IIS and I have to close it so that I can use Apache
chandecweng
 
Posts: 17
Joined: 20. July 2011 05:54
Operating System: Window 7

Re: pear within xampp installer

Postby Sharley » 13. October 2011 14:11

That's good. 8)

My next question is do you have another php installation on your PC?

With Apache and MySQL running go to http://localhost/xampp/phpinfo.php and look for the item:
Loaded configuration file
It should show C:\xampp\php\php.ini
Let me know if that is correct.

I want to make sure that you are using the correct php.ini file as there may be others on your PC after install those other servers. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: pear within xampp installer

Postby chandecweng » 13. October 2011 14:35

Sharley wrote:That's good. 8)

My next question is do you have another php installation on your PC?

With Apache and MySQL running go to http://localhost/xampp/phpinfo.php and look for the item:
Loaded configuration file
It should show C:\xampp\php\php.ini
Let me know if that is correct.

I want to make sure that you are using the correct php.ini file as there may be others on your PC after install those other servers.
:)


It show C:\xampp\php\php.ini

Thanks
chandecweng
 
Posts: 17
Joined: 20. July 2011 05:54
Operating System: Window 7

Re: pear within xampp installer

Postby Sharley » 13. October 2011 14:43

Looking Good. 8)

Now using the xampp_shell can you see the list of installed packages and their versions by typing pear list at the command prompt?

If so are there any that you feel need updating and if so which ones?

I just test pear channel-update pear.php.net and I had an update succeed with no errors using a clean 7zip installation.

So we need to see why you are having problems that at this point in time I can't understand.

How do you feel about uninstalling the installer version you now use and then downloading and using the 7zip version?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: pear within xampp installer

Postby Sharley » 13. October 2011 14:56

How to change port 80 in IIS on Win 7 if it helps :)
http://www.gadgetcage.com/how-to-change ... ws-7/3457/
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: pear within xampp installer

Postby chandecweng » 13. October 2011 15:16

Sharley wrote:Looking Good. 8)

Now using the xampp_shell can you see the list of installed packages and their versions by typing pear list at the command prompt?

If so are there any that you feel need updating and if so which ones?

I just test pear channel-update pear.php.net and I had an update succeed with no errors using a clean 7zip installation.

So we need to see why you are having problems that at this point in time I can't understand.

How do you feel about uninstalling the installer version you now use and then downloading and using the 7zip version?


If you want to use the package, for example Auth/HTTP.php

And so you create a php file and insert this "require_once("Auth/HTTP.php");" and put it into htdocs

And use the web browser to see it output

Like this?

Thanks
chandecweng
 
Posts: 17
Joined: 20. July 2011 05:54
Operating System: Window 7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 26 guests