Accessing from other place

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Accessing from other place

Postby morfasto » 06. October 2011 21:38

Hello,

I'm having problems when trying to access to my website from another place. When I access to it from the server (localhost) it works just fine, but when I'm trying to access to my website from other place (another computer and from the internet) I get this message:

404 Not Found
The requested URL "/xxxxx/" was not found on the server.


I've been investigating this problem but haven't got a solution yet.

I've opened all the ports from my router for the server and still haven't got it to work.

Any ideas?

I'm using windows 7 Ultimate 64 bit.
morfasto
 
Posts: 5
Joined: 04. October 2011 20:49

Re: Accessing from other place

Postby Sharley » 06. October 2011 21:40

\xampp\apache\logs\error.log file may hold the clues.

Also what address are you typing in your browser that gives the 404 file not found error?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Accessing from other place

Postby morfasto » 06. October 2011 21:53

This is what I got from XAMPP Control Panel v3.0.2:

03:45:15 p.m. [main] Initializing main
03:45:15 p.m. [main] Windows version: 6.1 (build 7601) - Service Pack 1
03:45:15 p.m. [main] Xampp version: 1.7.7
03:45:15 p.m. [main] Control center version: 3.0.2 [ Compiled: Jul 21th 2011 - build #1 ]
03:45:15 p.m. [main] Running as admin - good!
03:45:15 p.m. [main] Working with basedir: "c:\xampp\"
03:45:15 p.m. [main] Initializing moduls
03:45:15 p.m. [apache] Possible problem detected: Port 80 in use by "httpd.exe"!
03:45:15 p.m. [apache] Possible problem detected: Port 443 in use by "httpd.exe"!
03:45:15 p.m. [mysql] Possible problem detected: Port 3306 in use by "mysqld.exe"!
03:45:15 p.m. [main] Starting check-timer

And from the error.log I dont get anything when I try to see the website from another computer.

Also I've desactivated the firewall from windows.

This is the URL: http://200.121.166.133/website

Any clues?
morfasto
 
Posts: 5
Joined: 04. October 2011 20:49

Re: Accessing from other place

Postby Sharley » 06. October 2011 22:04

View the error log file from the PC with XAMPP using Windows Explorer.

You can't access any XAMPP system files and folder from anywhere but the PC that XAMPP is installed on for security reasons.

When I try that address I get a login screen when using just HTTP://200.121.166.133
But the 404 error when I use http://200.121.166.133/website

BTW if you are trying to access this WAN or ISP provided IP from your own network then you may not be able to.

Try the LAN IP of the PC where XAMPP is installed.

The version 3 log window seems to relate to Apache and MySQL already started.

Do they both show running in green?

Do you have Ticks that are not grayed out ie the service modules are installed?

If so try Stopping Apache and MySQL then remove the ticks in the service modules.

Then start Apache and MySQL again but don't tick the services boxes until you are certain that both Apache and MySQL are working as they should and you can access your web site without 404 errors.

Then you can install the service modules if you want Apache and MySQL to start on boot.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Accessing from other place

Postby morfasto » 06. October 2011 22:25

Im trying to access to my web from my neighbours wifi :D

Apache and MySQL are both on green, I've tried uninstalling the module services and still the same.
morfasto
 
Posts: 5
Joined: 04. October 2011 20:49


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 65 guests