localhost wont load

Problems with the Windows version of XAMPP, questions, comments, and anything related.

localhost wont load

Postby landline » 06. October 2011 16:19

I don't know whats wrong. I use xampp to test some website stuff, and see if I want to use it on my website. And so far xampp has been working great but last night i logged off my computer, then logged back on, and now localhost wont load. apache and MySQL start, but xampp doesnt load. I have tried localhost, localhost/phpmyadmin, 127.0.0.1, etc
I reinstalled xampp, and still same problem.
He is my error code i found in apache>logs>error

"An operation was attempted on something that is not a socket." And "Encountered too many errors accepting client connections. Possible causes: dynamic address renewal, or incompatible VPN or firewall software. Try using the Win32DisableAcceptEx directive.
landline
 
Posts: 2
Joined: 06. October 2011 16:12

Re: localhost wont load

Postby Sharley » 06. October 2011 16:59

We require your XAMPP version and your Windows Version to provide the correct version support.
viewtopic.php?f=16&t=48331
viewtopic.php?f=16&t=32670

Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: localhost wont load

Postby landline » 06. October 2011 20:20

Oh, sorry. I'm using Windows Vista, service pack 1 i think..... It has been working for months, and all of a sudden it stopped.
And I was using xampp 17.1, then i uninstalled it, and now im using the new 1.7.7 but still same issue. except now the error code is
"(OS 10038)An operation was attempted on something that is not a socket. : winnt_accept: getsockname error on listening socket, is IPv6 available?"
landline
 
Posts: 2
Joined: 06. October 2011 16:12

Re: localhost wont load

Postby Sharley » 06. October 2011 20:42

Often Windows automatic updates can be the culprit in issues like this. :(

Open your C:\Windows\Sytem32\Drivers\etc\HOSTS file by dragging it into an open text editor window and paste back here what you see.

Also you can open C:\xampp\apache\conf\extra\httpd-mpm.conf and find this section and change it so it looks like this ie remove the # from Win32DiasbleAcceptEx
Code: Select all
# WinNT MPM
# ThreadsPerChild: constant number of worker threads in the server process
# MaxRequestsPerChild: maximum  number of requests a server process serves
# Win32DisableAcceptEx: Use accept() rather than AcceptEx() to accept network connections
<IfModule mpm_winnt_module>
    ThreadsPerChild      150
    MaxRequestsPerChild    0
    Win32DisableAcceptEx
</IfModule>
Then save this file and restart Apache and try again.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: localhost wont load

Postby Dvelvet84 » 12. October 2011 22:32

I had this same problem, and it was a Windows update that caused the problem as mentioned. I had attempted to remove the update, but it still did not work. Fortunately, my system had created a restore point before hand, so rolling back to before that restore point resolved my issue.
Dvelvet84
 
Posts: 1
Joined: 12. October 2011 22:17

Re: localhost wont load

Postby mkozlov » 24. November 2011 16:18

I just had the same problem and stumbled upon a solution. This is what worked for me:

Open this file: C:\Windows\Sytem32\Drivers\etc\HOSTS

Then find the following line and remove the leading '#' character.
Code: Select all
#   127.0.0.1       localhost
mkozlov
 
Posts: 1
Joined: 24. November 2011 16:15
Operating System: Windows 7 SP1


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests