Apache Won't Start Windows 7/64 (SOLVED)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache Won't Start Windows 7/64 (SOLVED)

Postby LEDFanCDN » 06. October 2011 04:50

Solved - viewtopic.php?f=16&t=48483

I have the same problem, exactly the same situation and symptoms but I cannot solve it since I'm running Windows 7 and cannot downlaod your dll file (for Vista, XP, etc. only).

I'm running as an administrator with UAC at OFF and using it as a Win32 app.

How can I resolve this?
Last edited by Sharley on 06. October 2011 19:21, edited 4 times in total.
Reason: Started a new topic as your post is not OS related to the above solved issue.
LEDFanCDN
 
Posts: 7
Joined: 06. October 2011 04:47

Re: Apache Won't Start - Version 1.7.7 (SOLVED)

Postby Sharley » 06. October 2011 05:00

What version of XAMPP?
viewtopic.php?f=16&t=48331
viewtopic.php?f=16&t=32670


LEDFanCDN wrote:I have the same problem, exactly the same situation and symptoms
Tell us about them.
LEDFanCDN wrote:but I cannot solve it since I'm running Windows 7 and cannot downlaod your dll file (for Vista, XP, etc. only).
I would assume then that the dll, which is not ours but Microsofts, is already installed in W7 again what is stopping you from trying to download it?

LEDFanCDN wrote:I'm running as an administrator with UAC at OFF and using it as a Win32 app.
Where on your drive did you install it exactly?

LEDFanCDN wrote:How can I resolve this?
Try some of the other methods offered in this topic.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache Won't Start - Version 1.7.7 (SOLVED)

Postby LEDFanCDN » 06. October 2011 05:16

Sharley wrote:What version of XAMPP?
http://community.apachefriends.org/f/viewtopic.php?f=16&t=48331
http://community.apachefriends.org/f/viewtopic.php?f=16&t=32670

I'm using version 1.7.7 latest one first install (no other previous versions)

LEDFanCDN wrote:I have the same problem, exactly the same situation and symptoms. Tell us about them.

Well same problems the previous user had, Apache is not starting but MySQL does start. When trying to start Apache with the batch files, small black screen appears but close right away.
Ports 80 and 443 are free (No Teamviewer of whatever...) etc like I told you same symptoms.

LEDFanCDN wrote:but I cannot solve it since I'm running Windows 7 and cannot downlaod your dll file (for Vista, XP, etc. only).I would assume then that the dll, which is not ours but Microsofts, is already installed in W7 again what is stopping you from trying to download it?

It says on Microsoft site to not install it when you are running more recent packages of them.

LEDFanCDN wrote:I'm running as an administrator with UAC at OFF and using it as a Win32 app.Where on your drive did you install it exactly?

Xampp is intalled on C:\Program Files (x86)\xampp

LEDFanCDN wrote:How can I resolve this? Try some of the other methods offered in this topic.

I tried all solutions in this topic and no go.

I'd like to attach images but it's not possible here... is it?
LEDFanCDN
 
Posts: 7
Joined: 06. October 2011 04:47

Re: Apache Won't Start - Version 1.7.7 (SOLVED)

Postby Sharley » 06. October 2011 05:28

LEDFanCDN wrote:Xampp is intalled on C:\Program Files (x86)\xampp
This is your problem and you really should have read the readme_en.txt file in the xampp folder or here
http://www.apachefriends.org/en/xampp-windows.html
as the XAMPP installation should be in the root of a drive for example the C:\ so you have C:\xampp

Issues arise when spaces and special characters are in the folder paths in XAMPP

You would need to uninstall and reinstall to the correct location.

Good luck :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Apache Won't Start Windows 7/64

Postby davidhussy11 » 06. October 2011 19:14

I'm sorry, it's true I did not read and I should have. It's because I had Vista before and using c:\Program Files was working so I though it would be the same.

Thanks for your support, it now works.
davidhussy11
 
Posts: 1
Joined: 06. October 2011 18:50

Re: Apache Won't Start Windows 7/64

Postby Sharley » 06. October 2011 19:19

Latest news:
It has been pointed out that the latest runtime components will work on old and new Windows versions so you can get it from here:
http://www.microsoft.com/download/en/de ... px?id=5582


Good result and thanks for the feedback. 8)

Best wishes. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests