cannot login to website with internet explorer

Problems with the Windows version of XAMPP, questions, comments, and anything related.

cannot login to website with internet explorer

Postby rohonupe99 » 03. October 2011 23:20

I host 2 social websites using the open source software called ELGG that uses mysql databases.I have my domains registered with a company called POWWEB.com under a shared hosting plan. As you know with shared hosting, there are limitations on mysql database access, so I decided to use my PC as a webserver, and I installed, and am currently running my 2 sites using the XAMPP server software on my windows xp professional operating system. In order for me to do this, I had to point to the IP address on my PC, since that is where the files and database his hosted now, since I moved them over to my PC. So here is the problem I'm having. ON the POWWEB.COM control panel in the section where you point to the url of your site, it has a STEALTH option. when you select this option, the IP address is hidden in the web address, so that it shows MYWEBSITE.COM/WHATEVER PAGE. The problem is, when I do this, my members are not able to log into my website from internet explorer. I've tested on firefox, and I can log in. but in internet explorer it will not log in. I'm posting this on the forum for the ELGG software also, to make sure that it is not a bug in their system. So if anyone can offer a solution, I would really appreciate it. By the way, when I don't select the stealth option, I am able to log into my website in internet explorer. It's only when I try to use the stealth option to hide the IP address, when I'm not able to log in using internet explorer.
rohonupe99
 
Posts: 7
Joined: 03. October 2011 22:56

Re: cannot login to website with internet explorer

Postby Sharley » 03. October 2011 23:24

We require your XAMPP version and your Windows Version to provide the correct version support.
viewtopic.php?f=16&t=48331
viewtopic.php?f=16&t=32670

Also please don't post in one huge continuous paragraph as it is very hard to read - try splitting the sentences into paragraphs ie add a blank line between sentences.

Thanks. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: cannot login to website with internet explorer

Postby rohonupe99 » 03. October 2011 23:35

i'm using xp professional and the latest xampp version


sorry, my mistake, but xampp 1.7.4 is the version i'm using.
rohonupe99
 
Posts: 7
Joined: 03. October 2011 22:56

Re: cannot login to website with internet explorer

Postby Sharley » 03. October 2011 23:40

It may be a privacy or security setting in IE that may need attention.

My guess is a browser setting if Firefox is working as it should.

Do you get an error message?

Are there any clues in the \xampp\apache\logs\error.log or access.log files?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: cannot login to website with internet explorer

Postby rohonupe99 » 04. October 2011 00:15

I got this in the error.log file

[Mon Oct 03 18:03:42 2011] [error] [client my-ip-address] PHP WARNING: 2011-10-03 18:03:42 (CDT): "opendir(views_counter/languages) [<a href='function.opendir'>function.opendir</a>]: failed to open dir: No such file or directory" in file C:\\xampp\\htdocs\\bama\\bama\\engine\\lib\\languages.php (line 128), referer: http://my-ip-address/bama/bama/pg/dashboard/
rohonupe99
 
Posts: 7
Joined: 03. October 2011 22:56

Re: cannot login to website with internet explorer

Postby Sharley » 04. October 2011 00:25

You may have a path configuration issue in bama, what ever that is.

You may have an absolute path beginning with a / instead of beginning with no forward slash, a relative path.

It is looking for C:\xampp\htdocs\bama\bama\engine\lib folder. do you have such a folder tree?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: cannot login to website with internet explorer

Postby rohonupe99 » 04. October 2011 00:30

yes, that folder exists and has files in it. i'm noticing though from what i just posted that there are double slashes in the path in the error that i just posted. it's saying C:\\xampp\\htdocs\\bama\\bama\\engine\\lib\\languages.php


instead of it saying
C:\xampp\htdocs\bama\bama\engine\lib


would that have something to do with it? i don't understand why it would put double slashes insted of single slashes in the file path
rohonupe99
 
Posts: 7
Joined: 03. October 2011 22:56

Re: cannot login to website with internet explorer

Postby Sharley » 04. October 2011 00:39

rohonupe99 wrote:[Mon Oct 03 18:03:42 2011] [error] [client my-ip-address] PHP WARNING: 2011-10-03 18:03:42 (CDT): "opendir(views_counter/languages) [<a href='function.opendir'>function.opendir</a>]: failed to open dir: No such file or directory" in file C:\\xampp\\htdocs\\bama\\bama\\engine\\lib\\languages.php (line 128), referer: http://my-ip-address/bama/bama/pg/dashboard/
What does the line of code referenced in the error message say?

In your configuration is there a setting that uses the full path
C:\xampp\htdocs\bama\bama\engine\lib
without quotes?

Or with quotes?
"C:\xampp\htdocs\bama\bama\engine\lib"
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: cannot login to website with internet explorer

Postby rohonupe99 » 04. October 2011 00:47

This is the page that should be displayed when a user logs in. i want it to show mydomain instead of my-ip-address.

http://my-ip-address/bama/bama/pg/dashboard/


i will have to look through the files to locate whether or not there are quotes around that path
rohonupe99
 
Posts: 7
Joined: 03. October 2011 22:56

Re: cannot login to website with internet explorer

Postby Sharley » 04. October 2011 00:57

Also look for a configuration setting that references your IP instead of your domain name.

I don't believe that your issue is with the way XAMPP is configured by default because Apache is listening on port 80 for any connection be it IP or domain name.

In the web root folder you have a .htaccess file which should have the RewriteBase /bam uncommented as per these instructions:
http://docs.elgg.org/wiki/Installation

Here is something you could try and that is to put your web site directly in the htdocs folder (DocumentRoot/web root folder) ie not in a folder of it's own and delete the 2 index file that belong to XAMPP.
See these troubleshooting tips:
http://docs.elgg.org/wiki/Install_Troubleshooting

Did you follow these XAMPP specific instructions - but my method of directly adding your web site to the htdocs folder is still worth considering:
http://docs.elgg.org/wiki/Install_XAMPP



Finally and very important, XAMPP is not meant for use in a production environment open to the public because of security concerns, but rather it is designed for development use at localhost level only.

So I can't recommend XAMPP for your intended purpose - see Zend Server (CE) for a free production environment server ( thank Altrea ).

Good luck :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 39 guests