Help with curl please?

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Help with curl please?

Postby bellamandu » 03. October 2011 01:57

Ok, to start, this is what I have in my readme file in regards to what I have...

+ Apache 2.2.21
+ MySQL 5.5.16 (Community Server)
+ PHP 5.3.8 (VC9 X86 32bit thread safe) + PEAR
+ XAMPP Control Panel Version 2.5 from www.nat32.com
+ (BETA) XAMPP Control Panel Version 3.0.2 by Steffen Strueber (not in the USB & lite version)
see http://community.apachefriends.org/f/viewtopic.php?f=16&t=46743
+ XAMPP Security
+ OpenSSL 1.0.0e
+ phpMyAdmin 3.4.5
+ ADOdb 5.14
+ Mercury Mail Transport System v4.62 (not in the USB & lite version)
+ FileZilla FTP Server 0.9.39 (not in the USB & lite version)
+ Webalizer 2.23-04 (not in the USB & lite version)
+ Perl 5.10.1 (not in the USB & lite version)
+ Mod_perl 2.0.4 (not in the USB & lite version)
+ Tomcat 7.0.21 (not in the USB & lite version)

I'm running on Windows Vista 32 bit. I currently only have Apache running as a service.

Here's, the deal. I began about a week ago trying to start a home web server to host a modified zazzle (zazzle.com) storebuilder page as the webhost i was using before didn't support curl, and curl is required for zazzle storebuilder grids. I started with just using apache 2.2 and php 5, and couldn't get php running for the life of me. I finally wound up switching over to XAMPP and it works fine now. HOWEVER, curl still isn't functioning.

I started from a fresh install, and removed the ; from the curl extenstions line. That didn't work. I wound up going through about 10-15 different tutorials, none of which worked, before I started back on a fresh install, and removed the semicolon again. PHP is working, and I can verify that with my phpinfo test page. Unfortunately I still have yet to see any section on phpinfo in regards to curl, and my test page for the storebuilder grids also don't work.

I've been eyeing code for two days straight now, will someone please tell me what I am missing? None of the online tutorials I have found work, so I'm assuming they are outdated?
bellamandu
 
Posts: 6
Joined: 03. October 2011 01:46

Re: Help with curl please?

Postby Sharley » 03. October 2011 02:04

Did you save the php.ini file and then restart Apache as I can see Curl in the phpinfo after uncommenting the curl extension, saving and restarting Apache.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Help with curl please?

Postby bellamandu » 03. October 2011 02:08

yes i did, again and again lol

still nothing.

this is my phpinfo file, i have it loaded as index currently: http://bellasgreatdesigns.com/

not there... unless i really need a new pair of glasses? :lol:

would it make any difference if i am using DynDNS? although, it doesn't show on localhost either.
bellamandu
 
Posts: 6
Joined: 03. October 2011 01:46

Re: Help with curl please?

Postby Sharley » 03. October 2011 02:10

Open the phpinfo file and look for this item "Loaded configuration file" and tell me what you see please.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Help with curl please?

Postby bellamandu » 03. October 2011 02:12

C:\xampp\php\php.ini

this is also the one i uncommented.
bellamandu
 
Posts: 6
Joined: 03. October 2011 01:46

Re: Help with curl please?

Postby Sharley » 03. October 2011 02:19

Then I suggest your installation may some how be corrupt as I can't replicate your issue - you are logged in as Administrator in Vista?

Try this phpinfo:
http://localhost/xampp/phpinfo.php

I suggest you uninstall then a reinstall using a different zip or 7zip method.

Try these instructions that may simplify the process:
viewtopic.php?p=179699#p179699

Please let me know back if you are successful or if there is any issues with the fresh install.

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Help with curl please?

Postby bellamandu » 03. October 2011 02:20

k i will do that... thanks.
bellamandu
 
Posts: 6
Joined: 03. October 2011 01:46

Re: Help with curl please?

Postby Sharley » 03. October 2011 02:23

I edited my post for you to try the XAMPP phpinfo first before un-installing. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Help with curl please?

Postby bellamandu » 03. October 2011 02:26

i got it! what a save!

i was about to uninstall...went to stop apache and got error-1.... searched forums. the fix for that error just so happens to also fix my issue and i can now see curl. yay!
bellamandu
 
Posts: 6
Joined: 03. October 2011 01:46

Re: Help with curl please?

Postby Sharley » 03. October 2011 02:30

bellamandu wrote:...went to stop apache and got error-1.... searched forums. the fix for that error just so happens to also fix my issue and i can now see curl...
Mind telling the forum what that fix was please so others reading this can also benefit without having to search.

Or type in the link address to the fix post.

Thanks. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 79 guests