PHP Startup Warning

Problems with the Windows version of XAMPP, questions, comments, and anything related.

PHP Startup Warning

Postby Jubic » 02. October 2011 06:55

PHP Startup: ming: Unable to initialize module
Module compiled with build ID=API20090626,TS,VC6
PHP compiled with build ID=API20090626,TS,VC9
These options need to match


Everytime I startup apache/mysql, the above warning would appear, any solutions?
Jubic
 
Posts: 7
Joined: 01. September 2011 07:10

Re: PHP Startup Warning

Postby Sharley » 02. October 2011 06:57

Thewre have been big changes so require your XAMPP version and your Windows Version to provide the correct version support.
viewtopic.php?f=16&t=48331
viewtopic.php?f=16&t=32670

Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: PHP Startup Warning

Postby Jubic » 02. October 2011 07:03

XAMPP version 1.7.7
Control Panel version 2.5
Windows 7 Enterprise
Jubic
 
Posts: 7
Joined: 01. September 2011 07:10

Re: PHP Startup Warning

Postby Sharley » 02. October 2011 07:08

Exit the 2.5 CP and open the xampp-control-beta-3.exe and see what the log window has to say as it is more helpful for troubleshooting and has many more features - you can create a shortcut for easy access.

You can paste the contents of the log windows here.

Seems something is not compatible with the VC9 compile.

Any clues in the Apache error log file?

Did you upgrade to 1.7.7 by overwriting your older version instead of a fresh install after deleting your old version?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: PHP Startup Warning

Postby Jubic » 02. October 2011 07:15

[Sun Oct 02 14:12:55 2011] [warn] pid file C:/xampp/apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sun Oct 02 14:12:55 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Oct 02 14:12:55 2011] [notice] Digest: done
PHP Warning: PHP Startup: ming: Unable to initialize module\nModule compiled with build ID=API20090626,TS,VC6\nPHP compiled with build ID=API20090626,TS,VC9\nThese options need to match\n in Unknown on line 0
<br />
<b>Warning</b>: PHP Startup: ming: Unable to initialize module
Module compiled with build ID=API20090626,TS,VC6
PHP compiled with build ID=API20090626,TS,VC9
These options need to match
in <b>Unknown</b> on line <b>0</b><br />
[Sun Oct 02 14:13:00 2011] [notice] Apache/2.2.21 (Win32) mod_ssl/2.2.21 OpenSSL/1.0.0e PHP/5.3.8 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Sun Oct 02 14:13:00 2011] [notice] Server built: Sep 10 2011 11:34:11
[Sun Oct 02 14:13:00 2011] [notice] Parent: Created child process 5920
[Sun Oct 02 14:13:03 2011] [notice] Digest: generating secret for digest authentication ...
[Sun Oct 02 14:13:03 2011] [notice] Digest: done
Jubic
 
Posts: 7
Joined: 01. September 2011 07:10

Re: PHP Startup Warning

Postby Sharley » 02. October 2011 07:27

Do you have 2 XAMPP versions installed - One the older VC6 compiled and the other 1.7.7 VC9 compiled?

Any help?
viewtopic.php?f=16&t=42772
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: PHP Startup Warning

Postby tjeran » 03. February 2012 23:01

I had the same problem, php5.3.8 used in xampp 1.7.7 was compiled with the vc9 compiler. The last version of php_ming.dll supported by php.net was compiled with the vc6 compiler. Evidently the vc9 compiler versions of php do not tolerate older compilers. php.net does not support ming although its documentation does. Support for ming now resides with libming.org. But you will not find any binaries there.
To solve the problem you can get the code from libming.org and compile it with a vc9 compiler. Alternately, if you don't need ming, you can comment out the ming extension in the php.ini file. What if any flash capability you have left I am uncertain.
tjeran
 
Posts: 1
Joined: 03. February 2012 22:23
Operating System: windows xp


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 63 guests