XAMPP Win7 32-bit Theme issue

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP Win7 32-bit Theme issue

Postby maxnetix » 28. September 2011 18:56

Bitte, mein deutsch ist nichts so gut - so please forgive my posts in American English...

Greetings from sunny New Hampshire USA where it is a sunny lovely 73F 28 September 2011 Fall day and a great apple pick your own season underway.

Now on to business - I just installed the latest XAMPP distribution 1.7.7 on a Windows 7 Ultimate machine fully patched and updated with Win 7 SP1 and all critical and security updates on a Dual core AMD cpu chips server box and I then installed the latest WordPress v3.2.1 AOK (Had to struggle to find the right install path turns out http://localhost/wp-admin/install.php popped up and WP install worked fine from the latest Chrome bowser.

So being a security wonk I ran the security scripts OK and security reports:
These XAMPP pages are no longer accessible by network for everyone SECURE
The MySQL admin user root has no longer no password SECURE
PhpMyAdmin password login is enabled. SECURE
PHP is NOT running in "safe mode"

So what is the Problem you wonder - a simple problem with, I hope, a simple solution...

I am able to login to the WordPress Console and Dashboard as Admin just fine and was able to install the new iFeature "Apple Like" Theme just fine on my underway pilot project 1 "up1" but when logged into the WordPress 3.2.1 dashboard and I try to click on my project link I call "up1" in the upper left of the WP dashboard screen http://localhost/wp-admin/index.php instead of going to the "up1" project iFeature theme home page to view my live pilot site build - I get the http://localhost/xampp/ default XAMPP console page instead. Any ideas on how to fix this bug are appreciated as I do not want to poke around and break something else in XAMPP stack if at all possible.

Viel Danke for the wonder XAMPP project.

Best regrds and thank you for reading my post.

Mike in New Hampshire USA
Last edited by Altrea on 28. September 2011 19:31, edited 1 time in total.
Reason: moved: if you want to post in english, then please use the english part of the board
Posts: 3
Joined: 28. September 2011 18:10

Re: XAMPP Win7 32-bit Theme issue

Postby maxnetix » 28. September 2011 19:57

Altrea - when I authenticated my registration with the board it moved me from the English section to the German which is where I posted but I will post there too if I must... I did read the Board TOU and intro posts which clearly states that posting in English is not Verboten.
Posts: 3
Joined: 28. September 2011 18:10

Re: Win7 SP1 XAMPP WordPress Project Site Home Page bug

Postby maxnetix » 28. September 2011 20:19

Turns out the fix was simple - when I unzipped and copied the WordPress files to the htdocs folder it asked me if I wanted to overwrite the index.php file and I selected copy and save both. It saved the WP index.php file as index(2).php - on opening and reading the WP index.php specifically states that its purpose is to load the wp-blog-header.php that loads the WP theme.

Saved the XAMPP index.php as indexBAKxampp.php, opened and saved index(2).php as just index.php with code below and clicked on the up1 project in the WP dashboard and everything now seems to work fine...

Code: Select all
 * Front to the WordPress application. This file doesn't do anything, but loads
 * wp-blog-header.php which does and tells WordPress to load the theme.
 * @package WordPress

 * Tells WordPress to load the WordPress theme and output it.
 * @var bool
define('WP_USE_THEMES', true);

/** Loads the WordPress Environment and Template */
Posts: 3
Joined: 28. September 2011 18:10

Re: XAMPP Win7 32-bit Theme issue

Postby Sharley » 28. September 2011 21:41

Hello Mike,
Altrea is quite justified in moving your post as the general rule is that you post in German in the German language only forum and only in English in the English language forum and if you look in these forums you will see that you are not alone as their are many posts that have to be moved.

XAMPP is a German developed project and so the Apache Friends support forum is set up to default to the German language forums.

Thanks for your understanding in this matter as it does help the board to run smoothly. 8)

Best wishes. :)
User avatar
AF Moderator
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 72 guests