XAMPP lite not working

Problems with the Windows version of XAMPP, questions, comments, and anything related.

XAMPP lite not working

Postby carolyn99 » 28. September 2011 07:32

I have had a seperate PHP/MySQL and Apache server working fine locally and i read somewhere that its a good idea to have XAMPP locally to test WordPress instead of doing 'live' changes on internet.

Been trying to do this for the last week - started with trying to get XAMPP (not lite) and that has failed but i have been mucking around and have now got it to the stage where i go to
http://localhost/xampp/index.php and it asks for language - i put in english, and then when i go here i get

Congratulations:
You have successfully installed XAMPP on this system!
Now you can start using Apache and Co. You should first try »Status« on the left navigation to make sure everything works fine.

so i check status, and it says all started except MySQL database which is 'deactivated'

The next step in the instructions (http://tamba2.org.uk/wordpress/xampp/) says to go to "After you have clicked your language and entered the program, click phpMyAdmin."

I do this and i get

Error
MySQL said:

#1045 - Access denied for user 'root'@'localhost' (using password: NO)

Connection for controluser as defined in your configuration failed.
phpMyAdmin tried to connect to the MySQL server, and the server rejected the connection. You should check the host, username and password in your configuration and make sure that they correspond to the information given by the administrator of the MySQL server.

In orer to even get this far has been a nightmare, and i think it's because i have a previous install of PHP, MySQL and apache - which i used to test that my PHP scripts were working (these connect to the database and retrieve some info).

I'm not sure how to go further now. I dont want to delete my database - is there any other suggestions ? Is it trying to connect to my existing database? and if so where could i change the login info as its not gonna work with 'root'@'localhost' (using password: NO) as my existing database has a root password. I was under the impression it would create a new database, but i dont know the XAMPP product?

Thanks

Carolyn
carolyn99
 
Posts: 6
Joined: 23. September 2011 09:12

Re: XAMPP lite not working

Postby Sharley » 28. September 2011 07:36

What versions are we dealing with here? :shock:
viewtopic.php?f=16&t=48331

Please read the forum Announcements before posting.

Your issue have been well covered in here many time even just recently.

Have you started MySQL in the Xampp Control Panel and does it stay running?

Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP lite not working

Postby carolyn99 » 28. September 2011 09:07

Sorry about that i'm just getting soo frustrated with this as as i said i've been tryng for about a week to get xampp working - the versions are xampp-win32-1.7.7-usb-lite.exe the version of mysql is 5.1.48 and apache is 2.2

since posting this i've set my root password to empty which i've confirmed by going to cmd prompt and issuing 'mysql -u root -p' and just entering when it asks for a password.

i was trying to check the http://localhost/xampp/splash.php to try the mysql section again and its now saying that it cant find the page...

I have started the services both by using the control panel of xampp and also with the control panel services of windows and yes, they do stay up.

Now i dont know why the page cant be found - if i go to start, all programs, Apache HTTP server 2.2, Configure the apache server, edit the apache httptd.conf configuration file
the entries that i have for this is how it was set up beore but i made a change to

DocumentRoot "C:/" and

<Directory "C:/">

im not sure if i need any other entries in here to make it 'see' the http://localhost/xampp/splash.php ? and to be honest, this file doesn't exist here so i dont know how i saw it the first time

i'll search for the issue here, and in the meantime if u have any ideas, that would be great.

Carolyn
carolyn99
 
Posts: 6
Joined: 23. September 2011 09:12

Re: XAMPP lite not working

Postby carolyn99 » 28. September 2011 09:19

http://localhost/xampp/splash.php is not here and neither is http://localhost/xampp/index.php - what is the correct file? and where should it be? to get the screen that i got before? where it asks me to select a language - i'm assuming (but dont know for sure ) that its in the apache httptd.conf that localhost is defined by DocumentRoot "C:/"

i say that as in my previous working setup i had these set to <dirctory "C:/Websites"> and all my php files where there and where found fine - so if i put in 'localhost/index.php' then the index.php file would be run but maybe my understanding of this is incorrect?
carolyn99
 
Posts: 6
Joined: 23. September 2011 09:12

Re: XAMPP lite not working

Postby carolyn99 » 28. September 2011 09:33

sorry forgot to put in im running
OS = Windows 7 home premium
carolyn99
 
Posts: 6
Joined: 23. September 2011 09:12

Re: XAMPP lite not working

Postby Sharley » 28. September 2011 09:39

You may want to start again.

First you unpack or install XAMPP to C:\xampplite

Then you double click on the xampp_control.exe and Start Apache and MySQL but to do anything serious with XAMPP you should really right click on this file and select to Run as Administrator.

When they both show running all is well.

Next you go to http://localhost in your browser and it will redirect you to the splash screen where you select your language and proceed to the Welcome page.

What you don't do is configure anything until you have exercised all the demos in the left menu of the Welcome page to test your installation.

When you are happy that the installation is working then you can add your web site files into C:\xampplite\htdocs in a folder of choice, for example C:\xampplite\htdocs\wordpress

To see your site you would type http://locahost/wordpress in browser and proceed to install WP.

Don't use the command console.

Use the provided GUIs like http://locahost/phpmyadmin to setup WP's database.

Use Windows Explorer to locate the files in the C:\xampplite folder only, you can edit files from within Explorer if required.

Don't edit any configuration files as the defaults work just fine for what you are trying to do.

I am not sure if the lite version is suitable for WP but only time will tell. :)

I hope this helps you to move forward.

Good luck. :)

Here are a couple of links that also have some useful info for new users:
http://www.apachefriends.org/en/xampp-windows.html
http://www.apachefriends.org/en/faq-xampp-windows.html

Plus the readme file in the c:\xampplite folder,
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP lite not working

Postby carolyn99 » 28. September 2011 10:14

thanx so much for your lightning fast response!

Ok, so when you say 'You may want to start again.' are you meaning get rid of php, mysql and apache as well as the xampp lite? or just the xampp lite and leave the other products there? I have a feeling that this issue may be because i have these products installed prior to trying to get xampp as well and my only problem with this if so would be that i reall want my db to be able to still be available after.

I do have an export of the db, but i've had so many issues doing the xampp lite/xampp insall im really worried about messing up my current config so that i wont be able to test my php

so do you think there'll be any probs later if you do mean to remove all? sorry to be so pedantic but i cant think straight at moment due to head spinning from all problems ive fixed or trying to fix

thx

carolyn
carolyn99
 
Posts: 6
Joined: 23. September 2011 09:12

Re: XAMPP lite not working

Postby Sharley » 28. September 2011 10:24

carolyn99 wrote:Ok, so when you say 'You may want to start again.' are you meaning get rid of php, mysql and apache
Keep xampplite and uninstall the others keeping your database exports as you can't use both at the same time and really XAMPP takes care of all the housework.

Using phpMyAdmin to create your WP database you can then import your database sql file into the MySQL of xampplite again using phpMyAdmin.

Best wishes.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: XAMPP lite not working

Postby carolyn99 » 29. September 2011 07:08

I wanted to say a huge THANK YOU - alls working since I did the deinstall of PHP/MySQ: and Apache - was how I thought it should be - easy !!

Thanks again
carolyn99
 
Posts: 6
Joined: 23. September 2011 09:12


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 46 guests