phpmyadmin help

Problems with the Windows version of XAMPP, questions, comments, and anything related.

phpmyadmin help

Postby whopunk123 » 24. September 2011 17:01

When I try to set up a database with phpmyadmin it says Access denied and on the status page it says MySQL database DEACTIVATED
does anyone know how to fix this?
pls can someone help me.
Last edited by whopunk123 on 24. September 2011 17:49, edited 2 times in total.
whopunk123
 
Posts: 3
Joined: 24. September 2011 16:57

Re: phpmyadmin help

Postby whopunk123 » 24. September 2011 17:33

please help me why is no one helping :cry:
whopunk123
 
Posts: 3
Joined: 24. September 2011 16:57

Re: help pls

Postby Sharley » 24. September 2011 17:36

We require your XAMPP version and your Windows Version to provide the correct version support.
viewtopic.php?f=16&t=48331
viewtopic.php?f=16&t=32670

Did you forget something perhaps?

Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: help pls

Postby whopunk123 » 24. September 2011 17:44

Windows 7 ultimate service pack 1

XAMPP 1.7.7

hope this helps
Last edited by Sharley on 25. September 2011 08:26, edited 1 time in total.
Reason: Please rezise your image to no bigger than 800wx600h
whopunk123
 
Posts: 3
Joined: 24. September 2011 16:57

Re: phpmyadmin help

Postby JonB » 25. September 2011 16:29

I will give you a GUESS, and ask for some info.

I think its a socket error induced by Win 7 SP1 - a guess based on a previous post I answered. (I have not located it yet)

please post that last part of :
C:\xampp\mysql\data\mysql_error.log

If your XAMPP is not in C:\xampp, then change that to wherever XAMPP is -

Good Luck
8)

BTW - this forum relies on about 4 or 5 VOLUNTEERS from around the world to answer posts - that's it - no mas. I think all of us have jobs, mostly in IT or development

please help me why is no one helping


We check every hour or so for new posts, sometimes more, sometimes less, often while we are working - and then we actually sleep, go shopping, have s*x, etc....
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: phpmyadmin help

Postby hackattack142 » 25. September 2011 20:35

I use Win 7 SP1 x64 and when I do a fresh install, I always have to add or uncomment "bind-address="127.0.0.1"" from "xampp/mysql/bin/my.ini" under the "[mysqld]" section before MySQL shows up as activated on the status page.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: phpmyadmin help

Postby wlawl3ss » 27. September 2011 01:48

Hello All, I (not OP) have the exact same problem and would greatly appreciate any help and advice given
Im new to php so please excuse my ignorance

Here is my setup
Win 7 64bit Sp1
XAMMP 1.7.4

heres a screencap of my localhost status and xammp control panel
http://i.imgur.com/fO8Kd.png

and another poster had asked OP to post the last part of his error log so here is the last paragraph so to say of mine

110926 17:18:14 [Note] Plugin 'FEDERATED' is disabled.
InnoDB: The InnoDB memory heap is disabled
InnoDB: Mutexes and rw_locks use Windows interlocked functions
InnoDB: Compressed tables use zlib 1.2.3
110926 17:18:15 InnoDB: Initializing buffer pool, size = 16.0M
110926 17:18:15 InnoDB: Completed initialization of buffer pool
110926 17:18:16 InnoDB: highest supported file format is Barracuda.
110926 17:18:17 InnoDB: 1.1.4 started; log sequence number 1595675
110926 17:18:19 [Note] Event Scheduler: Loaded 0 events
110926 17:18:19 [Note] c:\xampp\mysql\bin\mysqld.exe: ready for connections.
Version: '5.5.8' socket: '' port: 3306 MySQL Community Server (GPL)

again thank you for any help
Last edited by Sharley on 27. September 2011 02:03, edited 1 time in total.
Reason: Sorry, direct outside links not permitted for new users, simply type in the link - spam prevention measure
wlawl3ss
 
Posts: 2
Joined: 27. September 2011 01:29

Re: phpmyadmin help

Postby Sharley » 27. September 2011 02:16

Your error.log file looks OK.

Did you try adding the item mentioned above in the post by Hackerattack142?

Also open with a text editor like notepad for example this file C:\xampp\phpmyadmin\config_inc.php and change this section to look like this:
Code: Select all
/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['compress'] = false;
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '';
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = true;

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '';
Clear your browser's temporary files (cache).
Save the file and restart MySQL - when saving in notepad make sure it does not add the txt extension or you will have errors.

Now try and access phpMyAdmin again using username root and no password - unless you set a password for user root in the Security menu of the Welcome page http://locahost/xampp/index.php

You may also have set a password for user pma which often causes this Deactivated issue. A password for user pma is not required.

As well as the above you could try this:

Stop both Apache and MySQL and remove the ticks in the Svc check boxes and answer yes.

Next Start Apache and MySQL and try phpMyAdmin again.
http://localhost/phpmyadmin.

BTW thanks for the detailed post, much appreciated. 8)

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpmyadmin help

Postby wlawl3ss » 27. September 2011 03:25

ok after making the above mentioned suggestions i am now able to see the login to phpmyadmin screen but when i do i still receive the mysql error 2002 and mysql is still deactivated among the status list. also when i tried to stop MySQL after i cleared my cache and saved the config_inc it would give me an error in my xammp control panel saying MySQL service not stopped (-1)

hmm ive been at this roadblock for two weeks now and no clue where to go from here
wlawl3ss
 
Posts: 2
Joined: 27. September 2011 01:29

Re: phpmyadmin help

Postby Sharley » 27. September 2011 04:14

Sometimes a reboot helps after editing system (registry) files, but not always. :)
When removing the tick in the Svc box in your CP it removes the Windows service entries for XAMPP in the registry.

May I suggest a fresh install using the latest 1.7.7 version after un-installing this version completely ( see linked post below ) but this time instead of using the installer exe file use the 7zip or zip archived version.

1.7.4 was a problem release with some bugs that affected Windows versions differently.

When you have the archive version downloaded open it and drag the xampp folder to the C:\ drive.

Then open the xampp folder and run the setup_xampp.bat file.

Here is a post that will give you some tips for un-installing and then installing with the archived versions.
viewtopic.php?p=179699#p179699

Good luck. :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: phpmyadmin help

Postby derekraeapfa » 02. October 2011 08:52

Thanks Sharley. Your post helps in solving my problem as well. Thank you so much.
derekraeapfa
 
Posts: 1
Joined: 02. October 2011 08:31


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 38 guests