apache newbie here, how to allow Apache to support .htaccess

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache newbie here, how to allow Apache to support .htaccess

Postby urboyfriend » 21. September 2011 10:03

how do we allow apache to support .htaccess files? i went to httpd and there was like 3 AllowOverride there :shock: thank you for the reply
urboyfriend
 
Posts: 4
Joined: 10. August 2011 11:13

Re: apache newbie here, how to allow Apache to support .htac

Postby Sharley » 21. September 2011 12:34

urboyfriend wrote:how do we allow apache to support .htaccess files?
Apache supports .htaccess and .htpasswd by default.

What's your problem :?:
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: apache newbie here, how to allow Apache to support .htac

Postby urboyfriend » 27. September 2011 05:11

i just want to know where to modify the option...
urboyfriend
 
Posts: 4
Joined: 10. August 2011 11:13

Re: apache newbie here, how to allow Apache to support .htac

Postby Sharley » 27. September 2011 05:27

http://httpd.apache.org/docs/2.2/mod/co ... owoverride

In the htdocs.conf file the 3 Allowoverride entries are correct and disallow .htaccess (none) by default in folders other than the htdocs folder - do not modify them.

If you want to allow .htaccess in other folders outside the htdocs folder (DocumentRoot) then you need to use a VirtualHost in the htdocs-vhosts.conf file in the extra folder of apache conf folder.

Otherwise you will seriously effect security if you allow .htaccess files in any folder outside the htdocs folder as entries in this file override security entries in the htdocs configuration files.

I ask again what is your problem with .htaccess file?

BTW please follow instructions here when ever you post for help:
viewtopic.php?f=16&t=48331
Thanks.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: apache newbie here, how to allow Apache to support .htac

Postby JonB » 27. September 2011 06:21

i just want to know where to modify the option...


Sadly urboyfriend, as .htaccess directives work both in the configuration '.conf' files and on a folder by folder basis by introducing individual .htaccess files into the directory tree, there is no 'one answer'. :shock:

- this is a very good introduction -
http://corz.org/serv/tricks/htaccess.php

http://httpd.apache.org/docs/2.0/howto/htaccess.html

So the answer you seek is - you change it where needed. Most likely in your DocumentRoot.

Good Luck
8)






ycf
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: apache newbie here, how to allow Apache to support .htac

Postby urboyfriend » 27. September 2011 07:16

Sharley wrote:http://httpd.apache.org/docs/2.2/mod/core.html#allowoverride

In the htdocs.conf file the 3 Allowoverride entries are correct and disallow .htaccess (none) by default in folders other than the htdocs folder - do not modify them.

If you want to allow .htaccess in other folders outside the htdocs folder (DocumentRoot) then you need to use a VirtualHost in the htdocs-vhosts.conf file in the extra folder of apache conf folder.

Otherwise you will seriously effect security if you allow .htaccess files in any folder outside the htdocs folder as entries in this file override security entries in the htdocs configuration files.

I ask again what is your problem with .htaccess file?

BTW please follow instructions here when ever you post for help:
http://community.apachefriends.org/f/viewtopic.php?f=16&t=48331
Thanks.



nothing much i was just lurking at the zend beginner's tutorial

http://akrabat.com/wp-content/uploads/Getting-Started-with-Zend-Framework.pdf

not sure where to edit the htacess, i just continue with the tutorial until i went to page 4, i discarded the problem and just pasted the folder in my local htdocs folder. all went fine there i guess. i am using xampp
urboyfriend
 
Posts: 4
Joined: 10. August 2011 11:13


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 73 guests