Xampp version 1.7.4 and 1.7.5 new install phpmyadmin problem

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Xampp version 1.7.4 and 1.7.5 new install phpmyadmin problem

Postby stevendoane » 19. September 2011 07:23

okay this is a new install of xampp version 1.7.4, i also tried 1.7.5
windows 7 home premium 64-bit
downloaded the .zip version

okay the apache server starts fine
the MySQL Server starts up just fine

something i noticed right off the bat was the mcrypt extension is missing from both version of xampp i listed above

the myphpadmin gives me an error when i try to access it

Existing configuration file (./config.inc.php) is not readable.

all the info i have found about the above error talks about chmod which does not mean anything on a windows server

i did edit config.inc.php i changed some of the info to protect my install but there it is:
Code: Select all
<?php
/*
 * This is needed for cookie based authentication to encrypt password in
 * cookie
 */
$cfg['blowfish_secret'] = 'xampp'; /* YOU SHOULD CHANGE THIS FOR A MORE SECURE COOKIE AUTH! */

/*
 * Servers configuration
 */
$i = 0;

/*
 * First server
 */
$i++;

/* Authentication type and info */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
$cfg['Servers'][$i]['user'] = 'root';
$cfg['Servers'][$i]['password'] = '123456';
$cfg['Servers'][$i]['extension'] = 'mysql';
$cfg['Servers'][$i]['AllowNoPassword'] = false;

/* User for advanced features */
$cfg['Servers'][$i]['controluser'] = 'pma';
$cfg['Servers'][$i]['controlpass'] = '123456';

/* Advanced phpMyAdmin features */
$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
$cfg['Servers'][$i]['relation'] = 'pma_relation';
$cfg['Servers'][$i]['table_info'] = 'pma_table_info';
$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
$cfg['Servers'][$i]['column_info'] = 'pma_column_info';
$cfg['Servers'][$i]['history'] = 'pma_history';
$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
$cfg['Servers'][$i]['tracking'] = 'pma_tracking';
$cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';

/*
 * End of servers configuration
 */

?>


I am at a loss with what is going on with it. i think it is because mcrypt extension is missing but not for sure....... please help
stevendoane
 
Posts: 6
Joined: 19. September 2011 07:01

Re: Xampp version 1.7.4 and 1.7.5 new install phpmyadmin pro

Postby Sharley » 19. September 2011 07:32

First replace the config_inc.php file back to it's default settings then save and restart Apache and mySQL.

Next try and access phpmyadmin without a password for user root - the default.
http://localhost/phpmyadmin

If you can access then do your security settings using the menu item in this page:
http://localhost/xampp/index.php

Let me know back what happens when you return the settings to default if it still does not allow access.

mcrypt no longer requires an extension as it is pre compiled into php.
http://locaslhost/xampp/phpinfo.php
Look for the mcrypt entry.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xampp version 1.7.4 and 1.7.5 new install phpmyadmin pro

Postby stevendoane » 19. September 2011 07:36

i have tried that also it does the same thing
i even deleted it all and did a fresh install without changing anything it always does the same thing
stevendoane
 
Posts: 6
Joined: 19. September 2011 07:01

Re: Xampp version 1.7.4 and 1.7.5 new install phpmyadmin pro

Postby Sharley » 19. September 2011 07:41

Where did you install XAMPP - what drive and folder tree did you use?
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xampp version 1.7.4 and 1.7.5 new install phpmyadmin pro

Postby stevendoane » 19. September 2011 07:48

xampp is installed on my external network drive directly on the root of the V:/ drive

v:/xampp
stevendoane
 
Posts: 6
Joined: 19. September 2011 07:01

Re: Xampp version 1.7.4 and 1.7.5 new install phpmyadmin pro

Postby Sharley » 19. September 2011 07:56

Using the zip version - it is registry agnostic - extract the xampp folder to the C;\ drive so you have c:\xampp then double click on the setup_xampp.bat file in the xampp folder and then try again.
http://localhost
and
http://localhost/phpmyadmin

Remember root user no password is the default.

If you can access phpMyAdmin then the issue may be with permission on the network drive.
You need administrator rights everywhere.

Make sure the xampp Apache and MySQL on the V drive are stopped before the C drive test.
You did run the setup_xampp.bat file on the V drive?

This is a test to see if the issue is with reading your network drive.

You can easily delete the XAMPP on the C drive after the test but again make sure you have stopped all xampp components before deleting the xampp folder.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xampp version 1.7.4 and 1.7.5 new install phpmyadmin pro

Postby stevendoane » 19. September 2011 08:01

my network drive requires a username to access the public directory folder there is no password set that is probably what is causing the issue now that i think about it. is there a way to input the username needed to give access

give me a min or so and i will test your theory
stevendoane
 
Posts: 6
Joined: 19. September 2011 07:01

Re: Xampp version 1.7.4 and 1.7.5 new install phpmyadmin pro

Postby Sharley » 19. September 2011 08:08

stevendoane wrote:my network drive requires a username to access the public directory folder there is no password set that is probably what is causing the issue now that i think about it. is there a way to input the username needed to give access
Not that I know of but install xampp not in the public access folder and then use a VirtualHost (research it) to have the public access DocumentRoot (htdocs) folder accessible using the password you set.

I am not familiar with your setup but the above may allow access to the private parts (xampp folder) of the network drive and access to the public parts (htdocs folder).

Another method with VirtualHosts is to install XAMPP on the C drive and have the DocumentRoot on the V drive accessible by the public only by password.

You can wait for other members who may have experience with your type of setup.

Good luck :)
Last edited by Sharley on 19. September 2011 08:11, edited 1 time in total.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Xampp version 1.7.4 and 1.7.5 new install phpmyadmin pro

Postby stevendoane » 19. September 2011 08:11

yeah it works on my internal hard drive just fine.....
stevendoane
 
Posts: 6
Joined: 19. September 2011 07:01

Re: Xampp version 1.7.4 and 1.7.5 new install phpmyadmin pro

Postby stevendoane » 19. September 2011 08:16

okay thank you for the info.

I would prefer to keep the xampp folder and the web directory on my external network hard drive so if anyone has info on how to do this please let me know

the external requires a username and password to access it so i would like to incorporate that into the program some how
stevendoane
 
Posts: 6
Joined: 19. September 2011 07:01


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 48 guests