Cant connect to my localhost!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Cant connect to my localhost!

Postby jlaursen » 18. September 2011 19:41

Hello

For some reason I seem unable to connect to localhost
Using Windows 7 64-Bit with xampp 1.7.4

I have xampp installed on my external harddrive, and in the beginning, there was no problem...
now... for some reason its like my computer dont want me to connect to localhost. Its just stuck at "Connected to localhost"

Im 100% sure its my computer because if I stick my hdd into my moms laptop, there is no problems...

Anyone who can help?
Image
jlaursen
 
Posts: 21
Joined: 15. August 2009 10:22

Re: Cant connect to my localhost!

Postby glitzi85 » 18. September 2011 21:33

Please check your hosts file (C:\Windows\system32\drivers\etc\hosts). Comment or remove all IPv6 Lines (those with : in it). The only really necessary line is this:
Code: Select all
127.0.0.1     localhost

If this does not help, please post the content (or at least the last few lines) of the Apache error log file (xampp\apache\logs\error.log).

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Cant connect to my localhost!

Postby jlaursen » 19. September 2011 20:46

Hello

Thanks, for some reason my hosts file did not contain that line, thats now fixed and ive rebooted. Still not working, so here for your request is my error log:

http://pastebin.com/G2LA817m
Image
jlaursen
 
Posts: 21
Joined: 15. August 2009 10:22

Re: Cant connect to my localhost!

Postby hackattack142 » 19. September 2011 23:24

I have read that sometimes running the following from a command prompt (Start > Run > cmd) will fix that error:
Code: Select all
netsh winsock reset
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: Cant connect to my localhost!

Postby jlaursen » 20. September 2011 17:01

This is the result i get from this:

Code: Select all
The following helper DLL cannot be loaded: WSHELPER.DLL.
The following command was not found: winsock reset.
Image
jlaursen
 
Posts: 21
Joined: 15. August 2009 10:22

Re: Cant connect to my localhost!

Postby glitzi85 » 20. September 2011 18:04

Open the file xampp\apache\conf\extra\httpd-mpm.conf and look at the end of the file. There will find this block:

Code: Select all
<IfModule mpm_winnt_module>
    ThreadsPerChild      150
    MaxRequestsPerChild    0
    #Win32DisableAcceptEx
</IfModule>


Remove the hash (#) in front of Win32DisableAcceptEx, save the file and restart Apache.

glitzi
User avatar
glitzi85
 
Posts: 1920
Joined: 05. March 2004 23:26
Location: Dahoim

Re: Cant connect to my localhost!

Postby Sharley » 20. September 2011 18:24

glitzi85 wrote:Open the file xampp\apache\conf\extra\httpd-mpm.conf and look at the end of the file. There will find this block:
Code: Select all
<IfModule mpm_winnt_module>
    ThreadsPerChild      150
    MaxRequestsPerChild    0
    #Win32DisableAcceptEx
</IfModule>
Remove the hash (#) in front of Win32DisableAcceptEx, save the file and restart Apache.
glitzi

Hi glitzi
Perhaps you may want to read the OP's other topic as most things related to his issue were covered by you and I already.
viewtopic.php?f=16&t=48220

It may need another approach to help find the solution ( is it perhaps OS related or some infection perhaps? ).
Could it be related to the external drive permissions if it networked etc. etc. ?
Best wishes. :)

@jlaursen
Perhaps restore the missing dll and see if it helps solve the mystery:

These Google search results will help finding a replacement for the lost dll which seems to be a common fault.

Good luck :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Cant connect to my localhost!

Postby jlaursen » 20. September 2011 19:33

I do Belive its my OS that has problems. No matter what drive, including the c drive it wornt work. I'll try to get the .dll file as soon as I get my Internet back up. It's really unstable ATM.

*off topic*
Would it be possible to make a torrent file of the new xampp version? My Internet is too unstable to download such big files. For some reason it screws up when there is missing around 10mb of the file.
Image
jlaursen
 
Posts: 21
Joined: 15. August 2009 10:22

Re: Cant connect to my localhost!

Postby Sharley » 20. September 2011 19:42

*off topic*
Would it be possible to make a torrent file of the new xampp version? My Internet is too unstable to download such big files. For some reason it screws up when there is missing around 10mb of the file.
Use the 7z version and extract it just like a zip file - 7zip is a free program.

Do a search for download manager and install one which will help greatly with bad connections as they usually keep downloading using a technique that will auto resume the download, ideal for bad connections, believe me I know first hand as I only have a dial-up.
I use this free download manager:
http://www.flashget.com/index_en.html


Remember if you get the dll and do the winsock fix it may help your Internet connection.

Also do a complete virus scan of your PC and also use a good malware app like Malwarebytes' (free).
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Cant connect to my localhost!

Postby jlaursen » 20. September 2011 19:59

I have winRAR, which also supports 7zip

And will definitely try the 7zip version, and regarding the dll, it appears to already exists, and it wornt let me replace the new one with the other one... not even sure if its safe?

And regarding my internet, i dont think it'll help... my whole area got the same problem :S
Image
jlaursen
 
Posts: 21
Joined: 15. August 2009 10:22

Re: Cant connect to my localhost!

Postby jlaursen » 21. September 2011 13:03

Just got the .7zip file, but it appears to still not be working

Here is my error log:

http://pastebin.com/1SWa7Lne


And yes... did disable the AcceptEX() thingy...

*Sorry for double post*
Last edited by jlaursen on 21. September 2011 13:21, edited 1 time in total.
Image
jlaursen
 
Posts: 21
Joined: 15. August 2009 10:22

Re: Cant connect to my localhost!

Postby Sharley » 21. September 2011 13:21

I hope it does solve the mystery and I would be interested to know the outcome.

Good luck :)
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: Cant connect to my localhost!

Postby jlaursen » 23. September 2011 21:29

I've just re-installed my OS, and XAMPP seems to be working now! So, it was an OS problem

I'd like to say thanks to all who have helped!
Image
jlaursen
 
Posts: 21
Joined: 15. August 2009 10:22

Re: Cant connect to my localhost!

Postby Sharley » 23. September 2011 21:34

That really is good news indeed, it had to be something that we could not replicate for you.

At last you can move forward and enjoy what XAMPP has to offer.

Good luck and my best wishes. :D
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 76 guests