$_server (http_user_agent etc.)

Problems with the Windows version of XAMPP, questions, comments, and anything related.

$_server (http_user_agent etc.)

Postby Bjh83 » 15. September 2011 18:31

I got problems with http_user_agent (and more..) when i use it on xampp. I have tried to find a solution other places but people does'nt seem to know it, so i am trying to see if people around here can help me.....

When i use it the page is blank..... Nothing happens.
Bjh83
 
Posts: 4
Joined: 15. September 2011 18:18

Re: $_server (http_user_agent etc.)

Postby Altrea » 15. September 2011 18:38

case sensitivity?

$_server['http_user_agent'] != $_SERVER['HTTP_USER_AGENT']
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: $_server (http_user_agent etc.)

Postby Bjh83 » 15. September 2011 18:43

Anybody who knows $_SERVER[HTTP_USER_AGENT]? :(
Bjh83
 
Posts: 4
Joined: 15. September 2011 18:18

Re: $_server (http_user_agent etc.)

Postby Altrea » 15. September 2011 18:46

I want to help you, but you have to give much more information!

- Is your display_errors setting activated and error_reporting minimum E_ALL?
- how does your sourcecode look like?
- What problem do you have with $_SERVER['HTTP_USER_AGENT']?
- Have you read the php.net documentation for $_SERVER?
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64

Re: $_server (http_user_agent etc.)

Postby Bjh83 » 15. September 2011 19:12

I have taken look at it but i have encountered something.. Ill have to wait explaining it till tomorrow. Maybe around 9.30-10.00 tomorrow..... I may have solved the problem on my Nas but xampp wont run php files but opens it so the source code can be read and php in html files is'nt displayet. I Will take a look at it before i tell you whats wrong.... Sorry....
Bjh83
 
Posts: 4
Joined: 15. September 2011 18:18

Re: $_server (http_user_agent etc.)

Postby Bjh83 » 16. September 2011 09:32

i have solved the problem on my nas, and file association may result in an error when i run php-files from webdav(it opens the file in ie etc. so the files can be read instead of runned.
i have opend the file association program in windows but i can´t un-check "allways run this file in the selected program"
Bjh83
 
Posts: 4
Joined: 15. September 2011 18:18

Re: $_server (http_user_agent etc.)

Postby Altrea » 16. September 2011 11:56

Bjh83 wrote:when i run php-files from webdav(it opens the file in ie etc. so the files can be read instead of runned.

Sure. That's the sense of webDAV
We don't provide any support via personal channels like PM, email, Skype, TeamViewer!

It's like porn for programmers 8)
User avatar
Altrea
AF Moderator
 
Posts: 8286
Joined: 17. August 2009 13:05
XAMPP version: several
Operating System: Windows 10 Pro x64


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 43 guests