i have a funny error and i cant find the solution

Problems with the Windows version of XAMPP, questions, comments, and anything related.

i have a funny error and i cant find the solution

Postby q2501 » 01. September 2011 04:54

my system of computer is 32bit wins xp when i connect to the internet the mysql is able to running but once i disconnect the internet and no connect to any network the phpmyadmin has a eroor 2002
and mysql database is deactivated. plz hlep i dont have any firewall
q2501
 
Posts: 7
Joined: 14. June 2011 23:06

Re: i have a funny error and i cant find the solution

Postby hackattack142 » 01. September 2011 13:43

It sounds like it might not be binding to localhost by default. You could try opening xampp/mysql/bin/my.ini (or my.cnf whichever you have), going under the [mysqld] section, and adding:
Code: Select all
bind-address="127.0.0.1"
on a new line.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: i have a funny error and i cant find the solution

Postby charles.stricklin » 10. September 2011 11:45

hackattack142 wrote:It sounds like it might not be binding to localhost by default. You could try opening xampp/mysql/bin/my.ini (or my.cnf whichever you have), going under the [mysqld] section, and adding:
Code: Select all
bind-address="127.0.0.1"
on a new line.


That appears to have fixed my problem. Thanks!
charles.stricklin
 
Posts: 1
Joined: 08. September 2011 06:22


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 42 guests