apache wont start!

Problems with the Windows version of XAMPP, questions, comments, and anything related.

apache wont start!

Postby yoni101kessler » 30. August 2011 13:09

hello, ive just installed the new version of xampp, and in the control pannel i get green- running for mysql but not for the apache.
when i try to start the apache i get the message "apache started port 80", but nothing works and i cant get to http://localhost/...
i have windows 7

plls helpp!
thank u!
Last edited by yoni101kessler on 30. August 2011 14:16, edited 1 time in total.
yoni101kessler
 
Posts: 8
Joined: 30. August 2011 13:04

Re: apache wont start!

Postby yoni101kessler » 30. August 2011 13:31

after reading the last apache problem notes, I can add some more info:
the apache\logs directory is empty....
and when i try to open: c:\xampp\apache\bin\httpd.exe the command window was popped but only for a seccond with some error massage i guess, i cant read it since its closing itself immediatly,
what is the problem??
yoni101kessler
 
Posts: 8
Joined: 30. August 2011 13:04

Re: apache wont start!

Postby JonB » 30. August 2011 13:54

well what was the 'error messgae I guess' ???

Try opening a command window

Change folder to c:\xammp\apache\bin
cd c:\xampp\apache\bin
start Apache
httpd.exe

write down any error messages

Also please post the tail end of your apache error log
c:\xampp\apache\logs\error.log

Good Luck
8)



yrwts
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: apache wont start!

Postby yoni101kessler » 30. August 2011 14:15

thanks for replying!

the message i got:
c:\xampp\apache\bin>httpd.exe
(OS 10048)■■ßπ°Ω δ∞∞ εσ·° ∞Σ∙·ε∙ ⌠≥φ ατ· ß∞ßπ ßδ∞ δ·σß· Socket (⌠°σΦσ≈σ∞/δ·σß· °
∙·/Θ÷ΘαΣ). : make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

c:\xampp\apache\bin>

and the c:\xampp\apache\logs\ folder is empty....

whats next??
yoni101kessler
 
Posts: 8
Joined: 30. August 2011 13:04

Re: apache wont start!

Postby JonB » 30. August 2011 14:28

(OS 10048) - means the port/socket is in use

After you have installed the new Control Panel3

Run net-stat

See what application is running on port 80. You will have to either disable that application or direct it to use a different port.

Skype and IIS are the leading contenders :!:

Good luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: apache wont start!

Postby yoni101kessler » 30. August 2011 14:38

yeah, as u said skype uses the ports 80 and 443,
how can i change the port for the apache? and how do i know which port i can use for it?
yoni101kessler
 
Posts: 8
Joined: 30. August 2011 13:04

Re: apache wont start!

Postby JonB » 30. August 2011 15:09

change the port in Skype, don't cause yourself problems with Apache

tools > options > advanced > connections

Use Port 16210

leave use ports 80 & 443 as alternates checked.

Make it so Skype does not auto-start on Windows Load,
re-boot

You should be able to start XAMPP now.


OTHERWISE, you will have to append port numbers to everything you do in Apache (bad concept)

Good luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: apache wont start!

Postby yoni101kessler » 30. August 2011 16:40

thank u! it works, i can use both skype and the apache,
but now i have a new BIG problem!
since i made the changes and restrart, the computer's sound went off!
i have no sound at all,
when i look at the speakers tab at the bootom of the desktop, it seems like its working, but i got no sound!
help!

what could be the problem?!
yoni101kessler
 
Posts: 8
Joined: 30. August 2011 13:04

Re: apache wont start!

Postby JonB » 30. August 2011 17:22

Well - That is weird.

Did you un-install any programs? Checky very well any cables?

From a Windows debugging point of view, you should look at (I think - I'm on a Linux workstation at the moment) -

Control Panel > Hardware & Sound > Manage Audio Devices

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 62 guests