cannot access localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Re: cannot access localhost

Postby JonB » 29. August 2011 15:57

If the error log does not exist -

It means that Apache cannot start at all. This means its blocked (firewall/OS flagged), or the executable (httpd.exe) cannot load - corrupt?.

skip using the XAMPP Control Panel for a moment.

Open a Command Prompt

cd c:\xampp\apache\bin
httpd.exe

you will get some kind of error - whatever that error is, that's the problem

If you DON'T get any error, just the httpd.exe still showing, open the XAMPP control panel, you should find Apache is running. (it will stop if you close the command window).

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby gsdoby » 29. August 2011 19:34

Oops Apparently the error log does exist. I must have looked in the wrong place. Here are its contents[Fri Aug 26 09:29:48 2011] [notice] Digest: generating secret for digest authentication ...
[Fri Aug 26 09:29:48 2011] [notice] Digest: done
[Fri Aug 26 09:29:49 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Fri Aug 26 09:29:49 2011] [notice] Server built: Oct 18 2010 01:58:12
[Fri Aug 26 09:29:49 2011] [notice] Parent: Created child process 4760
Apache server shutdown initiated...
Digest: generating secret for digest authentication ...
[Fri Aug 26 09:29:50 2011] [notice] Digest: done
[Fri Aug 26 09:29:51 2011] [notice] Child 4760: Child process is running
[Fri Aug 26 09:29:51 2011] [notice] Child 4760: Acquired the start mutex.
[Fri Aug 26 09:29:51 2011] [notice] Child 4760: Starting 150 worker threads.
[Fri Aug 26 09:29:51 2011] [notice] Child 4760: Starting thread to listen on port 443.
[Fri Aug 26 09:29:51 2011] [notice] Child 4760: Starting thread to listen on port 80.
[Fri Aug 26 09:29:54 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Fri Aug 26 09:29:54 2011] [notice] Child 4760: Exit event signaled. Child process is ending.
[Fri Aug 26 09:29:55 2011] [notice] Child 4760: Released the start mutex
[Fri Aug 26 09:29:56 2011] [notice] Child 4760: All worker threads have exited.
[Fri Aug 26 09:29:56 2011] [notice] Child 4760: Child process is exiting
[Fri Aug 26 09:29:56 2011] [notice] Parent: Child process exited successfully.
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 29. August 2011 20:51

OK
Apache is STARTING, its also shutting itself down immediately.

[Fri Aug 26 09:29:51 2011] [notice] Child 4760: Starting thread to listen on port 80.
[Fri Aug 26 09:29:54 2011] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Fri Aug 26 09:29:54 2011] [notice] Child 4760: Exit event signaled. Child process is ending.
[Fri Aug 26 09:29:55 2011] [notice] Child 4760: Released the start mutex
[Fri Aug 26 09:29:56 2011] [notice] Child 4760: All worker threads have exited.
[Fri Aug 26 09:29:56 2011] [notice] Child 4760: Child process is exiting
[Fri Aug 26 09:29:56 2011] [notice] Parent: Child process exited successfully.




Here's a possible fix:

Look for the directive Win32DisableAcceptEx in the \xampp\apache\extra\httpd-mpm.conf file. Does it have a # before it like this??? :shock:

Code: Select all
# WinNT MPM
# ThreadsPerChild: constant number of worker threads in the server process
# MaxRequestsPerChild: maximum  number of requests a server process serves
# Win32DisableAcceptEx: Use accept() rather than AcceptEx() to accept network connections
<IfModule mpm_winnt_module>
    ThreadsPerChild      150
    MaxRequestsPerChild    0
    #Win32DisableAcceptEx
</IfModule>


Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby gsdoby » 30. August 2011 03:41

could not find the file \xampp\apache\extra\httpd-mpm.conf, I do not have a folder titled extra.

Someone recommended I run Http.exe from a command line. I did and got the following message in the control panel

10:27:45 PM [main] Initializing main
10:27:45 PM [main] Windows version: 6.1 (build 7600)
10:27:45 PM [main] Xampp version: 1.7.4
10:27:45 PM [main] Control center version: 3.0.2 [ Compiled: Jul 21th 2011 - build #1 ]
10:27:45 PM [main] Running as admin - good!
10:27:45 PM [main] Working with basedir: "c:\xampp\"
10:27:45 PM [main] Initializing moduls
10:27:45 PM [apache] "c:\xampp\apache\bin\httpd.exe" seems to be running on port 80?
10:27:45 PM [apache] "c:\xampp\apache\bin\httpd.exe" seems to be running on port 443?
10:27:45 PM [main] Starting check-timer
I was then able to access remote host but appears I have to leave command line open. Thanks for all your assistance . It appears there is still a problem but it is running.

netscan shows httpd.exe running on ports 80 and 443 pid 3800 and 540 and address 0.0.0.0
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 30. August 2011 04:55

\xampp\apache\extra\httpd-mpm.conf


OOOPS :oops:

should be

\xampp\apache\conf\extra\httpd-mpm.conf

If the line is not commented out, do so now (add a # before the Win32DisableAcceptEx)

------------------------------------------------------------
On the real basic issue - IF you can start httpd.exe as I suggested from the Command Line AND
When you are using the new Control Panel 3, it still WON'T start or stop within the Control Panel == you may have found some type of bug. So please try it now with the Control Panel and let me know what happens.

thanks



Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby gsdoby » 30. August 2011 14:23

The line you mentioned in the extras folder was already commented out.
I can start and stop apache from a control line but not from the control panel
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 30. August 2011 14:32

Ok thanks

just to make sure, you are running the new Control Panel 3, right??? xampp-control3.exe

If so, I will point Inspector Clouseau (the author of the Control Panel) at this topic and see what he thinks.

Thanks for the reports and Good Luck

8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby gsdoby » 30. August 2011 17:11

yes I am using control panel 3
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 30. August 2011 17:25

OK, thanks - I posted a note in the Control Panel 3 topic.

viewtopic.php?f=16&t=46743

thanks and Good Luck with your project.
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby gsdoby » 31. August 2011 19:21

OK so today I am able to go to my local host page when I try to go to the phpadmin page I get an error 2002 server not responding or local server not configured. I was able to go to this page yesterday.
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 31. August 2011 21:41

Did you start XAMPP Apache/MySQL first???

:wink:
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby hackattack142 » 01. September 2011 02:00

Regarding localhost access, I have read in the past that AVG can cause issues with localhost access/servers. You could try playing with the LinkScanner or Surf Guard to see if it is causing an issue.

With the control panel, you mentioned that you were running it with the Service checkbox enabled. Does it work if you uncheck that box? The difference is how the program is invoked. If it is unchecked, it directly calls the application like you did on the command line. If it is checked, it would be equivalent to running "net start Apache2.2" at the command line when you hit the Start button given the service installed correctly. The service invokes a command like "C:\xampp\apache\bin\httpd.exe" -k runservice.

Also, assuming you had apache/mysql running first, if you still have problems accessing mysql from phpmyadmin, I usually have to manually specify a bind address on a fresh install for mysql before it works correctly for me. You could try opening xampp/mysql/bin/my.ini (or my.cnf whichever you have), going under the [mysqld] section, and adding
Code: Select all
bind-address="127.0.0.1"
on a new line.
XAMPP Control Panel Developer
Latest CP: viewtopic.php?f=16&t=48932
hackattack142
 
Posts: 703
Joined: 20. May 2011 23:29
Operating System: Windows 7 Ultimate SP1 64-Bit

Re: cannot access localhost

Postby gsdoby » 01. September 2011 21:29

I unchecked the service box and it allowed me to start from the control panel. I did not have mysql started when I tried to go to phpadmin. That takes care of that issue. One more question and I will try to leave you alone. I had a message saying I did not have a password for my user root. I went in to the priviledge page and set one. I left local host and tried to reenter and received a message cannot connect invalid settings. Should I list this under a new post or topic. to close out this thread.
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby zardiw » 01. September 2011 21:45

What else is new........and Welcome to the club..z
zardiw
 
Posts: 19
Joined: 01. September 2011 20:06

Re: cannot access localhost

Postby JonB » 01. September 2011 21:49

LOL - thanks for asking -

I'll simply say - you probably need to fix config.inc.php in (\xampp\phpmyadmin)

These topics covers 'most issues' -

http://rudyegenias.wordpress.com/2006/0 ... -database/

http://rudyegenias.wordpress.com/2006/0 ... -database/

IF you don't fix it right away - then start a new topic -

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Previous

Return to XAMPP for Windows

Who is online

Users browsing this forum: No registered users and 68 guests