cannot access localhost

Problems with the Windows version of XAMPP, questions, comments, and anything related.

cannot access localhost

Postby gsdoby » 22. August 2011 21:58

I downloaded Xampp today to install. I Have windows 7. I initially downloaded the installer version and got a check status failure message so I uninstalled and downloaded the zip version. I went to my browser to go to the local host page and was told I could not connect. Any Idea what the problem is All help will be appreciated
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby Sharley » 23. August 2011 02:39

gsdoby wrote:Any Idea what the problem is
There is not enough specific detail or error messages in your post that could possibly help lead to a solution for your issue.

See if you can follow these instructions which may help with a successful XAMPP installation:
viewtopic.php?p=179699#p179699
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: cannot access localhost

Postby gsdoby » 23. August 2011 14:52

I will try to provide more detail in this post. I tried several times to upload with the installer. When I did this I got a check status failure 3 message in the control panel. I found a post that recommended downloading the zip file. This is what I did yesterday. I unzipped the files to me C: directory. I then went to my web browser and typed localhost. I got a 403 error message
I hope this provides enough information
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 23. August 2011 16:31

Hi

Look in your hosts file, and see if there is an entry for

localhost 127.0.0.1

If there is not, add that entry, reboot and test XAMPP.

http://helpdeskgeek.com/windows-7/windows-7-hosts-file/

If that is not a fix (you should do this anyway really)

First -

Download and install the new XAMPP control Panel 3. You unzip teh file, then copy XAMMP-control3.exe to the root folder of your XAMPP installation - proabably c:\xampp The new Control Panel has much better diagnostics and cures some faults/errors in the prior version (which came with XAMPP 1.7.4)
the latest version is found in this thread:

viewtopic.php?f=16&t=46743

Second after this is done, start Apache in the new control panel and see what happens. Do you get a 'green light' (running)? If yeas, and if you type in localhost and still get nothing, its either a permissions issue or soemthing is wrong with teh installation. you should go directly to the XAMPP splash page where you select the language, and then to the XAMMP opening page.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby gsdoby » 23. August 2011 23:44

Thanks for the assistance.
I checked my hosts file and the 127.0.0.1 host was there
I installed the new control panel with the following results
A green check in the svc box for apache
A gray check in the svc box for mysql and filezilla
all button show start in the action column
I clicked on start apache and was asked by avg software if ok to start
the follow text in the box below appeared.
4:37:32 PM [main] Initializing main
4:37:32 PM [main] Windows version: 6.1 (build 7600)
4:37:32 PM [main] Xampp version: 1.7.4
4:37:32 PM [main] Control center version: 3.0.2 [ Compiled: Jul 21th 2011 - build #1 ]
4:37:32 PM [main] Running not as admin! This will work for all application stuff, but whenever you do
4:37:32 PM [main] something with services there will be a security dialogue! So think about running
4:37:32 PM [main] this application with administrator rights!
4:37:32 PM [main] Working with basedir: "c:\xampp\"
4:37:32 PM [main] Initializing moduls
4:37:32 PM [main] Starting check-timer
4:38:12 PM [apache] Starting apache service...
I still cannot access local host
Now getting a message server not found
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 24. August 2011 08:39

Well, now we 'know' Apache is running -

try entering 127.0.0.1 for an address. also trying disabling your firewall.

There are a couple of possibilities.

Check the net-stat and see if httpd.exe is now listening on port 80.

If it is, there is EITHER a redirection still occuring on localhost
(are you running any ad-blocking software or toolbars?)
OR localhost is being blocked at a port level - usually a firewall.

The run as admin is needed to make things into services. If you want to do that , right click on xammp-control3.exe and use the run as admin option. On Vista and Win7 the account owner is NOT truly an administrator. There is a way to get an administrator login, You have to activate the administrator account. The easiest is with the CMD window and this command:

Start the Command Window with the Run as Adminstrator option
Issue this command
net user administrator /active:yes

You can now logout or restart and there will be an administrator login and desktop
http://www.petri.co.il/enable-the-windo ... ccount.htm

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby gsdoby » 24. August 2011 14:32

entering 127.0.0.1 as an address did not work

When I click on start for apache a user account control box appears asking me if I want a program called net command to run. apache tries to start but does not actually start. If I start mysql the action box changes to stop

net-stat DOES NOT SHOW httpd.exe for any port. port 80 does not appear anywhere.

I hope makes my situation clearer. I am very grateful for your assistance
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 24. August 2011 16:05

OK, it looks like Apache is not starting at the moment. Wasn't it starting a day or so ago???

Did you use the 'run as administrator' option to start 'xampp-control3.exe"???

One way to determine if the problem is related to the Windows OS permissions is to enable the Administrator account and actually run the desktop as the Administrator.

when logged in, In All Programs, Accessories > find 'Command Prompt' Right click, 'Run as Administrator'

in the Command Box type "net user administrator /active:yes" (without the quotes)

You should get a response like 'the command was successful' or something close.

You can now log out, and the Administrator account will be available for login. It will build you a desktop - (if you have not used it before). If it wants a password, it will be the password of the Owner account (the first logon that was setup on the machine)


This way when you are working, you will ALWAYS be the administrator - at least until you get things sorted.

BTW, if net-stat doesn't show anything for Port 80 - my 'guess' is that port 80 has been disabled in some fashion.

I had to loan my Windows 7 box that has XAMPP 1.7.4 installed to a colleague. we have a couple machines down right now. I'm working on my Linux desktop (which HAS XAMPP 1.7.4, but its the Linux variant, and not useful for debugging this) I'll have to test the net-stat thing later to see what is going on.

.Good Luck
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby gsdoby » 24. August 2011 23:24

Was able to set up and log in as administrator.

No I did not actually have apache started only that it was attempting to start
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby gsdoby » 25. August 2011 16:59

Now that I have set up to run as the administrator is there anything I should check in the Windows permissions?
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 25. August 2011 17:36

hI

Did you try running xampp-control3.exe? What happened?

Did you use the net-stat?

this is what I see on one of my machines with XAMMP 1.7.4, when I start Apache and MySQL using the control panel.

Image

What does the net-stat show for Ports 80 and 443?
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby Sharley » 26. August 2011 03:00

Hello Jon,
Please check your PM.
Best wishes.
Last edited by Sharley on 26. August 2011 04:01, edited 2 times in total.
User avatar
Sharley
AF Moderator
 
Posts: 3316
Joined: 03. October 2008 05:10
Location: Yeppoon, Australia Time Zone: GMT/UTC+10
Operating System: Win 7 Pro 32bit/XP Pro SP3

Re: cannot access localhost

Postby gsdoby » 26. August 2011 03:05

I get a status changed message for mysql but not apache
Net stat shows nothing for ports 80 and 443
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Re: cannot access localhost

Postby JonB » 26. August 2011 04:54

Hi -
Ok, what we should do is try to start Apache (even if not successful)

After you make the attempt, check the Apache error log. It's \xampp\apache\logs\error.log, usually.

If there are messages that tell you what version, etc : (like these) then Apache is trying to start -
Code: Select all
[Thu Aug 25 23:45:06 2011] [notice] Digest: generating secret for digest authentication ...
[Thu Aug 25 23:45:06 2011] [notice] Digest: done
[Thu Aug 25 23:45:10 2011] [notice] Apache/2.2.17 (Win32) mod_ssl/2.2.17 OpenSSL/0.9.8o PHP/5.3.4 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Thu Aug 25 23:45:10 2011] [notice] Server built: Oct 18 2010 01:58:12
[Thu Aug 25 23:45:10 2011] [notice] Parent: Created child process 5744
[Thu Aug 25 23:45:12 2011] [notice] Digest: generating secret for digest authentication ...
[Thu Aug 25 23:45:12 2011] [notice] Digest: done
[Thu Aug 25 23:45:14 2011] [notice] Child 5744: Child process is running
[Thu Aug 25 23:45:14 2011] [notice] Child 5744: Acquired the start mutex.
[Thu Aug 25 23:45:14 2011] [notice] Child 5744: Starting 150 worker threads.
[Thu Aug 25 23:45:14 2011] [notice] Child 5744: Starting thread to listen on port 443.
[Thu Aug 25 23:45:14 2011] [notice] Child 5744: Starting thread to listen on port 80.


(the above is a successful start on XAMPP 1.7.4)

Assuming it 'errors out' there will be an error noted right in the middle there somewhere, along with an explanatory code - If that's the case, copy and paste that info into your post. That will tell us probably what to fix.

IF the error.log is EMPTY or doesn't exist in \xampp\apache\logs - then Apache's executable (httpd.exe)is blocked or has an error that keeps it from executing.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: cannot access localhost

Postby gsdoby » 26. August 2011 14:28

The error log does not exist
gsdoby
 
Posts: 19
Joined: 08. August 2011 18:13

Next

Return to XAMPP for Windows

Who is online

Users browsing this forum: Gharas and 66 guests