Apache server stops after 2-3 sec..

Problems with the Windows version of XAMPP, questions, comments, and anything related.

Apache server stops after 2-3 sec..

Postby arhimidis64 » 19. August 2011 13:17

Hi!I have installed xampp,and when i'm trying to start apache,every time stops after 2-3 sec.All other servers are running fine.It's not the 80 port that uses apache..I'm runing on Windows 7 64 bit.Please help me..Thnks!
arhimidis64
 
Posts: 3
Joined: 19. August 2011 13:12

Re: Apache server stops after 2-3 sec..

Postby JonB » 19. August 2011 15:47

For starters:

Look in the Apache error log -
\xampp\apache\logs

NOTE: XAMPP's Apache configuration now ALSO uses port 443 (https) when it starts.

If you haven't done it already, DL the new XAMPP Control Panel 3, and palce its executable in the root of your XAMMP installation. That's usually C:\XAMPP

find it here:
viewtopic.php?f=16&t=46743

It has better controls, and provides far more diagnostic info. :shock:

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache server stops after 2-3 sec..

Postby arhimidis64 » 22. August 2011 16:38

From the log...


[Mon Aug 22 18:37:40 2011] [notice] Digest: generating secret for digest authentication ...
[Mon Aug 22 18:37:40 2011] [notice] Digest: done
[Mon Aug 22 18:37:40 2011] [notice] Apache/2.2.14 (Win32) DAV/2 mod_ssl/2.2.14 OpenSSL/0.9.8l mod_autoindex_color PHP/5.3.1 mod_apreq2-20090110/2.7.1 mod_perl/2.0.4 Perl/v5.10.1 configured -- resuming normal operations
[Mon Aug 22 18:37:40 2011] [notice] Server built: Nov 11 2009 14:29:03
[Mon Aug 22 18:37:40 2011] [crit] (22)Invalid argument: Parent: Failed to create the child process.
[Mon Aug 22 18:37:40 2011] [crit] (OS 6)Ο δείκτης χειρισμού δεν είναι έγκυρος. : master_main: create child process failed. Exiting.
[Mon Aug 22 18:37:40 2011] [notice] Parent: Child process exited successfully.


And i tryed XAMPP Control Panel 3 but nothing...
arhimidis64
 
Posts: 3
Joined: 19. August 2011 13:12

Re: Apache server stops after 2-3 sec..

Postby JonB » 22. August 2011 16:54

You need to see what is running on ports 80 and 443
You can also look here:
http://bravo.newnetenterprises.com/word ... art-helppp

To do this peeking - you can use the XAMPP control panel's net-stat option (even if Apache isn't running)

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache server stops after 2-3 sec..

Postby arhimidis64 » 22. August 2011 16:57

both ports are "free"...
arhimidis64
 
Posts: 3
Joined: 19. August 2011 13:12

Re: Apache server stops after 2-3 sec..

Postby JonB » 22. August 2011 19:26

(OS 6)Ο δείκτης χειρισμού δεν είναι έγκυρος <== need a translation

if the translation is "[crit] (OS 6)The handle is invalid"

The (OS 6) [I believe] indicates the error is propagating from the Operating System and the problem relates to an exe or DLL that is not loading. (because Apache can't find it)

If you have firewall software or an internet 'suite' installed, try disabling it and seeing if that does the trick. If that enables Apache, then you will need to learn how to make httpd.exe (or whatever else is blocked) an internet-enabled (safe) application. In particular, Comodo does not see Apache (httpd.exe) as a safe file -- others may auto-block applications that use ports 80 or 443.

A few questions also:

First - where did you install XAMPP?? (what drive and folder)

Second - what method did you use to install - the installer or the zip file??

Third - Did you make any adjustments to php.ini???

I Googled:
Apache master_main: create child process failed. OS 6

read the end of this one -
http://serverfault.com/questions/106790 ... zilla-does

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7

Re: Apache server stops after 2-3 sec..

Postby x3ro » 23. August 2011 10:41

hey there,
i got exactly the same error as arhimidis64 did.
I'm confused cause i am running xampp since april this year.

Changed nothing in the php.ini... firewall is just windows firewall (windows 7)... maybe some windows updates are responsible for the problem?
I try to work off the link JonB posted.


greetz

//edit:
- it is not skype nor any other port 80 thing
- xampp is installed to c:\xampp
- there aren't any services running like "Worldwide web services or Web Deployment services"
- i copied the php.ini from php folder to apache/bin

what about the httpd.conf file? i only located a httpd.exe (in apache/bin ) ?

//edit part2:

i finally found the httpd.conf and commented the "Include "conf/extra/httpd-perl.conf"" part out - and apache keeps running (yeah)

--> but what about the httpd-perl.conf? why is there an error out of the blue? can i fix it?
x3ro
 
Posts: 1
Joined: 23. August 2011 10:34

Re: Apache server stops after 2-3 sec..

Postby JonB » 23. August 2011 15:36

maybe some windows updates are responsible for the problem?


The same thought ran through my mind.

If turning of mod_perl fixed it, it means one of the dlls invloved is either "not where it belongs", is corrupt, or has been falgged by the OS or a firewall as unsafe.

that's what the OS 6 is about. 'the file handle for a called executable or library is invalid) And that's why in the other cases, turning off PHP extensions (dlls) worked.

Good Luck
8)
User avatar
JonB
AF Moderator
 
Posts: 3210
Joined: 12. April 2010 16:41
Location: Land of the Blazing Sun
Operating System: Windows XP/7 - Fedora 15 1.7.7


Return to XAMPP for Windows

Who is online

Users browsing this forum: JJ_Tagy and 37 guests